iSCSI root fails: open-iscsi tries to configure networking prior to network devices being detected

Bug #1066945 reported by Patrick Domack on 2012-10-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
Critical
James Page
Quantal
Critical
James Page

Bug Description

Testing on Quantal Final RC's

installing iso to iscsi root fails to boot, and is stuck in bootloader (busybox initramfs shell)

Last screen output is:

Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... ipconfig: no devices to configure
ipconfig: no devices to configure
ipconfig: no devices to configure
ipconfig: no devices to configure
ipconfig: no devices to configure
ipconfig: no devices to configure
ipconfig: no devices to configure
ipconfig: no devices to configure
/scripts/local-top/iscsi: .: line 505: can't open '/run/net-*.conf'
done.
[ 2.260189] e1000: Intel(R) Pro/1000
[ 2.287678] Floppy drive(s): fd0 is 1.44M
[ 2.302014] FDC 0 is a post-1991 82077
[ 2.389848] eth0 NIC Link is Up 1000Mbps
Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
  - Check rootdelay=
  - Check root=
 - Missing modules (cat /proc/modules)
ALERT! /dev/disk/by-uuid/bbc5a7be-...... does not exist.
Dropping to a shell!

Used to be, to work around this issue, I could just run /scripts/local-top/iscsi manually, since the nic seems to get setup AFTER the local-top scripts run, but that isn't working anymore, instead I get the below:

IP-Config: eth0 hardware address .......
IP-Config: eth0 complete (dhcp from 192.168.x.x):
  address: 192.168.x.x broadcast: 192.168.x.x netmask: 255.255.255.0
  gateway: 192.168.x.x dns0: 192.168.x.x dns1: 192.168.x.x
  domain: xxx
  rootserver: 192.168.x.x rootpath:
[ 168.204516] Loading iSCSI transport class v2.0-087.
[ 168.212114] iscsi: registered transport (tcp)
iscsistart: TargetName not set. Exiting iscsistart

iscsistart: TargetName not set. Exiting iscsistart

(initramfs)

I have also check /etc/iscsi.initramfs and /etc/initiatorname.iscsi and the settings in there are good.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1066945

tags: added: iso-testing
Patrick Domack (patrickdk) wrote :

Installing open-iscsi from proposed fixed the second issue, but first issue about iscsi script setting up nic before nic is found via udev is still an issue.

James Page (james-page) wrote :

I was able to reproduce Patrick's first issue by switching my iscsi root kvm installs to use the e1000 driver instead of virtio.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
James Page (james-page) wrote :

OK - so sticking 'wait_for_udev' infront of the 'configure_networking' call in the iscsi local-top hook appears to resolve the issue so it looks like this is a udev timing problem with the e1000 card.

James Page (james-page) wrote :

In fact this is a regression from precise where exactly this happened.

Changed in debian-installer (Ubuntu):
importance: Undecided → Critical
status: Confirmed → In Progress
affects: debian-installer (Ubuntu Quantal) → open-iscsi (Ubuntu Quantal)
James Page (james-page) on 2012-10-17
summary: - iSCSI root fails
+ iSCSI root fails: open-iscsi tries to configure networking prior to
+ network devices being detected
Changed in open-iscsi (Ubuntu Quantal):
assignee: nobody → James Page (james-page)
Colin Watson (cjwatson) on 2012-10-17
Changed in open-iscsi (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.873-3ubuntu5

---------------
open-iscsi (2.0.873-3ubuntu5) quantal-proposed; urgency=low

  * Ensure all udev events have been processed before trying to configure
    iscsi networking in the initramfs (LP: #1066945):
    - debian/extra/initramfs.local-top: Restore wait_for_udev call before
      configure_networking to ensure network devices are present.
 -- James Page <email address hidden> Wed, 17 Oct 2012 12:37:43 +0100

Changed in open-iscsi (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers