"jue","que","xue" mapped to "jiong", "qiong", "xiong" in 14.04

Bug #1310346 reported by Tao Wang on 2014-04-20
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
open-gram (Ubuntu)
Undecided
Aron Xu
Trusty
Undecided
Aron Xu

Bug Description

OS: Ubuntu Desktop 14.04

When inputting Chinese by SunPinYin, I found following item are mapped in wrong way:

```
jue => jiong
que => qiong
xue => xiong
```

I found same issue at https://github.com/sunpinyin/sunpinyin/issues/31#issuecomment-12486150

And as the owner said, it might be 'dict.utf8' is not up to date.

It is an important bug, I have to switch to another IM for a workaround.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sunpinyin (Ubuntu):
status: New → Confirmed
Vanity Harmony (vanity-fr) wrote :

I tested sunpinyin by fcitx and ibus.
This bug appears in both input methods. So there may be no problem in the packages of fcitx and ibus.
For sunpinyin-data, there's no differences among raring, saucy and trusty.
This bug did not appear when I was in UBUNTU saucy, so I tried to use packages for saucy and tested. (sunpinyin-utils and libsunpinyin3)
The result is that the bug is because of the package named 'libsunpinyin3'.
I use all new packages except this 'libsunpinyin3'package. I use the libsunpinyin3_2.0.3+git20120607-1ubuntu1_amd64.deb instead. After this, sunpinyin is OK.

So I think there may be some problems in the package 'libsunpinyin3', 'libsunpinyin3_2.0.3+git20130507-1ubuntu1_amd64.deb'.

Changed in sunpinyin (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
Aron Xu (happyaron) wrote :

Updating dict.utf8 will fix this problem. I'll sync from Sid to Utopic soon, and see what to do is the minimal update for Trusty.

Aron Xu (happyaron) on 2014-05-06
Changed in sunpinyin (Ubuntu):
status: Confirmed → In Progress
Changed in sunpinyin (Ubuntu Trusty):
status: New → Triaged
Aron Xu (happyaron) on 2014-05-06
Changed in sunpinyin (Ubuntu):
status: In Progress → Fix Committed
Changed in sunpinyin (Ubuntu Trusty):
assignee: nobody → Aron Xu (happyaron)
Aron Xu (happyaron) on 2014-05-06
affects: sunpinyin (Ubuntu) → open-gram (Ubuntu)
Changed in open-gram (Ubuntu):
status: Fix Committed → Fix Released
Don Tai (dontai-canada) wrote :

Hi, I know I'm late in this thread, but doit (richangyongpin) 's script solved my "学” xue problem. I downloaded his script, saved it as resolve.sh, went to terminal and did a "sh resolve.sh" command. After approval it worked! Thanks doit (richangyongpin) . 谢谢.

I could not get through the Chinese in the GitHub link at the top. My Chinese is not that good.

Hello Tao, or anyone else affected,

Accepted open-gram into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-gram/0.1.22+20131212-0ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in open-gram (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Aron Xu (happyaron) on 2016-04-07
tags: added: verification-done verification-done-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-gram - 0.1.22+20131212-0ubuntu0.14.04.1

---------------
open-gram (0.1.22+20131212-0ubuntu0.14.04.1) trusty; urgency=medium

  * Fix wrong mapping in data (LP: #1310346, #1361764)

 -- Aron Xu <email address hidden> Fri, 18 Mar 2016 00:35:22 +0800

Changed in open-gram (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for open-gram has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers