OPAM 1.1.1-1build3 (utopic) is broken because compiled with an incompatible version of libdose3

Bug #1401346 reported by Louis Gesbert on 2014-12-11
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
opam (Ubuntu)
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

Opam 1.1 is broken when compiled with Dose >= 3.2.2, see https://github.com/ocaml/opam/issues/1683

I'd suggest upgrading the package to 1.2 (backport from vivid) or reverting to an older build/dose version.
Thanks

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in opam (Ubuntu):
status: New → Confirmed
Anil Madhavapeddy (avsm) wrote :

Just adding my support for backporting OPAM 1.2 from vivid rather than fixing OPAM 1.1, since the upstream OPAM package repository causes errors if `opam init` is run with OPAM 1.1.1.

summary: - Broken build on utopic due to incompatible version of libdose3
+ OPAM 1.1.1-1build3 (utopic) is broken because compiled with an
+ incompatible version of libdose3
Robie Basak (racb) wrote :

Presumably this is fixed in Vivid, since you're suggesting backporting from it? Marking as such.

See https://wiki.ubuntu.com/StableReleaseUpdates for the policy, rationale and procedure for updating Utopic. We prefer to backport a minimal patch to avoid regressions. But if this package is completely broken, perhaps the SRU team would consider a backport.

Changed in opam (Ubuntu):
status: Confirmed → Fix Released
Changed in opam (Ubuntu Utopic):
status: New → Confirmed
Louis Gesbert (louis-gesbert) wrote :

Thanks. Filling in the template from https://wiki.ubuntu.com/StableReleaseUpdates :

[Impact]

* `opam` will only work on first `init` and `install` commands, but break severely as soon as another action is attempted (upgrade, new install...) -- its state becomes broken and it's unusable unless you start from scratch.

* We don't have a simple patch for the bug, because the way we use the Dose library had been rewritten _before_ a change to Dose broke (older) OPAM's behaviour, and the cleaner rewrite did'nt trigger it -- indeed the breakage never happened in the upstream's timeline (which also explains how it was overlooked).

[Test Case]

`opam init; opam install lwt; opam install utop`: OPAM tries to reinstall packages that are already installed and breaks.

[Regression Potential]

* the new version, released in october, hasn't seen any important bugs
* for what it's worth, it's been included in the Debian Jessie freeze, with no issue so far
* no packages depend on OPAM as far as I know, so consequences are limited
* given the current state of the package, it can only get better

[Other Info]

In case pushing the newer version is really not an option, I'd even be in favor of having it pulled off utopic rather than left in the current state: it doesn't reflect on the quality of our software, and we had to include warnings about this bug in our troubleshooting pages.

Thanks for your time !

Louis Gesbert (louis-gesbert) wrote :

Any hope to get this fixed in any way ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers