oneconf-service crashed with KeyError in check_if_refresh_needed(): 'packages_checksum'

Bug #940710 reported by James Tait on 2012-02-25
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
Undecided
Didier Roche

Bug Description

This occurred after performing the usual daily package updates through Update Manager.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: oneconf 0.2.6.9
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CheckboxSubmission: dd3689fa6394f60ec14dbe98d0bab891
CheckboxSystem: b633b4f40868d491c2ae5b50030ce6f3
CrashCounter: 1
Date: Sat Feb 25 00:18:02 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/share/oneconf/oneconf-service
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/oneconf/oneconf-service
PythonArgs: ['/usr/share/oneconf/oneconf-service']
SourcePackage: oneconf
Title: oneconf-service crashed with KeyError in check_if_refresh_needed(): 'packages_checksum'
UpgradeStatus: Upgraded to precise on 2012-01-13 (42 days ago)
UserGroups: adm admin cdrom dialout disk libvirtd lpadmin plugdev sambashare vde2-net

James Tait (jamestait) wrote :
tags: removed: need-duplicate-check
Changed in oneconf (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

@James: can you please ping me on IRC? Do you reproduce it reliably? If so, I would be interested in some interactive debugging we can establish together.

visibility: private → public
Didier Roche (didrocks) wrote :

phew, was hard to track it, but I finally reproduced the twisted case and fix it! :)

Didier Roche (didrocks) on 2012-04-10
Changed in oneconf (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.2.8

---------------
oneconf (0.2.8) precise; urgency=low

  [ Michael Vogt ]
  * Fix software-center crashed with KeyError in get_hostid_pending_change()
    (LP: #941193)

  [ Didier Roche ]
  * Move saving facility to an utils module to reuse safe saving accross
    the whole application. Removed a deprecated call as well
    (LP: #944738, #842198)
  * Recover gracefully if any of the json file is broken (LP: #849037)
  * Fix turning off oneconf is USC doesn't work (LP: #964659)
  * oneconf-service crashed with KeyError in check_if_refresh_needed():
    'packages_checksum' (LP: #940710)
  * Added/Enhanced tests for all the above
  * debian/control:
    - Bump Standards-Version: to latest
 -- Didier Roche <email address hidden> Tue, 10 Apr 2012 15:11:17 +0200

Changed in oneconf (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers