oneconf-service crashed with RedirectLimit in _request(): Redirected more times than rediection_limit allows.

Bug #851567 reported by JoshuaPurcell on 2011-09-16
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
Undecided
Unassigned

Bug Description

Running Ubuntu 11.10 64-bit with oneconf 0.2.6.2.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: oneconf 0.2.6.2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 15 21:47:35 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/oneconf/oneconf-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110831)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/oneconf/oneconf-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/share/oneconf/oneconf-service']
SourcePackage: oneconf
Title: oneconf-service crashed with RedirectLimit in _request(): Redirected more times than rediection_limit allows.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

JoshuaPurcell (joshua-purcell) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-21
Changed in oneconf (Ubuntu):
status: Confirmed → Fix Committed
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.2.6.4

---------------
oneconf (0.2.6.4) oneiric; urgency=low

  * New release:
    - Convert data receive rom OneConf server from strings to json objects
    - Empty content can be valid, like removing latest other host
    - Protect against a BadStatusLine and RedirectLimit http requests return
      (LP: #852296, #851567)
    - Don't continue syncing if we even can't get a successfull list machines
      data (LP: #854685)
 -- Didier Roche <email address hidden> Wed, 21 Sep 2011 09:13:01 +0200

Changed in oneconf (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers