oneconf-service crashed with TypeError in _sso_login_result(): 'NoneType' object is not subscriptable

Bug #851132 reported by Till Kamppeter on 2011-09-15
This bug affects 389 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
Critical
Didier Roche
Oneiric
Critical
Didier Roche

Bug Description

Happened a few seconds after running

sudo apt-get update
sudo apt-get dist-upgrade

in a terminal window. Probably triggered by one of the updates.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: oneconf 0.2.6.2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 15 19:52:43 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/oneconf/oneconf-service
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/oneconf/oneconf-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/share/oneconf/oneconf-service']
SourcePackage: oneconf
Title: oneconf-service crashed with TypeError in _sso_login_result(): 'NoneType' object is not subscriptable
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/oneconf/networksync/__init__.py", line 82, in _sso_login_result
     authorizer = OAuthAuthorizer(token_key=credential['token'],
 TypeError: 'NoneType' object is not subscriptable
UpgradeStatus: Upgraded to oneiric on 2009-12-18 (636 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Till Kamppeter (till-kamppeter) wrote :
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
miked (miked11) wrote :

USB with Oneric Ocelot 11.10 Beta 1 ix386.iso Ubuntu
crash while searching for flash.
Dell Inspiron 1150 Laptop without Hard drive, using usb drive.

Barry Fishman (barry-fishman) wrote :

In my case it happens when performing updates within aptitude-curses.

$ uname -a
Linux ecube 3.0.0-11-generic #18-Ubuntu SMP Tue Sep 13 23:38:01 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Rainer Rohde (rainer-rohde) wrote :

Happens each time I run apt-get update && apt-get dist-upgrade ...

Brian Poirier (brianpoirier1) wrote :

11.10, 3.0.0-11-generic. Started happening after recent update.

Changed in oneconf (Ubuntu Oneiric):
importance: Undecided → High
importance: High → Critical
Neko (ibaquez) wrote :

Same here, but running the Update Manager (not in terminal)

Djodjo (talk2frossard) wrote :

Same as Neko

Happened to me during:

sudo apt-get purge linux-headers-3.0.0-10 linux-headers-3.0.0-10-generic linux-image-3.0.0-10-generic

mike culford (mike-culford) wrote :

Happened when I closed synaptic after using it to add virtualbox. Adding the program was successful though.

Steve Masson (steve-masson) wrote :

Got that one too..

Didier Roche (didrocks) on 2011-09-16
Changed in oneconf (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
assignee: nobody → Didier Roche (didrocks)
milestone: ubuntu-11.10 → ubuntu-11.10-beta-2
status: Confirmed → Fix Committed
Miguel (xadrezmiguelpires) wrote :

same as Neko

Didier Roche (didrocks) wrote :

oneconf 0.2.6.3 fixing this issue has been uploaded and wait for a beta2 freeze ack.

Jonah J. Loctar (spyhunter442) wrote :

After crash it doesn't shutdown, it only logs out.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.2.6.3

---------------
oneconf (0.2.6.3) oneiric; urgency=low

  * Fix no logging result not handled error (LP: #851132)
  * Protect against apps.ubuntu.com not being available (LP: #851169)
 -- Didier Roche <email address hidden> Fri, 16 Sep 2011 08:07:23 +0200

Changed in oneconf (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Sam Mercier (samercier) wrote :

Affects me. I don't get to use my flash drives or any form of flash memory externally, but do get to use my wireless usb mouse...

T. Lucas (tech4him) wrote :

In my case I was removing restricted drivers when this came up.

RüdiCoerdt (ruediger-coerdt) wrote :

Happened to me when using the update manager applying several updates after my yesterday's dist upgrade which was terminated with an error. The update manager said: "Your system is up to date", but I'm not sure if the updates were already finished when the error message popped up. Maybe it was also me tampering with the settings of the manager.

Federico (fkremer-terra) wrote :

same as RüdiCoerdt.

On Fri 16 Sep 2011 19:10:29 SAST, Federico wrote:
> same as RüdiCoerdt.
>

This has been fixed earlier today (around 2pm SAST for me).

--
--
Bruce Pieterse

Barkhat (barkhat) wrote :

Was running the update manager.

To post a comment you must log in.