oneconf-query needs generic /usr/bin/python3 shebang

Bug #1296325 reported by James System on 2014-03-23
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
High
Barry Warsaw

Bug Description

?

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: oneconf 0.3.6
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 23 17:15:06 2014
ExecutablePath: /usr/share/oneconf/oneconf-query
InstallationDate: Installed on 2013-12-10 (102 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64+mac (20131210)
InterpreterPath: /usr/bin/python3.3
PackageArchitecture: all
ProcCmdline: /usr/bin/python3.3 /usr/bin/oneconf-query --async-update
PythonArgs: ['/usr/bin/oneconf-query', '--async-update']
SourcePackage: oneconf
Title: oneconf-query crashed with ImportError in /usr/lib/python3/dist-packages/dbus/types.py: No module named '_dbus_bindings'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

James System (system-waw) wrote :
tags: removed: need-duplicate-check
Changed in oneconf (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in oneconf (Ubuntu):
importance: Medium → High
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) wrote :

With the removal of Python 3.3, the /usr/bin/oneconf-query shebang is wrong. The right fix is to force the shebang to the generic /usr/bin/python3. Fix underway.

Changed in oneconf (Ubuntu):
status: Confirmed → In Progress
summary: - oneconf-query crashed with ImportError in /usr/lib/python3/dist-
- packages/dbus/types.py: No module named '_dbus_bindings'
+ oneconf-query needs generic /usr/bin/python3 shebang
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.3.7

---------------
oneconf (0.3.7) trusty; urgency=medium

  * d/rules: Override dh_python3 command to force oneconf-query to use the
    generic /usr/bin/python3 shebang. (LP: #1296325)
 -- Barry Warsaw <email address hidden> Mon, 24 Mar 2014 11:23:02 -0400

Changed in oneconf (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers