oneconf-query crashed with ImportError in /usr/bin/oneconf-query: No module named oneconf.version

Bug #1102715 reported by James System
458
This bug affects 71 people
Affects Status Importance Assigned to Milestone
OneConf
New
High
Barry Warsaw
oneconf (Ubuntu)
Fix Released
High
Barry Warsaw

Bug Description

Trying to autorepair installation

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: oneconf 0.3
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
Date: Tue Jan 22 02:42:06 2013
ExecutablePath: /usr/share/oneconf/oneconf-query
InstallationDate: Installed on 2013-01-10 (11 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130110)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/oneconf-query --async-update
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/oneconf-query', '--async-update']
SourcePackage: oneconf
Title: oneconf-query crashed with ImportError in /usr/bin/oneconf-query: No module named oneconf.version
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/oneconf-query", line 37, in <module>
     from oneconf.version import *
 ImportError: No module named oneconf.version
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom debian-tor dip lpadmin plugdev sambashare sudo

Revision history for this message
James System (system-waw) wrote :
tags: removed: need-duplicate-check
Changed in oneconf (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
Michael Terry (mterry)
information type: Private → Public
tags: added: bugpattern-needed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

13 duplicates in 5 hours. We should probably be worried.

Changed in oneconf (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
assignee: Barry Warsaw (barry) → nobody
Revision history for this message
Didier Roche (didrocks) wrote :

Barry, you did the python3 port and latest upload, can you please have a look?

Changed in oneconf (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
Changed in oneconf:
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
Changed in oneconf (Ubuntu):
importance: Medium → High
Barry Warsaw (barry)
Changed in oneconf (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

Occurred on my system right after updating my oneconf packages on my 13.04 install this morning. Has only happened once so far, however.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.3.2

---------------
oneconf (0.3.2) raring; urgency=low

  * setup.py: Only install the command line scripts for Python 3.
    (LP: #1102715)
 -- Barry Warsaw <email address hidden> Tue, 22 Jan 2013 11:24:38 -0500

Changed in oneconf (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.