oneconf-query crashed with ImportError in _get_distro(): No module named CaixaMagica, LinuxMint…

Bug #1006701 reported by Miguel de Freitas Fonseca on 2012-05-31
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]
Oneconf could have never worked on LinuxMint and other derivatives distro (those have to ship a file to get it working, what they didn't do), meaning that a crash will happen at each installation/removal of any package and when software-center launches. Those crashes are spamming errors.ubuntu.com, hence the fix is to ignore if the file for the current distro isn't shipped.

[Test case]
1. On a linuxmint, or elementary derived OS, install the version in precise-proposed
2. start software-center, go the install pane, check that you have no crash
3. run /usr/share/oneconf/oneconf-service --debug. Wait for 30 minutes, check that you have no crash, see no synchronization of data as well
4. run oneconf-query --list, check that you have no crash as well

[Regression potential]
No more synchronization and new crashes on the derived distribution (the code only touches if it can't import the file). Some new tests have been added to cover all those cases.

-----------

After install Elementary Desktop through the Elementary OS Daily PPA, I saw one GTK warning saying it couldn't find PIXMAP in /usr/shar/per15...

 I really don't know what happend.

 But I hope the information in the report is sufficient for you to be able to solve it.

 Thank you.

 Greats.

ProblemType: Crash
DistroRelease: CaixaMagica 18
Package: oneconf 0.2.8
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CrashCounter: 1
Date: Thu May 31 04:23:21 2012
ExecutablePath: /usr/share/oneconf/oneconf-query
InstallationMedia: CaixaMagica 18 LTS "Mondego" - Release amd64 (20120518)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/oneconf-query --async-update
PythonArgs: ['/usr/bin/oneconf-query', '--async-update']
SourcePackage: oneconf
Title: oneconf-query crashed with ImportError in _get_distro(): No module named CaixaMagica
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lp lpadmin plugdev sambashare sudo tty

tags: removed: need-duplicate-check
visibility: private → public
Saurabh Rawat (eklavya) wrote :

I see many crashes which show that oneconf-query crashed but don't notice any odd behaviour because of the crash, just too many crash dialogs in a row.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
Joel Oliver (joelol75) wrote :

I'm experiencing same but I'm also mixing mint 13 repos and running in Cinnamon with MATE installed as well, so this may be related.

Didier Roche (didrocks) on 2012-06-04
summary: oneconf-query crashed with ImportError in _get_distro(): No module named
- CaixaMagica
+ CaixaMagica, LinuxMint…
Didier Roche (didrocks) on 2012-06-04
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.2.9

---------------
oneconf (0.2.9) quantal; urgency=low

  * New release:
    - fix some typos and enhanced translations
    - fix some tests to be able to pass on others machines
    - prevent crashes on mint and elementary which doesn't ship a file
      for their distro. Added test cases for it (LP: #1006701)
  * debian/control:
    - python-gtk2 removed, not needed anymore
 -- Didier Roche <email address hidden> Mon, 04 Jun 2012 13:43:51 +0200

Changed in oneconf (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu Precise):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Was this change regarding RELEASE intentional?

diff -Nru oneconf-0.2.8/oneconf/version.py oneconf-0.2.8.1/oneconf/version.py
--- oneconf-0.2.8/oneconf/version.py 2012-04-10 13:11:34.000000000 +0000
+++ oneconf-0.2.8.1/oneconf/version.py 2012-06-04 11:48:14.000000000 +0000
@@ -1,5 +1,5 @@

-VERSION='0.2.8'
-CODENAME='precise'
+VERSION='0.2.8.1'
+CODENAME='precise-proposed'
 DISTRO='Ubuntu'
-RELEASE='12.04'
+RELEASE='12.10'

Didier Roche (didrocks) wrote :

The change is intentional. RELEASE is used to track where the release has been done (on my quantal machine). The real target is the CODENAME, which is the desired one.

Hello Miguel, or anyone else affected,

Accepted oneconf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in oneconf (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Didier Roche (didrocks) wrote :

Marking as verification-failed as it produces bug #1010239

tags: added: verification-failed
removed: verification-needed
Didier Roche (didrocks) wrote :

Sorry, I speak too fast, the regression spotted above is only on quantal, not in this version of precise-proposed :) Setting back to verification-needed.

tags: added: verification-needed
removed: verification-failed
Didier Roche (didrocks) wrote :

I tried cheating the values and it indeed works.

no longer affects: oneconf
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.2.8.1

---------------
oneconf (0.2.8.1) precise-proposed; urgency=low

  * New bug fix release:
    - prevent crashes on mint and elementary which doesn't ship a file
      for their distro. Added test cases for it (LP: #1006701)
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 16:45:12 +0200

Changed in oneconf (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers