Onboard randomly sets as default in login screen

Bug #986843 reported by Carlos Soriano Sánchez
102
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Onboard
Fix Released
Undecided
Unassigned
onboard (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

The onboard randomly is set to default when unlocking the screen.
I can't reproduce the bug. It's happens to me twice times, in different contexts.
Each time I have to go to onboard settings and unclick "show onboard when unlokcing the screen".
Also, in askubuntu:
http://askubuntu.com/questions/84050/how-do-i-disable-the-on-screen-keyboard-in-the-unlock-screen
The user indicates that " I'm not sure how I activated these settings in the first place though" and I'm sure that is the same issue that happens to me.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-shell 3.2.2.1-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Sun Apr 22 14:39:46 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Carlos Soriano Sánchez (carlos-soriano89) wrote :
Revision history for this message
Carlos Soriano Sánchez (carlos-soriano89) wrote :

it's only happens to me in gnome-shell, not in unity, so I report this bug to gnome-shell. Please, take it into acccount.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Carlos Soriano Sánchez (carlos-soriano89) wrote :

User told me that it happens also in unity, so I changed to onboard package.

affects: gnome-shell (Ubuntu) → onboard (Ubuntu)
Revision history for this message
marmuta (marmuta) wrote :

Thanks for the bug report. Yes, Ubuntu's Onboard adds itself to the login screen on startup. There is bug #938302 for this already, however, having it happen twice to the original poster may be a sign of something else going on.

Questions, Carlos:
When you say it happened twice, in different contexts, what contexts were this?
There are two workarounds listed in the link to askubuntu.com, did you always use the GUI method?

- The GUI method, turning off "Show Onboard when unlocking the screen", would be the most effective one - Onboard should not try to add itself to gnome-screensaver again. You can do the same from command line:
$ gsettings set apps.onboard xembed-onboard false

- The linked command line method
$ gsettings set org.gnome.desktop.screensaver embedded-keyboard-enabled false
only keeps Onboard away until it is started the next time. Better use the first method.

Changed in onboard (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Carlos Soriano Sánchez (carlos-soriano89) wrote :

Marmuta:
With "different" context I mean that it happens without specific action. One time I was navigating internet, and the other time I was programming.
BUT, the first time I'm sure that I click on onboard program accidentally and I closed it. The next time I got the onboard in the gnome lock screen. Then I disable it in the GUI settings.
The second time I don't remember if accidentally click on onboard accidentally, but i'm pretty sure I didn't open onboard program.

I used GUI method twice to disable the onboard.

Since then (date of the bug report) I don't get the error again.

Revision history for this message
marmuta (marmuta) wrote :

Ok thanks. The code seems ok, or at least I didn't immediately spot something suspicious. Perhaps keep an eye on this issue and if it happens again, maybe we can reconstruct what happened. The fix for bug #938302 will probably hide this one, though.

Changed in onboard (Ubuntu):
status: Incomplete → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in onboard (Ubuntu):
status: New → Confirmed
Revision history for this message
zasran (erik-zasran) wrote :

I use Unity and have the same problem. Not sure if it's relevant but at some point I had keyboard not working and I turned on virtual screen in lightdm (login screen) and in Unity as well.

Revision history for this message
marmuta (marmuta) wrote :

Yes zaaran, unfortunately that's the expected behavior after running Onboard once in Precise, see bug #938302. This shouldn't happen anymore starting with v0.97.1 (in Quantal).

Mr. Blonde (mr.blonde)
summary: - Onboard randomly sets as default in lock screen
+ Onscreen keyboard randomly sets as default in login screen
summary: - Onscreen keyboard randomly sets as default in login screen
+ Onboard randomly sets as default in login screen
Rahul (pr-rahulpatel)
Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
affects: lightdm → unity-greeter
Revision history for this message
marmuta (marmuta) wrote :

I'll close this bug for Onboard, there were no more complaints after the fix for bug #938302. Please reopen it if you are still affected.
I believe, since the unlock dialog is part of gnome-screensaver, lightdm/unity-greeter/gdm were never involved.

Changed in onboard:
status: New → Fix Released
Changed in unity-greeter:
status: New → Invalid
Revision history for this message
marmuta (marmuta) wrote :

Please, someone change the status for gdm to 'Invalid' too. Launchpad doesn't let me.

no longer affects: gdm
no longer affects: unity-greeter
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers