Onboard got random resize on usecase touchscreen

Bug #893644 reported by cm-t arudy on 2011-11-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Undecided
Unassigned

Bug Description

A finger is not as precise than a mouse.

After having the onboard finnaly working great in ubuntu, but after some hours of use (most on firefox mobile) for example, i had like 10 times a finger that trigger without the wish, a resize

the resize trigger has different origin :

- window resize (rare coz hard to point, but did 2 time) : when scrolling on firefox and onboard getting un-focsu transparency, sometime resize is called
- GRID (i have the floating onboard icon at the corner bot/right) : finger trigger grid before call the clic to show onboard, so the icon is resized to the hald of the screen. In this case, sometime it resize to random size when tryed un-grid it.

- Unity MT GRAB Handles : this was my way to resize the window when it was wrong un-grided, but user should not use this to « fix », should not fix at all.

I these point shoudl be checked for improve ergonomy in ubuntu.

Librement

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: onboard 0.96.1-0ubuntu0.1 [modified: usr/share/icons/hicolor/scalable/apps/onboard.svg]
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CheckboxSubmission: a1f9a68278e067f3a49183e5ee24e5af
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Tue Nov 22 15:58:25 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.1)
SourcePackage: onboard
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

cm-t arudy (cm-t) wrote :
tags: added: a11y
removed: ergonomy onboard running-unity
marmuta (marmuta) wrote :

Hi, thank you for taking the time to report this bug and helping to make Ubuntu better.

I have pushed a fix for your second issue, the icon palette being resized by the grid plugin.
Until that arrives you could perhaps try to disable the grid plugin in CompizConfig Settings manager (ccsm).

I'll see what can be done about accidentally resizing keyboard window and icon palette.

cm-t arudy (cm-t) wrote :

Hi, thank you for fixing bugs and helping to make ubuntu better.

I will not disable GRIS because I use it much, but it could help people reading this and absolutly want this fixed for the moment.

I have to add something that just happended 2 times in a row :

In the 1st point i said :

- window resize (rare coz hard to point, but did 2 time) : when scrolling on firefox and onboard getting un-focsu transparency, sometime resize is called

this does not happend only to the window keyboard, but to the floating onboard icon too.

Than you again for your attention.

marmuta (marmuta) on 2011-11-23
Changed in onboard:
status: New → Confirmed
marmuta (marmuta) wrote :

I believe your first problem in fixed too now. There are timed thresholds before resizing and moving the keyboard window and the floating icon.
This will probably be available for testing in a PPA before the next release. We'll let you know when it is ready.

Changed in onboard:
status: Confirmed → Fix Committed
Francesco Fumanti (frafu) wrote :

Hello,

You can find a preview package for oneiric and precise containing the fix to this bug in the Onboard Snapshots PPA:
https://launchpad.net/~onboard/+archive/snapshots

In the case where you dare to test packages build from snapshots, please give us feedback here.

Moreover, if you see other bugs during your tests, please file them indicating in what package you found them.

Many thanks in advance.

Francesco Fumanti (frafu) wrote :

Hello,

You can find a preview package for oneiric and precise containing the fix for this bug in the Onboard Snapshots PPA:
https://launchpad.net/~onboard/+archive/snapshots

In the case where you dare to test packages build from snapshots, please give us feedback here.

Moreover, if you see other bugs during your tests, please file them indicating in what package you found them.

Many thanks in advance.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.2-0ubuntu1

---------------
onboard (0.96.2-0ubuntu1) precise; urgency=low

    * Protect against accidental resize/move of Onboard window (LP: #893644)
    * Add option to always show on visible workspace (LP: #803875)
    * Give the AppIndicator an accessible description (LP: #891931)
    * Don't let compiz grid plugin resize the icon palette (LP: 893644)
    * Don't let the move button leave the screen (LP: 885608)
    * Reduce updates of gtk widget (LP: 897678)
    * Work around transparency state loss due to bug 837456
    * Fix resize cursor disapearing for north east window corner
    * Fix window corner issue in Unity on Ubuntu Precise
    * Fix Icon Palette flashing when unity-greeter is killed
    * Fix Unity 2D fighting with Onboard for the top spot
    * Fix missing super key label on distributions without the ubuntu logo
    * Fix almost invisible short feedback on keypress occuring on some notebooks
    * Don't shrink labels when the system font dpi changes
    * Don't ignore force-to-top mode when moving the window back into view
    * Hide move button when window decoration is enabled and force-to-top is off
    * Don't fail to start on older versions of gtk3 (3.0.11 on Mandriva 2011)
    * Prevent onboard getting stuck by grid plugin and gnome-shell
    * Fix middle and right click button for 0.95 legacy layouts
    * Don't crash gnome-shell when window state sticky is off
    * Make a newly created customized theme the active one
    * Stop intltool warnings about messages being hard to translate
    * Restore Authors file that was accidently deleted
    * Some cleanup, typo fixing, gui improvements and performance fixes
    * Merge oneiric translations from the 13-12-2011
    * debian/patches: add system defaults file with values for Unity
 -- Francesco Fumanti <email address hidden> Tue, 13 Dec 2011 21:01:07 +0100

Changed in onboard (Ubuntu):
status: New → Fix Released
marmuta (marmuta) wrote :

cm-t, if you still have problems with random resizing please let us know and reopen this bug at any time.

Changed in onboard:
status: Fix Committed → Fix Released
cm-t arudy (cm-t) wrote :

Sorry for being unactive on lp for a while.
Happy new year !

I am using the ppa snapshot (oneiric, with onbaord ~/.onboard and gconf/apps/onboard cleared ) :

1. fixed: compiz "grid" plugin doens't resize anymore the floating icon or keyboard, well done
2. "border unwanted clic" keep resizing the floating icon or keyboard.

new issue:

3. (not really sure, but i don't remember that issue), in unity 2D : i can see the indicator, preference window, but nothing more (floating icon nor keyboard) ill check if a bug is opened.
4. fixed: on locked screen password prompt, docked keybaord is no longer unusable, well done.

I think the issue 2 is in the topic of this bug (maybe i didnt expainned myself well in english, appologies) and might re-open this bug ( i repeat because after reading what i said, it looks not so easy to understand :s ) :
In preference window, should have a checkbox to diseable the resize of the floating icon and keyboard ( the probleme isnt from «Unity MT GRAB Handles» but from the border 1px for resize can be used by error with fingers)
example: drag and drop the floating icon to move it → it resizes because finger points too close on the 1px resize border

Librement

Francesco Fumanti (frafu) wrote :

Happy new year to you, too.

Marmuta implemented a feature to make Onboard ignore little movements done on its borders or on the move key on the layout. By default, it ignores movements of the size determined by the system 'drag treshold' setting, which is quite limited.

However, it can be set to ignore much bigger movements. To do so, please open the dconf-editor (not the gconf-editor; Onboard 0.96 does not use gconf anymore; you might have to install the dconf-editor as it is not installed by default), navigate to apps/onboard/universal-access and set the drag-treshold for example to 40 (or more), which will make it ignore movements up to 40 pixels. I don't mean to tell you that 40 is a good value in your case; but it might help you to find out how it works.

The idea about a checkbox to disable the moving and resizing of Onboard also came to us, but we prefered to try to find a solution that would solve the resizing and moving problem without totally disabling it. Please, let us know whether you still have issue 2 when you set a bigger drag-treshold with the dconf-editor.

cm-t arudy (cm-t) wrote :

Hi,

I just changed setting as you suggested:

a. when you want to drag and drop the floating icon from a corner to an other corner, it is more than the 40 or the 60px, it will resize, not move. Most case you want to drag the floating icon, it is for reveal the zone it cover, and you drag it away to a zone bigger than it size to have a better eyes on this zone.

b. in multitouch case, you can use «Unity MT GRAB Handles» to resize, if needed. You can use GRAB to move too, but (no stats to proves, just my experience) moving is more in use than resize; mean we can set max px to block the natif feature, but in less than tripple touch, you cant activate GRAB (with default setting ofc)

c. for the keyboard, this trick should resolve it exept in this example: you have keyboard transparented, you are scrolling your page (drag page in firefox mobile for example) but you can clic on the 1px and resize. when you are in a form page, you doent want to go floating between each field.

in this case (c.), i suggest to prevent the resize when it is transparent or something like that, except if another usecase need absolutly a resize in transparent way, i didnt analysed all tbh.

marmuta (marmuta) wrote :

from comment #9:
> 3. (not really sure, but i don't remember that issue), in unity 2D : i can see the
> indicator, preference window, but nothing more (floating icon nor keyboard) ill
> check if a bug is opened.
I remember working on this at some point. This may be a glitch of the snapshot only, if you have the chance please try the final 0.96.2.

> In preference window, should have a checkbox to diseable the resize of the
> floating icon and keyboard
Francesco and me discussed this, but decided to first try an approach that didn't require an additional preferences toggle.

from comment #12:
> c. for the keyboard, this trick should resolve it exept in this example: you have
> keyboard transparented, you are scrolling your page (drag page in firefox
> mobile for example) but you can clic on the 1px and resize. when you are in
> a form page, you doent want to go floating between each field.
I see what you mean. The next release will have real auto-hide, which will probably mitigate this.

marmuta (marmuta) wrote :

I see there is still an issue with accidental resizing at least of the floating icon.
Please help me answering some questions to get a better feel for this:

- How frequently do you have to move the floating icon?
- Out of ten tries, how often does an attempted move result in resizing?
- Which resize corners/edges do you hit most frequently by accident (left, left-top, top, right-top...)?
- What's your screen resolution?
- What's the size of your floating icon? Best attach the output of
  gsettings list-recursively apps.onboard

Unrelated question: how do you manage to move onboard or the floating icon with Unity MT grab handles? I get them for all other windows, but they never show up for onboard.

Changed in onboard:
status: Fix Released → New
marmuta (marmuta) wrote :

Trunk now has an option to limit or disable the resizing. Should be in the upcoming release. This ought to fix it, but please reopen this bug any time if you keep having problems.

Changed in onboard:
status: New → Fix Committed
Changed in onboard:
status: Fix Committed → Fix Released
Luis Mascote (kike-mascote) wrote :

on ubuntu 15.10 onboard does not obey the resize protection and it can grow bigger than the screen but can't shrink even if in 1st instance you try to shrink onboard it will grow over the screen making it unusable, also can't figure out how to reset to the default size uninstalling flushing and reinstaling doesn't help

Francesco Fumanti (frafu) wrote :

That's an odd problem; marmuta will probably look into it when he gets time.

In the meantime, you might be able to resize Onboard by installing the gconf-editor and manually changing Onboard's size values.

marmuta (marmuta) wrote :

@Luis Mascote, do you remember what you did to grow Onboard larger than the screen? I'm trying, but can't seem to figure it out. AFAIK it can happen when changing screen resolution/connected monitors, but I'm not sure how to do it in regular usage. Is this on Compiz/Unity?

Concerning the resize protection, all it does is to disable resize handles of the keyboard window and floating icon. This is to prevent accidental resizing. It wasn't actually meant as a hard lock on a specific window size. While it's active you can still use Onboard's touch handles for example (long press on move button).

There's no convenient way to reset size/position (should there be one?), but you can run:
gsettings reset-recursively org.onboard.window.landscape
optionally:
gsettings reset-recursively org.onboard.window.portrait
gsettings reset-recursively org.onboard.icon-palette.landscape
gsettings reset-recursively org.onboard.icon-palette.portrait
or look up these paths and change them in dconf-editor as Francesco suggested.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers