Oneiric-proposed: new version of Onboard with GI, gsettings,...

Bug #872374 reported by Francesco Fumanti
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
onboard (Ubuntu)
Fix Released
High
Unassigned
Oneiric
Fix Released
High
Unassigned
Precise
Fix Released
Undecided
Unassigned

Bug Description

Sorry for getting this release ready only this late. I hope that it will nevertheless make it into oneiric.

Here is the list of the principle changes taken from the NEWS file:
    * Uses gobject introspection (GTK3), (LP: #858988)
    * Uses gsettings rather than gconf (LP: #801208)
    * Show on new lock screen (LP: #857813)
    * Make Caps Lock stick on single click, (LP: #68716)
    * Use dh_python2 (LP: #788514)
    * Make Caps Lock stick on single click (LP: #68716)
    * Add a hide button (LP: #564040 , LP: #584119)
    * Add options for transparency of the onscreen keyboard window (LP: #643204)
    * Add option to use a window without decoration
    * Add tooltips to some keys of Onboard
    * Add option to force Onboard window to top (work around bug 739812)
    * Add possibility to differentiate snippets with custom labels
    * Add buttons to control the hover click eature provided by the system
    * Enhance the layout creation with parts that are visible on all layer
    * Reworked the layouts and renamed Classic Onboard layout to Compact layout
    * Many other little fixes and adjustments (details in commits on launchpad)

A reason to grant the exception might be that it provides among others gobject introspect on and the use of gsettings. Moreover, it ships some new features that were requested by onscreen keyboard users by filing bugs. Finally, for users that are not able to click, it fixes the regression since the Unity desktop that was previously provided by the dwell applet: the fonctionality of the dwell applet is now available in Onboard.

As an onscreen keyboard user and part of the development team (I am not the coder however), I have been creating a new debian package for my personal use every few commits and the problems encountered during its usage were addressed.

I am going to attach a debian source package to this email with defaults that should suit oneiric.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

This is a little late to go in to the release, but after discussion with Colin, we're ok with it going in as an SRU after suitable review. We'd like to pick this up right now, but if there is a regression we wouldn't have time to react.

Please submit this into -proposed, and get a couple of reviewers to signoff after testing it, and we'll let it in as an SRU. Yes this is outside the normal SRU criteria, but risk should be manageable.

tags: added: rls-mgr-o-tracking
Changed in onboard (Ubuntu Oneiric):
milestone: none → oneiric-updates
importance: Undecided → High
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
summary: - Feature Freeze exception request: new version with GI, gsettings,...
+ Oneiric-proposed: new version of Onboard with GI, gsettings,...
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Because of the size of the diff and the fact that we're in SRU mode now for oneiric, I'm not sure I can +1 this all by myself. On review of the debian directory changes, it looks structurally fine, but I'd like to get the other SRU team members' opinion on whether we can accept this with just the authority of Kate's pre-release comment.

Revision history for this message
Martin Pitt (pitti) wrote :

I can't sensibly review the diff either, as there are so many changes. But I agree with Kate that the risk is manageable, as it's not a library. Also, onboard is quite important for accessibility. So this should get some good testing in -proposed, with feedback from several people who use it.

Changed in onboard (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Francesco, or anyone else affected,

Accepted onboard into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Alan Bell (alanbell) wrote :

I would like to see lp:877386 and lp:877385 fixed if we are doing an SRU. I think the lack of window controls kind of fixes lp:859288

Revision history for this message
marmuta (marmuta) wrote :

Alan's lp:877385 should be fixed, but some more issues came up when I tested on live CD and a fresh install:
There are lp:877592, lp:877604 with committed fixes, but lp:877601 needs more investigation, could be a gsettings problem.

Revision history for this message
Francesco Fumanti (frafu) wrote :

Onboard 0.96.1 has been released as a bugfix release. I have packaged it for oneiric; you can find it here:
https://bugs.launchpad.net/ubuntu/+source/onboard/+bug/880085

Revision history for this message
Jeremy Bicha (jbicha) wrote :

I uploaded 0.96.1-0ubuntu0.1 to the oneiric-proposed queue. It includes fixes for the regressions Alan mentioned.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.1-0ubuntu1

---------------
onboard (0.96.1-0ubuntu1) precise; urgency=low

  * New bugfix release (LP: #880085)
  * Make the Hover Click also work in the Unity Greeter
  * Add some shortcuts to the Preferences dialog
  * Fix the return key of the scanning layout (LP: #877385)
  * Fix black corner issue when auto-starting in unity (LP: #877604)
  * Fix starting of the Preferences of Onboard in the LiveCD (LP: #877592)
  * Improve handling of gsettings events (LP: #877601)
  * Silently embed into gnome-screen-saver if no app did so (LP: #857813)
  * Remove redundant hook check
  * Remove unused pictures
  * Make a few small visual adjustments
  * Improve or fix some tooltips and key names
  * Add Gerd to AUTHORS file and order the names alphabetically
  * Merge translations from the Ubuntu translators from the 22-10-2011
  * debian/patches: update onboard-defaults.conf file

onboard (0.96.0-0ubuntu0.1) oneiric-proposed; urgency=low

  * Feature Freeze exception request (LP: #872374)
  * Uses gobject introspection (GTK3), (LP: #858988)
  * Uses gsettings rather than gconf (LP: #801208)
  * Show on new lock screen (LP: #857813)
  * Make Caps Lock stick on single click, (LP: #68716)
  * Use dh_python2 (LP: #788514)
  * Make Caps Lock stick on single click (LP: #68716)
  * Add a hide button (LP: #564040 , LP: #584119)
  * Add options for transparency of the onscreen keyboard window (LP: #643204)
  * Add option to use a window without decoration
  * Add tooltips to some keys of Onboard
  * Add option to force Onboard window to top (work around bug 739812)
  * Add possibility to differentiate snippets with custom labels
  * Add buttons to control the hover click eature provided by the system
  * Enhance the layout creation with parts that are visible on all layer
  * Reworked the layouts and renamed Classic Onboard layout to Compact layout
  * Many other little fixes and adjustments (details in commits on launchpad)
  * debian/control:
      Build-Depends: add python-all-dev, libgtk-3-dev, libxi-dev, libxtst-dev
                     remove libxi6
      Depends: add ${shlibs:Depends}, python-dbus, gir1.2-gtk-3.0,
                   gir1.2-pango-1.0 (>= 1.29.3), gir1.2-glib-2.0,
                   gir1.2-gdkpixbuf-2.0, libgtk-3-0, libxtst6
               remove python-gtk2, python-gconf, python-gobject, libx11-6
  * debian/copyright: add Gerd Kohlberger to the list of authors
  * debian/rules: uncomment clean target
  * debian/patches: update onboard-defaults.conf file
                    remove onboard_autostart.patch
  * debian: remove outdated README.source file
 -- Francesco Fumanti <email address hidden> Sat, 22 Oct 2011 22:10:54 +0200

Changed in onboard (Ubuntu Precise):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.1-0ubuntu0.1

---------------
onboard (0.96.1-0ubuntu0.1) oneiric-proposed; urgency=low

  * New bugfix release (LP: #880085)
  * Make the Hover Click also work in the Unity Greeter
  * Add some shortcuts to the Preferences dialog
  * Fix the return key of the scanning layout (LP: #877385)
  * Fix black corner issue when auto-starting in unity (LP: #877604)
  * Fix starting of the Preferences of Onboard in the LiveCD (LP: #877592)
  * Improve handling of gsettings events (LP: #877601)
  * Silently embed into gnome-screen-saver if no app did so (LP: #857813)
  * Remove redundant hook check
  * Remove unused pictures
  * Make a few small visual adjustments
  * Improve or fix some tooltips and key names
  * Add Gerd to AUTHORS file and order the names alphabetically
  * Merge translations from the Ubuntu translators from the 22-10-2011
  * debian/patches: update onboard-defaults.conf file

onboard (0.96.0-0ubuntu0.1) oneiric-proposed; urgency=low

  * Feature Freeze exception request (LP: #872374)
  * Uses gobject introspection (GTK3), (LP: #858988)
  * Uses gsettings rather than gconf (LP: #801208)
  * Show on new lock screen (LP: #857813)
  * Make Caps Lock stick on single click, (LP: #68716)
  * Use dh_python2 (LP: #788514)
  * Make Caps Lock stick on single click (LP: #68716)
  * Add a hide button (LP: #564040 , LP: #584119)
  * Add options for transparency of the onscreen keyboard window (LP: #643204)
  * Add option to use a window without decoration
  * Add tooltips to some keys of Onboard
  * Add option to force Onboard window to top (work around bug 739812)
  * Add possibility to differentiate snippets with custom labels
  * Add buttons to control the hover click eature provided by the system
  * Enhance the layout creation with parts that are visible on all layer
  * Reworked the layouts and renamed Classic Onboard layout to Compact layout
  * Many other little fixes and adjustments (details in commits on launchpad)
  * debian/control:
      Build-Depends: add python-all-dev, libgtk-3-dev, libxi-dev, libxtst-dev
                     remove libxi6
      Depends: add ${shlibs:Depends}, python-dbus, gir1.2-gtk-3.0,
                   gir1.2-pango-1.0 (>= 1.29.3), gir1.2-glib-2.0,
                   gir1.2-gdkpixbuf-2.0, libgtk-3-0, libxtst6
               remove python-gtk2, python-gconf, python-gobject, libx11-6
  * debian/copyright: add Gerd Kohlberger to the list of authors
  * debian/rules: uncomment clean target
  * debian/patches: update onboard-defaults.conf file
                    remove onboard_autostart.patch
  * debian: remove outdated README.source file
 -- Francesco Fumanti <email address hidden> Sat, 22 Oct 2011 22:10:54 +0200

Changed in onboard (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
David Planella (dpm) wrote :

Several translators have pointed out that this new upload has changed existing strings and introduced new ones. Since there wasn't any notification in the translators mailing list, these went unnoticed.

This means that these strings will appear in English for all users until the next language packs are released (planned for January [1])

In the future, if an SRU upload is absolutely necessary and it changes stable strings, please consider:

- Notifying translators by sending an e-mail to the mailing list (ubuntu-translators(AT)lists(DOT)ubuntu(DOT)com)
- Coordinate the SRU so that it coincides with a language pack update

Thanks.

[1] https://wiki.ubuntu.com/Translations/OneiricLanguagePackReleaseSchedule

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers