onboard doesn't show on lock screen in 11.10 beta 2

Bug #857813 reported by chadmerkert
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Onboard
Fix Released
Medium
marmuta
onboard (Ubuntu)
Fix Released
Undecided
Unassigned
Oneiric
Fix Released
Undecided
Unassigned

Bug Description

If you set in the preferences Show Onboard when unlocking the screen, it doesn't show up. I can't find any way to get an on-screen keyboard on the lock screen of the new version of Ubuntu!

Description: Ubuntu oneiric (development branch)
Release: 11.10

onboard:
  Installed: 0.95.1-0ubuntu2
  Candidate: 0.95.1-0ubuntu2
  Version table:
 *** 0.95.1-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Let me know if I can provide more information!

Revision history for this message
Jeremy Bicha (jbicha) wrote :

I'm adding an upstream task because I'd like to see the developer's opinion on how this should be fixed. Do we need onboard 0.96 to get the gtk3 version?

Revision history for this message
marmuta (marmuta) wrote :

XEmbed mode is supposed to work in the current release. The gtk3 changes aren't required yet, not for this bug at least. I'm looking into it.

Changed in onboard:
assignee: nobody → marmuta (marmuta)
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in onboard (Ubuntu):
status: New → Confirmed
Revision history for this message
marmuta (marmuta) wrote :

I should have remembered. The keys to enable embedding in gnome-screensaver have moved from gconf to gsettings. The gtk3 changes in upstream take care of that, but the current release still sets them in gconf.

Chadmerkert, as a workaround try running these in a terminal:

gsettings set org.gnome.desktop.screensaver embedded-keyboard-enabled true
gsettings set org.gnome.desktop.screensaver embedded-keyboard-command 'onboard --xid'

I suspect this will make it work, if not, please let me know.

Changed in onboard:
status: New → Fix Committed
Revision history for this message
chadmerkert (chad-merkert) wrote :

The workaround works great! Onboard now shows up when the screen is locked!

I also realized that I can't get onboard to work at the GDM login screen. I switched from lightdm to GDM, but there isn't an option for on onscreen keyboard. I have set /apps/gdm/simple-greeter/accessibility/screen_keyboard_enabled in gconf-editor, but that doesn't help. Is this a problem with onboard or GDM? Any idea on how to get onboard on the GDM login? My GDM version is:
gdm:
  Installed: 3.0.4-0ubuntu11
  Candidate: 3.0.4-0ubuntu11
  Version table:
 *** 3.0.4-0ubuntu11 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

Thanks.

Revision history for this message
marmuta (marmuta) wrote :

I'm not sure what happens with onboard in GDM. As far as I know gnome-shell will have a built-in on-screen keyboard and thus onboard might be replaced in GDM too. Jeremy could probably tell you more about this.
If you still want to try, playing with or creating /usr/share/gdm/autostart/LoginWindow/onboard.desktop may be the way to go.

Lightdm has an option to start onboard now, only the actual typing isn't working yet. There is a fix on it's way apparently with unity-greeter-0.0.9. It's not in the repos yet though.
https://bugs.launchpad.net/unity-greeter/+bug/851565

Revision history for this message
Jeremy Bicha (jbicha) wrote :

I don't think GDM 3.0 supports an on screen keyboard; you'll need to use LightDM (which is the new Ubuntu default as it's far more powerful for our use cases & it's supposed to be more themable too). For Ubuntu 12.04, GDM 3.2 or 3.4 will probably have the GNOME Shell screen keyboard built-in.

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello chadmerkert, or anyone else affected,

Accepted onboard into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in onboard (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
Alan Bell (alanbell) wrote :

yes, this works, but the checkbox isn't selected by default to show on the lock screen

Revision history for this message
marmuta (marmuta) wrote :

> but the checkbox isn't selected by default to show on the lock screen
I've added this recently, should come with the bug fix release.
Onboard then silently sets those g-s-s keys on startup, but does so only if no other osk has taken them before.

@Francesco, just in case, this needs xembed-onboard = True in onboard-defaults.conf, but you knew this.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

marmuta, what exactly needs to be set for the lock screen to work? Is it gsettings, lightdm.conf, some other file?

I'd like to test what circumstances the onscreen keyboard still won't show on the lock screen, because it should always show if org.gnome.desktop.a11y.applications screen-keyboard-enabled is turned on.

Revision history for this message
Francesco Fumanti (frafu) wrote :

@Jeremy

You should open the Onboard Preferences and activate the checkbox "Show Onboard when unlocking the screen".

Revision history for this message
marmuta (marmuta) wrote :

The keys are in gsettings, at org.gnome.desktop.screensaver. To have Onboard show up when unlocking the screen they need to be set to
embedded-keyboard-command = 'onboard --xid'
embedded-keyboard-enabled = True

The lightdm greeter (unity-greeter) has "onboard --xid" hard-coded into the greeter code. I believe there's nothing to configure (yet).

Onboard can set the screen-saver keys on user action, as Francesco wrote above, or automatically and silently on startup (since 0.96.1).
The latter requires to have
xembed-onboard = True
in onboard-defaults.conf. 'xembed-onboard' is the key behind the checkbox in preferences. Basically this enables the toggle by default. Francesco has added this to the patch for the Ubuntu package.

This is not a 100% solution though. If Onboard has never been run before, it won't show up in the unlock screen either.
Also, if any other on-screen keyboard has set itself to be the unlock keyboard, Onboard won't stay silent, but pop up one of two message boxes asking the user what to do. It's a bit like the default web browser setting. it wouldn't be polite to set it silently in this case.

For testing, you could do
gsettings reset-recursively apps.onboard
gsettings reset-recursively org.gnome.desktop.screensaver
then run (Ubuntu's) onboard once and lock the screen -> it should show the keyboard

Or, to simulate some other app grabbing the unlock keys
gsettings set org.gnome.desktop.screensaver embedded-keyboard-command 'some-other-osk'
running onboard should then pop up a message box to either overwrite the setting or disable the checkbox in Onboard's preferences.

Revision history for this message
marmuta (marmuta) wrote :

Another solution may be to have a gsettings vendor override file for gnome-screen-saver. That way Onboard wouldn't need to run once to have lock screen working. I don't believe this should be installed by Onboard though, pretty sure not by the upstream version and probably neither with an Ubuntu patch.

Anyway, I believe it would be named
/usr/share/glib-2.0/schemas/org.gnome.gnome-screenshot.gschema.override

and look like this
[org.gnome.desktop.screensaver]
embedded-keyboard-command='onboard --xid'
embedded-keyboard-enabled=true

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.1-0ubuntu1

---------------
onboard (0.96.1-0ubuntu1) precise; urgency=low

  * New bugfix release (LP: #880085)
  * Make the Hover Click also work in the Unity Greeter
  * Add some shortcuts to the Preferences dialog
  * Fix the return key of the scanning layout (LP: #877385)
  * Fix black corner issue when auto-starting in unity (LP: #877604)
  * Fix starting of the Preferences of Onboard in the LiveCD (LP: #877592)
  * Improve handling of gsettings events (LP: #877601)
  * Silently embed into gnome-screen-saver if no app did so (LP: #857813)
  * Remove redundant hook check
  * Remove unused pictures
  * Make a few small visual adjustments
  * Improve or fix some tooltips and key names
  * Add Gerd to AUTHORS file and order the names alphabetically
  * Merge translations from the Ubuntu translators from the 22-10-2011
  * debian/patches: update onboard-defaults.conf file

onboard (0.96.0-0ubuntu0.1) oneiric-proposed; urgency=low

  * Feature Freeze exception request (LP: #872374)
  * Uses gobject introspection (GTK3), (LP: #858988)
  * Uses gsettings rather than gconf (LP: #801208)
  * Show on new lock screen (LP: #857813)
  * Make Caps Lock stick on single click, (LP: #68716)
  * Use dh_python2 (LP: #788514)
  * Make Caps Lock stick on single click (LP: #68716)
  * Add a hide button (LP: #564040 , LP: #584119)
  * Add options for transparency of the onscreen keyboard window (LP: #643204)
  * Add option to use a window without decoration
  * Add tooltips to some keys of Onboard
  * Add option to force Onboard window to top (work around bug 739812)
  * Add possibility to differentiate snippets with custom labels
  * Add buttons to control the hover click eature provided by the system
  * Enhance the layout creation with parts that are visible on all layer
  * Reworked the layouts and renamed Classic Onboard layout to Compact layout
  * Many other little fixes and adjustments (details in commits on launchpad)
  * debian/control:
      Build-Depends: add python-all-dev, libgtk-3-dev, libxi-dev, libxtst-dev
                     remove libxi6
      Depends: add ${shlibs:Depends}, python-dbus, gir1.2-gtk-3.0,
                   gir1.2-pango-1.0 (>= 1.29.3), gir1.2-glib-2.0,
                   gir1.2-gdkpixbuf-2.0, libgtk-3-0, libxtst6
               remove python-gtk2, python-gconf, python-gobject, libx11-6
  * debian/copyright: add Gerd Kohlberger to the list of authors
  * debian/rules: uncomment clean target
  * debian/patches: update onboard-defaults.conf file
                    remove onboard_autostart.patch
  * debian: remove outdated README.source file
 -- Francesco Fumanti <email address hidden> Sat, 22 Oct 2011 22:10:54 +0200

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Hello chadmerkert, or anyone else affected,

Accepted onboard into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
marmuta (marmuta) wrote :

Works as intended on my fresh install. The toggle in preferences does turn it on and off in the unlock screen. Also Onboard shows up there right after its first launch.

Once it's in there, it doesn't go away on its own though. It's still in the lock screen when I turn off the osk in universal access settings. It can be turned off manually in preferences, but perhaps ultimately something other than Onboard should toggle the gsettings key "embedded-keyboard-enabled" in sync with "screen-keyboard-enabled"?

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
marmuta (marmuta)
Changed in onboard:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.1-0ubuntu0.1

---------------
onboard (0.96.1-0ubuntu0.1) oneiric-proposed; urgency=low

  * New bugfix release (LP: #880085)
  * Make the Hover Click also work in the Unity Greeter
  * Add some shortcuts to the Preferences dialog
  * Fix the return key of the scanning layout (LP: #877385)
  * Fix black corner issue when auto-starting in unity (LP: #877604)
  * Fix starting of the Preferences of Onboard in the LiveCD (LP: #877592)
  * Improve handling of gsettings events (LP: #877601)
  * Silently embed into gnome-screen-saver if no app did so (LP: #857813)
  * Remove redundant hook check
  * Remove unused pictures
  * Make a few small visual adjustments
  * Improve or fix some tooltips and key names
  * Add Gerd to AUTHORS file and order the names alphabetically
  * Merge translations from the Ubuntu translators from the 22-10-2011
  * debian/patches: update onboard-defaults.conf file

onboard (0.96.0-0ubuntu0.1) oneiric-proposed; urgency=low

  * Feature Freeze exception request (LP: #872374)
  * Uses gobject introspection (GTK3), (LP: #858988)
  * Uses gsettings rather than gconf (LP: #801208)
  * Show on new lock screen (LP: #857813)
  * Make Caps Lock stick on single click, (LP: #68716)
  * Use dh_python2 (LP: #788514)
  * Make Caps Lock stick on single click (LP: #68716)
  * Add a hide button (LP: #564040 , LP: #584119)
  * Add options for transparency of the onscreen keyboard window (LP: #643204)
  * Add option to use a window without decoration
  * Add tooltips to some keys of Onboard
  * Add option to force Onboard window to top (work around bug 739812)
  * Add possibility to differentiate snippets with custom labels
  * Add buttons to control the hover click eature provided by the system
  * Enhance the layout creation with parts that are visible on all layer
  * Reworked the layouts and renamed Classic Onboard layout to Compact layout
  * Many other little fixes and adjustments (details in commits on launchpad)
  * debian/control:
      Build-Depends: add python-all-dev, libgtk-3-dev, libxi-dev, libxtst-dev
                     remove libxi6
      Depends: add ${shlibs:Depends}, python-dbus, gir1.2-gtk-3.0,
                   gir1.2-pango-1.0 (>= 1.29.3), gir1.2-glib-2.0,
                   gir1.2-gdkpixbuf-2.0, libgtk-3-0, libxtst6
               remove python-gtk2, python-gconf, python-gobject, libx11-6
  * debian/copyright: add Gerd Kohlberger to the list of authors
  * debian/rules: uncomment clean target
  * debian/patches: update onboard-defaults.conf file
                    remove onboard_autostart.patch
  * debian: remove outdated README.source file
 -- Francesco Fumanti <email address hidden> Sat, 22 Oct 2011 22:10:54 +0200

Changed in onboard (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers