onboard symbol does not show up on every workspace

Bug #803875 reported by Daniel Stoni on 2011-06-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Medium
Unassigned

Bug Description

When selected to be seen on every workspace, onboard does so when in window/keyboard mode, but it does not when displayed as floating. Tried with 0.95.1, same effect.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: onboard 0.94.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Thu Jun 30 14:54:28 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_CH:sr:en
 PATH=(custom, user)
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
SourcePackage: onboard
UpgradeStatus: Upgraded to natty on 2011-06-07 (22 days ago)

Related branches

Changed in onboard (Ubuntu):
status: New → Confirmed
Changed in onboard:
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: a11y
Changed in onboard (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium

Cool, thanks.

Sergey Fukanchik (fuxx) wrote :

gtk.Window.stick() should be used to fix that. I am on Ubuntu 10.04 LTS so my version looks obsolete from what is usually discussed in this bugtracker and i can not create diff for you guys.

To fix this issue in my 'onboard' version i have added
self.stick()
to three places:
1) KbdWindowBase.__init__(self)
2) KbdWindowBase.on_deiconify(self, widget=None)
3) IconPalette. __init__(self):

so both keyboard window and icon are sticky.

marmuta (marmuta) wrote :

Thanks Sergey, I've added that plus a toggle in preferences. Sticky state is enabled by default for now.

Changed in onboard:
status: Confirmed → Fix Committed
Francesco Fumanti (frafu) wrote :

Hello,

You can find a preview package containing the fix to this bug in the Onboard Snapshots PPA:
https://launchpad.net/~onboard/+archive/snapshots

In the case where you dare to test packages build from snapshots, please give us feedback here.

Moreover, if you see other bugs during your tests, please file them indicating in what package you found them.

Many thanks in advance.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.2-0ubuntu1

---------------
onboard (0.96.2-0ubuntu1) precise; urgency=low

    * Protect against accidental resize/move of Onboard window (LP: #893644)
    * Add option to always show on visible workspace (LP: #803875)
    * Give the AppIndicator an accessible description (LP: #891931)
    * Don't let compiz grid plugin resize the icon palette (LP: 893644)
    * Don't let the move button leave the screen (LP: 885608)
    * Reduce updates of gtk widget (LP: 897678)
    * Work around transparency state loss due to bug 837456
    * Fix resize cursor disapearing for north east window corner
    * Fix window corner issue in Unity on Ubuntu Precise
    * Fix Icon Palette flashing when unity-greeter is killed
    * Fix Unity 2D fighting with Onboard for the top spot
    * Fix missing super key label on distributions without the ubuntu logo
    * Fix almost invisible short feedback on keypress occuring on some notebooks
    * Don't shrink labels when the system font dpi changes
    * Don't ignore force-to-top mode when moving the window back into view
    * Hide move button when window decoration is enabled and force-to-top is off
    * Don't fail to start on older versions of gtk3 (3.0.11 on Mandriva 2011)
    * Prevent onboard getting stuck by grid plugin and gnome-shell
    * Fix middle and right click button for 0.95 legacy layouts
    * Don't crash gnome-shell when window state sticky is off
    * Make a newly created customized theme the active one
    * Stop intltool warnings about messages being hard to translate
    * Restore Authors file that was accidently deleted
    * Some cleanup, typo fixing, gui improvements and performance fixes
    * Merge oneiric translations from the 13-12-2011
    * debian/patches: add system defaults file with values for Unity
 -- Francesco Fumanti <email address hidden> Tue, 13 Dec 2011 21:01:07 +0100

Changed in onboard (Ubuntu):
status: Triaged → Fix Released
marmuta (marmuta) on 2012-01-02
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers