default layout always loaded due to gconf key handling error

Bug #769104 reported by Alan Bell on 2011-04-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: onboard

on starting onboard from the command line you see:
WARNING:Config:Can't load Default.onboard loading default layout instead

this is because it tries to see if there is a layout file with filename "Default" from the gconf key /apps/onboard/layout_filename however the filename is layouts/Default.onboard
Setting the gconf key to layouts/Default.onboard (or layouts/Full.onboard) allows it to start without error and actually use the full keyboard layout.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: onboard 0.94.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
Date: Fri Apr 22 18:42:33 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100814)
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: onboard

Alan Bell (alanbell) wrote :
tags: added: a11y
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This is reproducable using the Natty Narwhal updated as of 2011-04-21. The messages seen in terminal are as described in the report. Since there is no menu entry for Onboard, the only way the user starts this application is using the terminal.

 Thanks for taking the time to make Ubuntu better!

Changed in onboard (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
marmuta (marmuta) wrote :

Thanks for the bug report. I've pushed a fix to onboard main. The message has been demoted to level "info", which hides it for the default invocation.

Changed in onboard:
status: New → Fix Committed
Francesco Fumanti (frafu) wrote :

@Charlie

> Since there is no menu entry for Onboard, the only way the user starts this application is using the terminal.

FYI: The onboard source package ships with menu entries. However, they get patched in the debian package in order to hide them by default.

Francesco Fumanti (frafu) wrote :

You can find the new version of Onboard that among others includes this bug fix in my PPA for Ubuntu Natty:
https://launchpad.net/~frafu/+archive/ppa

I am writing this here in case you might want to try the new release.

Changed in onboard:
status: Fix Committed → Fix Released
Changed in onboard (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers