Untranslated buttons in Onboard

Bug #1567301 reported by Jean-Marc on 2016-04-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Low
Unassigned
Ubuntu Translations
Undecided
Unassigned
onboard (Ubuntu)
High
Unassigned

Bug Description

Hello,

There are some untranslated and untranslatable buttons in Onboard Settings UI: "Close", "New", "Add", "Remove"...
These words do not appear in template: https://translations.launchpad.net/ubuntu/+source/onboard

Thank you

Ubuntu 15.10 Wily
Onboard 1.1.2-0ubuntu1

Related branches

Jean-Marc (m-balthazar) wrote :
Jean-Marc (m-balthazar) on 2016-04-07
description: updated
marmuta (marmuta) wrote :

Thank you, fixed in trunk.

Changed in onboard:
status: New → Fix Committed
Changed in onboard (Ubuntu):
status: New → Confirmed
Changed in onboard:
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

do you plan to get an update with the fix in xenial?

Francesco Fumanti (frafu) wrote :

Hi Sebastien,

Marmuta fixed the problem in revision 2129 of trunk. Since it is already quite late in the xenial release cycle with all the freezes already enabled, especially the string freeze, I decided to create a patch that only adds the translatable attribute where it is missing.

You can find the patch in the onboard update added to this bug thread. The onboard update is based on the onboard version currently in the xenial main repository.

If you want me to change anything in the patch, please let me know.

Have a nice day.

Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :

The attachment "onboard_1.2.0-0ubuntu5.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in onboard (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

thanks, sponsored (with a slightly more verbose changelog to easy release team review), let's see if that goes in for release or sru

Changed in onboard (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 1.2.0-0ubuntu5

---------------
onboard (1.2.0-0ubuntu5) xenial; urgency=medium

  * debian/patches/bzr_fix_untranslatable_buttons.patch:
    backport commit "Make former stock buttons in preferences translatable"
    (LP: #1567301)

 -- Francesco Fumanti <email address hidden> Fri, 15 Apr 2016 21:59:05 +0200

Changed in onboard (Ubuntu):
status: Fix Committed → Fix Released
Francesco Fumanti (frafu) wrote :

@Sebastien

Thanks for improving the changelog and sponsoring the update.

Jean-Marc (m-balthazar) on 2016-04-23
Changed in ubuntu-translations:
status: New → Fix Released
status: Fix Released → Fix Committed
Jean-Marc (m-balthazar) on 2016-04-26
summary: - Untranslated buttons
+ Untranslated buttons in Onboard
Jean-Marc (m-balthazar) on 2016-07-18
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers