international character selection offset on high-dpi screen

Bug #1421840 reported by Andreas E. on 2015-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
High
Unassigned
onboard (Ubuntu)
Undecided
Unassigned

Bug Description

When using a user-interface scaling > 1 (Ubuntu Control Center → Display), the sensitive areas of the international character selection popover is offset. It seems UI units and device units are confused. When you want to choose an international character, you have to touch the screen at twice the distance from the popover's top left corner.

Ubuntu 14.10
onboard 1.1.0~1908-0ppa1~utopic (from onboard snapshots ppa)
org.gnome.desktop.interface.scaling-factor = 2
screen resolution: 3200×1800px

Andreas E. (andreas-e) wrote :
Andreas E. (andreas-e) wrote :
marmuta (marmuta) wrote :

Thanks for the bug report. I can't reproduce it in Vivid, but will try in Utopic later. 1.1.0~1908-0ppa1~utopic is slightly outdated too by now. We should get you an updated snapshot just in case.

marmuta (marmuta) on 2015-02-14
Changed in onboard:
importance: Undecided → High
Francesco Fumanti (frafu) wrote :

Revision 1944 of trunk is now available in our Snapshots PPA.

Andreas E. (andreas-e) wrote :

Thanks! I tested the same procedure with 1.1.0+1944-0ppa1~utopic as described above and got the same observation.

marmuta (marmuta) wrote :

Found it, the scaling was applied twice. Looking at your screen-shots there was another issue with keys getting stuck on the main keyboard. This shouldn't happen anymore either. Try it please and let me know how it goes.

Francesco, another snapshot please. Thanks in advance.

Changed in onboard:
status: New → Fix Committed
Francesco Fumanti (frafu) wrote :

Revision 1949 of trunk containing the fix will be available in our Snapshots PPA for utopic and vivid as soon as launchpad has finished building them. Trusty and precise will follow later this evening.

Andreas E. (andreas-e) wrote :

Confirmed, 1.1.0+1949-0ppa1~utopic fixes the issue perfectly!
Thanks (again) for your very fast response. (From other projects I'm rather used to a response no earlier than a month and a fix after min. half a year.)

Francesco Fumanti (frafu) wrote :

Hi,

Thanks for the confirmation that your bug is fixed.

By the way, Onboard 1.1.1 has just been released containing among others this fix.
https://launchpad.net/onboard/+download

Cheers,

Francesco

PS: I fully agree: Marmuta is doing an outstanding job with Onboard since quite some time, which is really great from his part.

Changed in onboard:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 1.1.1-0ubuntu1

---------------
onboard (1.1.1-0ubuntu1) vivid; urgency=low

  * Request for sponsorship for new upstream release (LP: #1423181)
  * debian/rules:
    - Add additional cleaning to override_dh_auto_clean target
  * debian/patches:
    - Clean up and rebase add_defaults_for_ubuntu.patch patch
  * Import vivid translations from rosetta for Onboard 1.1 as of 18/02/2015
  * Fix international character selection offset on high-dpi screen (LP: #1421840)
  * Fix left click on GtkStatusIcon fallback not working (LP: #1421972)
  * Trap the occasional X error BadDrawable causing Onboard to exit
  * Fix traceback when showing keyboard popups in Precise
  * Fix display of key popups for compiz and metacity in Precise
  * Fix stuck keys in keyboard popups with event source GTK
  * Fix auto-inserting separator Ĩ instead of space when NumLock is enabled
  * Fix initial Py_None not being dereferenced when copying OskDeviceEvents
  * Stop synchronisation of modifiers when Alt is active
  * Recognize a touch device with reception of a touch event
  * Enhance cleaning command of source tree
  * Add encoding line to setup.py
  * Remove unused template.svg
 -- Francesco Fumanti <email address hidden> Wed, 18 Feb 2015 14:47:43 +0100

Changed in onboard (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers