Onboard too small in unity-greeter

Bug #1297695 reported by tuxiano on 2014-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
High
Unassigned

Bug Description

In the login screen (unity-greeter) the onboard only use fraction of the horizontal space. This is a regression to previews releases (0.99), since keys became very small and it is hard to type the password.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: onboard 1.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 26 09:34:15 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-01-11 (73 days ago)
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.2)
SourcePackage: onboard
UpgradeStatus: Upgraded to trusty on 2014-03-23 (2 days ago)

tuxiano (tuxiano) wrote :
marmuta (marmuta) wrote :

Hi, what kind of hardware is this? Touch screen? What's the screen size and resolution? If you can, please attach a screen shot.

Please try Onboard 1.0.1 from our PPA at
https://launchpad.net/~onboard/+archive/stable
One of the changes made Onboard use more of the width on small resolution screens. I'm not sure this is helps in your case, but it's worth a try.

Changed in onboard (Ubuntu):
status: New → Incomplete
tuxiano (tuxiano) wrote :

Hi, sorry for my incomplete bug report.

Hardware spec:
Asus EP121
13" Touchscreen + Wacom.

I attached you a screenshot and I will try the stable ppa.

Thank you

tuxiano (tuxiano) wrote :

Hi, I tried the stable ppa, but it does not resolve the issue.

Best regards

marmuta (marmuta) wrote :

Thanks for the screen shot. This is actually close to what v1.0+ was meant to look like. Before v1.0, the keyboard used to stretch from side to side even on 21:9 monitors, for an awfully distorted appearance. Now there is an upper limit for the aspect ratio change, i.e. by (Ubuntu) default, for the given height it won't use more width than you see in the image.

Maybe this aspect limit is set too low and we should allow for more distortion, but I think the real problem is that there isn't enough vertical space for the keyboard. The height is controlled by unity-greeter.

What you can do now is to manually change the range of allowed aspect ratios. Create the file
/etc/onboard/onboard-defaults.conf
and add the lines

[main]
xembed-aspect-change-range=[0, 1.6]

If it's still too small for typing then increase the upper limit "1.6" further. Let me know what you settled on.

The Ubuntu default is currently
xembed-aspect-change-range=[0, 1.15]

Changed in onboard (Ubuntu):
status: Incomplete → Confirmed
tuxiano (tuxiano) wrote :

Hi,

1.6 is just fine. Right now its easy again to type my password.

Just a thought:
Since the vertical space is the constraint, perhaps you add a more vertical space efficient keypoard layout. The keyboard of the tungsten c for example only used four instead of five rows:

http://www.brighthand.com/images/tungsten_w_keyboard.gif

Thank you and best regards.

marmuta (marmuta) wrote :

Good thinking, we even have two layouts with four rows - Small and Phone. Compact is still the default, mainly for accessibility reasons (hover click), but you should be able to change the layout for the greeter by adding this to your /etc/onboard/onboard-defaults.conf.

layout=Phone

The known layouts are listed in the Layout tab in Onboard's preferences.

It impacts accessibility of a core package.

Changed in onboard (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 1.0.0-0ubuntu4

---------------
onboard (1.0.0-0ubuntu4) trusty; urgency=medium

  * Request for sponsorship (LP: #1303370)
  * debian/patches/add_defaults_for_ubuntu.patch:
    - Increase xembed aspect change range (LP: #1297695)
 -- Francesco Fumanti <email address hidden> Fri, 04 Apr 2014 21:11:15 +0200

Changed in onboard (Ubuntu):
status: Triaged → Fix Released
marmuta (marmuta) wrote :

I've changed the example configuration in trunk to 1.6 too.

Changed in onboard:
status: New → Fix Committed
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers