SRU request for bugfix release (debian.tar.gz for trusty provided)

Bug #1289592 reported by Francesco Fumanti on 2014-03-07
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
onboard (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Utopic
High
Unassigned
Vivid
High
Unassigned

Bug Description

Hi,

We have just created a new bugfix micro-release for the version of Onboard shipping with Ubuntu trusty and hope that you will be able to pick it up.

IMPACT
--------
It contains the following changes compared to the version currently shipping with trusty:

onboard (1.0.1-0ubuntu1) trusty; urgency=medium

  * Request for sponsorship for new upstream release (LP: #1289592)
  * debian/copyright:
    - Update and refine copyright section
  * debian/patches/add_defaults_for_ubuntu.patch:
    - Add more xembed entries to onboard-defaults.conf
  * Add initial support for org.gnome.interface scaling-factor > 1 (LP #1283491)
  * Catch Onboard becoming unresponsive due to invisible dialogs
  * Small fix in the word suggestion line of the layouts
  * Fix loading of desktop backgrounds with non-ascii filenames
  * Fix startup failures in case of no defined locale or non-unicode locales
  * Fix handling of hint file with wrong permissions in /tmp
  * Fix black bars when xembedding
  * Ignore x-offset when xembedding in unity-greeter on small screens
  * Add more entries about embedding to the system defaults example file
  * Don't activate the move button twice on press
  * Assume RGBA support exist without compositing only in unity-greeter
  * Show dialog to enable accessibility also if only word suggestions needs it
  * Close the language menu when the language button is pressed a second time
  * Fix back trace and hangs when using click buttons with python3.2 on precise
  * Work around broken introspection of GLib.filename_from_uri() on precise
  * Work around jumpy moves and resizes of keyboard after unhiding by auto-show
  * Update window manager quirk selection after name change in gnome-shell
  * Fix a GTK depreciation warning
  * Remove spurious debug output
  * Some code cleanup
  * Update translations

 -- Francesco Fumanti <email address hidden> Fri, 07 Mar 2014 21:38:09 +0100

TEST CASE
------------
- Set scaling-factor > 1 and verify that keys are properly sized. Fixes LP: #1283491
- This is a bug-fix micro-release. Install and test for a while to make sure of no regressions.

REGRESSION POTENTIAL
-----------------------
- The update contains a few relatively important fixes.
- Apart the ubuntu-desktop and the xubuntu-desktop metapackages, there is no other package depending on it; thus in the worst case of an Onboard breakage, it would be limited to Onboard itself.

Thanks in advance for taking the feature freeze exception request into account and feel free to post any questions you might have in this thread.

Cheers,

Francesco

Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
description: updated
Dmitry Shachnev (mitya57) wrote :

For FFe bugs, you need to first subscribe ubuntu-release, and if the FFe is approved, only then subscribe ubuntu-sponsors. Unsubscribing ubuntu-sponsors for now.

Francesco Fumanti (frafu) wrote :

Sorry for the error and thanks for putting this thread on the right track.

description: updated
tags: added: sru trusty
summary: - FFE request for bugfix release (debian.tar.gz for trusty provided)
+ SRU request for bugfix release (debian.tar.gz for trusty provided)
tags: added: utopic vivid
Amr Ibrahim (amribrahim1987) wrote :

This bug should be fixed first in vivid.

Iain Lane (laney) on 2015-02-11
Changed in onboard (Ubuntu Vivid):
status: New → Fix Released
Iain Lane (laney) wrote :

I'm uploading this, sorry we missed it at the time. The fixes all look reasonable to me - thanks for providing them.

Since it's now a SRU, someone might ask you to fill in the template information in this bug.

Francesco Fumanti (frafu) wrote :

FYI: In the meantime, there has also been a new minor release, which has already made its way into vivid:
https://bugs.launchpad.net/ubuntu/+source/onboard/+bug/1415041

If you want to test the new minor release also in utopic and trusty, you can get it from our stable PPA: FYI: In the meantime, there has also been a new minor release:
https://launchpad.net/~onboard/+archive/ubuntu/stable
Please, be aware that the debian/changelog of the utopic and trusty version of Onboard 1.1.0 in our stable PPA has not been rebased on the Onboard version of the corresponding Ubuntu release.

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

description: updated
description: updated
Amr Ibrahim (amribrahim1987) wrote :

Please upload to trusty-proposed.

Sebastien Bacher (seb128) wrote :

sponsored now, it's in the sru queue waiting for review

Changed in onboard (Ubuntu Utopic):
status: New → Won't Fix

Hello Francesco, or anyone else affected,

Accepted onboard into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/onboard/1.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in onboard (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
marmuta (marmuta) wrote :

I've tested onboard+onboard-data 1.0.1-0ubuntu1 from the -proposed repository on a fresh install of current trusty and didn't find any regressions.
Login and unlocking the screen work as before. The keyboard is usable with org.gnome.interface scaling-factor != 1 - I've tried 0.5, 1, 2 and 4 in display settings and typed with (multi-)touch and mouse devices. Language menu closes on second click. Auto-show, word suggestions, transparency, docking, etc. work as expected back in 1.0.1.

Iain Lane (laney) on 2015-09-07
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for onboard has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 1.0.1-0ubuntu1

---------------
onboard (1.0.1-0ubuntu1) trusty; urgency=medium

  * Request for sponsorship for new upstream release (LP: #1289592)
  * debian/copyright:
    - Update and refine copyright section
  * debian/patches/add_defaults_for_ubuntu.patch:
    - Add more xembed entries to onboard-defaults.conf
  * Add initial support for org.gnome.interface scaling-factor > 1 (LP #1283491)
  * Catch Onboard becoming unresponsive due to invisible dialogs
  * Small fix in the word suggestion line of the layouts
  * Fix loading of desktop backgrounds with non-ascii filenames
  * Fix startup failures in case of no defined locale or non-unicode locales
  * Fix handling of hint file with wrong permissions in /tmp
  * Fix black bars when xembedding
  * Ignore x-offset when xembedding in unity-greeter on small screens
  * Add more entries about embedding to the system defaults example file
  * Don't activate the move button twice on press
  * Assume RGBA support exist without compositing only in unity-greeter
  * Show dialog to enable accessibility also if only word suggestions needs it
  * Close the language menu when the language button is pressed a second time
  * Fix back trace and hangs when using click buttons with python3.2 on precise
  * Work around broken introspection of GLib.filename_from_uri() on precise
  * Work around jumpy moves and resizes of keyboard after unhiding by auto-show
  * Update window manager quirk selection after name change in gnome-shell
  * Fix a GTK depreciation warning
  * Remove spurious debug output
  * Some code cleanup
  * Update translations

 -- Francesco Fumanti <email address hidden> Fri, 07 Mar 2014 21:38:09 +0100

Changed in onboard (Ubuntu Trusty):
status: Fix Committed → Fix Released
tags: removed: sru
Changed in onboard (Ubuntu):
importance: Undecided → High
Changed in onboard (Ubuntu Trusty):
importance: Undecided → High
Changed in onboard (Ubuntu Utopic):
importance: Undecided → High
Changed in onboard (Ubuntu Vivid):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers