rendering and size issues on high-dpi screen

Bug #1283491 reported by Andreas E. on 2014-02-22
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Onboard
Medium
Unassigned
onboard (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

When the global scaling factor is set to 2, onboard is not usable for touch input. In docked mode (bottom half of screen), it draws keys too large and most of the onboard UI is not drawn at all. In windowed mode (with titlebar and resizeable), the size is correct but it does not refresh the rendering.

org.gnome.desktop.interface.scaling-factor = 2
org.gnome.desktop.interface.text-scaling-factor = 1.0

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: onboard 1.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Feb 22 17:44:03 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-02-02 (19 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140201)
SourcePackage: onboard
UpgradeStatus: No upgrade log present (probably fresh install)

Andreas E. (andreas-e) wrote :
Andreas E. (andreas-e) wrote :
description: updated
description: updated
marmuta (marmuta) wrote :

Thanks for testing that.
I hadn't noticed 'scaling-factor' yet, it apparently came to Trusty's g-s-d just this month. Setting it to 2 or higher indeed leads to the effect shown in your images, but there seem to be a range of other problems as well. I'll have a closer look.
Changing 'test-scaling-factor' doesn't seem to have any adverse effects.

Changed in onboard:
status: New → Confirmed
importance: Undecided → Medium
Changed in onboard (Ubuntu):
status: New → Confirmed
marmuta (marmuta) wrote :

I've pushed a couple of fixes. The larger rendering issues with scaling-factor>1 are gone and where needed for typing/resizing/moving etc., there is additional scaling. Currently, the keyboard seems to be usable in all modes.

However, there are still issues:
- The SVG Images we're using on some keys are blurry.
- The window position returned by Gtk for override redirect windows isn't scaled. I had to work around this, but if this turns out to be a bug, then a fix from Gtk's side will make Onboard unusable again.

So, I'll leave this bug open, but we should still try to get the existing fixes into Trusty (before it's too late).

marmuta (marmuta) wrote :

Time for an update. A couple other issues popped up since my last post: label popups were too small, docking struts were halve size and switching the scaling-factor at run-time would lead to weird effects. I've added workarounds for these and the blurry label problem as well.

I think that was it, though I still feel future Gtk/Gdk updates might put us in trouble again and workarounds will have to be reversed. I'll close the Onboard task for now, but please feel free to reopen it as needed.

The bug-fix release 1.0.1 has all the scaling-factor fixes. With a bit of luck it may even still get picked up for Ubuntu 14.04. We're trying, see bug #1289592.

Changed in onboard:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Francesco Fumanti (frafu) wrote :

You can use our PPA with the Onboard releases, if you want to use version 1.0.1 immediately:
https://launchpad.net/~onboard/+archive/stable

It impacts accessibility of a core package.

Changed in onboard (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged

Hi,
I'm not sure if this is the right place, but I also had problems with the ui scale in the system settings in Ubuntu 14.04 beta2.
When I change the ui scale value with my mouse, the ui changes and org.gnome.desktop.interface text-scaling-factor changes, too. But when I change the text-scaling-factor or the ui scale with keyboard nothing happens.
Example:
gsettings get org.gnome.desktop.interface text-scaling-factor // output is 1
gsettings set org.gnome.desktop.interface text-scaling-factor 2
gsettings get org.gnome.desktop.interface text-scaling-factor // output is 1

I hope this information helps you.

Greets

marmuta (marmuta) wrote :

@Matthias Bendel, FWIW I can't confirm this here.
gsettings set org.gnome.desktop.interface text-scaling-factor 2
gsettings get org.gnome.desktop.interface text-scaling-factor
2.0
The ui changes too.

Onboard isn't affected by text-scaling-factor anyway because all text is scaled with the window size. Maybe you want to file a bug report for unity-settings-daemon.

Andreas E. (andreas-e) wrote :

Thanks, the version 1.0.1 in the ppa renders properly. However, it is still not perfectly usable on the high-dpi screen because it expands to much to the top (I believe the snapping feature gets sometimes the window coordinates wrong). I will try to narrow it down to write a separate bug report.

Andreas E. (andreas-e) wrote :

I found it out. I am now sure this bug is fixed.
What I still saw appears to be a feature: When I opened the search dialog in geany (which I have usually placed in the lower half of the screen), onboard jumps out of the way so that the input field is not occluded. It makes sense, but wasn't obvious to me.

Changed in onboard (Ubuntu):
status: Triaged → Fix Released
Changed in onboard (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
Mathew Hodson (mathew-hodson) wrote :

This bug was fixed in the package onboard 1.0.1-0ubuntu1

---
onboard (1.0.1-0ubuntu1) trusty; urgency=medium

  * Request for sponsorship for new upstream release (LP: #1289592)
  * debian/copyright:
    - Update and refine copyright section
  * debian/patches/add_defaults_for_ubuntu.patch:
    - Add more xembed entries to onboard-defaults.conf
  * Add initial support for org.gnome.interface scaling-factor > 1 (LP: #1283491)
  * Catch Onboard becoming unresponsive due to invisible dialogs
  * Small fix in the word suggestion line of the layouts
  * Fix loading of desktop backgrounds with non-ascii filenames
  * Fix startup failures in case of no defined locale or non-unicode locales
  * Fix handling of hint file with wrong permissions in /tmp
  * Fix black bars when xembedding
  * Ignore x-offset when xembedding in unity-greeter on small screens
  * Add more entries about embedding to the system defaults example file
  * Don't activate the move button twice on press
  * Assume RGBA support exist without compositing only in unity-greeter
  * Show dialog to enable accessibility also if only word suggestions needs it
  * Close the language menu when the language button is pressed a second time
  * Fix back trace and hangs when using click buttons with python3.2 on precise
  * Work around broken introspection of GLib.filename_from_uri() on precise
  * Work around jumpy moves and resizes of keyboard after unhiding by auto-show
  * Update window manager quirk selection after name change in gnome-shell
  * Fix a GTK depreciation warning
  * Remove spurious debug output
  * Some code cleanup
  * Update translations

 -- Francesco Fumanti <email address hidden> Fri, 07 Mar 2014 21:38:09 +0100

Changed in onboard (Ubuntu Trusty):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers