onboard crashes on launch

Bug #1204896 reported by Susan Cragin on 2013-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Lenovo with a touch screen.
When I launch Onboard, it crashes. It usually crashes on launch but I think there was one time where it didn't crash until I pressed the first key.
While I'm on the subject, could onboard be made a bit more user-friendly and simple? Like the iPad?

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: onboard 0.99.0~alpha1~tr1190-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-5.14-generic 3.10.2
Uname: Linux 3.10.0-5-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
Date: Thu Jul 25 08:59:51 2013
InstallationDate: Installed on 2013-07-06 (19 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130703)
MarkForUpload: True
SourcePackage: onboard
UpgradeStatus: No upgrade log present (probably fresh install)

Susan Cragin (susancragin) wrote :
Francesco Fumanti (frafu) wrote :

If you don't mind running non-release versions of Onboard, you might try the updated version available in our PPA:
https://launchpad.net/~onboard/+archive/ppa

By the way, the version in the PPA also includes two new layouts, that resemble more the layouts found on mobile devices.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in onboard (Ubuntu):
status: New → Confirmed

I tried revision 1627 from the PPA (0.99.0+1627-0ppa~saucy1). I am running Kubuntu Saucy in VirtualBox. And it is crashing for me, too. The output from the terminal is:

htpc@htpc-VirtualBox:~$ onboard
Traceback (most recent call last):
  File "/usr/bin/onboard", line 16, in <module>
    ob = Onboard()
  File "/usr/lib/python3/dist-packages/Onboard/OnboardGtk.py", line 111, in __init__
    self.init()
  File "/usr/lib/python3/dist-packages/Onboard/OnboardGtk.py", line 210, in init
    self.keyboard_widget.set_startup_visibility()
  File "/usr/lib/python3/dist-packages/Onboard/KeyboardWidget.py", line 327, in set_startup_visibility
    self.commit_transition()
  File "/usr/lib/python3/dist-packages/Onboard/KeyboardWidget.py", line 546, in commit_transition
    self._on_transition_step()
  File "/usr/lib/python3/dist-packages/Onboard/KeyboardWidget.py", line 583, in _on_transition_step
    window.set_visible(visible)
  File "/usr/lib/python3/dist-packages/Onboard/KbdWindow.py", line 288, in set_visible
    self._show_first_time()
  File "/usr/lib/python3/dist-packages/Onboard/KbdWindow.py", line 169, in _show_first_time
    self.pre_render_keys(*self.get_size())
  File "/usr/lib/python3/dist-packages/Onboard/KbdWindow.py", line 178, in pre_render_keys
    self.keyboard_widget.pre_render_keys(self, w, h)
  File "/usr/lib/python3/dist-packages/Onboard/KeyboardWidget.py", line 345, in pre_render_keys
    self.render(context)
  File "/usr/lib/python3/dist-packages/Onboard/LayoutView.py", line 204, in render
    item.draw_cached(context)
  File "/usr/lib/python3/dist-packages/Onboard/KeyGtk.py", line 128, in draw_cached
    surface = self._create_key_surface(context)
  File "/usr/lib/python3/dist-packages/Onboard/KeyGtk.py", line 147, in _create_key_surface
    self.draw(context)
  File "/usr/lib/python3/dist-packages/Onboard/KeyGtk.py", line 155, in draw
    self.draw_image(context, lod)
  File "/usr/lib/python3/dist-packages/Onboard/KeyGtk.py", line 483, in draw_image
    pixbuf = self.get_image(rect.w, rect.h)
  File "/usr/lib/python3/dist-packages/Onboard/KeyGtk.py", line 709, in get_image
    new_from_file_at_size(filename, width, height)
gi._glib.GError: Unrecognized image file format

I don't know where I can find the log files - so I've written print(filename) in an appropiate place. The image file mentioned is /usr/share/onboard/layouts/images/erase.svg, I hope that helps.

marmuta (marmuta) wrote :

Thanks for trying the PPA, Jörn.
You can get a debug log that shows the file names of loaded images with
$ onboard -ddebug
 but now that you found the file, I think I won't need this anymore.

Does this print anything?
$ /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders | grep -i svg

Does this make a difference?
$ sudo apt-get install librsvg2-common

Please attach that svg file /usr/share/onboard/layouts/images/erase.svg here.

It works now, with librsvg2-common - but I am not 100% sure, if that fixed it. If you want I can set up a VM tomorrow and check that. Just for the records, the erase.svg:

joern@joern-notebook:~$ cat /usr/share/onboard/layouts/images/erase.svg
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!-- Created with Inkscape (http://www.inkscape.org/) -->
<svg id="svg2985" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" height="16" width="16" version="1.1" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/">
 <metadata id="metadata2990">
  <rdf:RDF>
   <cc:Work rdf:about="">
    <dc:format>image/svg+xml</dc:format>
    <dc:type rdf:resource="http://purl.org/dc/dcmitype/StillImage"/>
    <dc:title/>
   </cc:Work>
  </rdf:RDF>
 </metadata>
 <rect id="rect3760" style="color:#000000;stroke:#000;stroke-width:.75;fill:none" ry="0" height="7.2" width="9.6" y="4.7" x="3.2"/>
 <path id="path3764" style="stroke:#000;stroke-linecap:round;stroke-width:.75;fill:none" d="m6.3456 9.9543 3.3088-3.3087"/>
 <path id="path3772" style="stroke:#000;stroke-linecap:round;stroke-width:.75;fill:none" d="m9.6544 9.9543-3.3088-3.3087"/>
</svg>

marmuta (marmuta) wrote :

Yes, the missing librsvg2-common must have been the reason. That package wasn't on our radar before, but I see now we have only a suggest dependency via libgtk-3-0. I could imagine a fresh Kubuntu not having it. If you'd like to confirm this, yes please, try a new VM.
In any case, we better add that package as a direct dependency of Onboard.

marmuta (marmuta) on 2013-10-19
Changed in onboard:
status: New → Confirmed

I have double-checked that, librsvg2-common was the missing dependency.

marmuta (marmuta) wrote :

Thank you, I've added the dependency and improved the error handling in trunk.

Changed in onboard:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package onboard - 1.0.0-0ubuntu1

---------------
onboard (1.0.0-0ubuntu1) trusty; urgency=low

  * Request for sponsorship for new upstream release (LP: #1282231)
  * debian/control:
    - Raise Standards-Version to 3.9.5
    - Add librsvg2-common to Depends for Kubuntu (LP: #1204896)
  * debian/onboard.install:
    - Use usr/share/onboard/onboard-defaults.conf* instead of single entries
    - Add the usr/share/onboard/tools/checkmodels file
  * debian/patches/add_defaults_for_ubuntu.patch:
    - Update add_defaults_for_ubuntu.patch with values for this release
  * Word suggestions enhancements:
    - Every language id now has its own user language model
    - Add a checkbox to the Preferences to show the language switch on layouts
    - Add a checkbox to the Preferences to show the pause learning button
    - Add Canadian English system language model
    - Add Danish system language model
    - Add various flavors of the Dutch system language model
    - Add Gaelic system language model
    - Add Greek system language model
    - Add Irish system language model
    - Add Luxembourgian system language model.
    - Add Polish system language model
    - Add Romanian system language model
    - Add Swedish system language model
    - Add Turkish system language model
    - Update Brazilian system language model
    - Improve makemodels script
    - Add model_info tool
    - Add checkmodels tool to diagnose language model loading errors
    - Add tool to randomize sentences in corpora
    - Add copy function to allow transfer between language models
    - Add smart support for camel-case words (Thanks Michael Bauer)
    - Make language switcher more user-friendly (Thanks Michael Bauer)
    - Stop word correction when spell checker dictionary is not present
    - Fix learning of text spans larger than 100 characters
    - Fix word suggestions sometimes being unaware of modifier presses
    - Fix all upper-case words not being suggested at sentence begin
    - Fix wrong caret position in rename function of Nautilus
    - Fix some character deletion on focus change after a word completion
    - Fix bit rot in split_corpus tool
    - Improve handling of the / and other non-word tokens
    - Improve support for URLs and directories
    - Don't learn passwords from URLs
    - Show dialog on language model loading error (LP: #1278599)
  * Layouts:
    - Add support for polygonal keys instead of only rectangles (LP: #1259371)
    - Make the Return key of the Compact and Full Keyboard layouts a polygon
    - Don't write suggestions outside prediction area in Onboard
    - Grid layout: add settings,move,hide,quit and click buttons (LP: #754391)
    - Add Whiteboard and Whiteboard wide layouts (contributed by Johannes Almer)
    - Add short and long description to the layouts
    - Perform small visual improvements
  * Change the design of the layout section in the Preferences
  * Tweak themes lightly
  * Click buttons:
    - Add support for new mousetweaks branch (version >= 3.9)
    - Fix CSClickMapper sometimes erroneously claiming to be active
  * Add dependencies check to setup.py
  * Add gsettings key to choose between App...

Read more...

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
Francesco Fumanti (frafu) wrote :

This bug should be fixed with the 1.0.0 release. If you still encounter problems, please feel free to reopen this bug or file a new one.

Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers