onboard.convert causes gsettings-data-convert to crash

Bug #1123789 reported by Jim Nelson on 2013-02-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Low
Unassigned

Bug Description

When onboard is installed, running gsettings-data-convert manually on Precise causes the converter to crash after reporting a problem with the 'x' key in apps.onboard.

After uninstalling onboard, gsettings-data-convert runs fine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in onboard (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks Jim, could you provide some details:
- what's the stdout/stderr output of gsettings-data-convert? have a gdb backtrace or the name of the key it's complaining about would be useful
- what version of Ubuntu did you upgrade from? the other bugs linked to this one in launchpad and upstream mention skipping releases on upgrade, which is not a supported scenario (and should be the case of few users in practice, even if that's still an issue)
- is that a new issue? it's weird that with precise out for almost a year we didn't hear about it before

Changed in onboard (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
marmuta (marmuta) wrote :

Sebastien, I can reproduce the error in a Precise VM:

$ gconftool-2 -s /apps/onboard/horizontal_position -t int 10
$ sed -i "s/onboard.convert;//" ~/.local/share/gsettings-data-convert
$ gsettings-data-convert --file /usr/share/GConf/gsettings/onboard.convert
(gsettings-data-convert:25137): GLib-GIO-ERROR **: Settings schema 'apps.onboard' does not contain a key named 'x'
Trace/breakpoint trap (core dumped)

There's clearly a problem with Onboard 0.97.x. 'onboard.convert' references non-existent gsettings keys apps.onboard.x/y/width/height. I let this slip through testing apparently.

The switch from gconf to gsettings came with Onboard 0.96, so this must have been a migration from <=0.95 to 0.97, skipping 0.96. If I'm not mistaken, upgrades from Oneiric and earlier to Precise had to be affected. I can't really explain why we haven't heard of this issue earlier.

Onboard 0.98 and later don't seem to be affected.

marmuta (marmuta) wrote :

Jim, as a workaround try removing Onboard's pre-0.96 preferences. This should stop the migration and allow Onboard to install.

gconftool-2 --recursive-unset /apps/onboard

marmuta (marmuta) on 2013-02-13
Changed in onboard (Ubuntu):
status: Incomplete → Confirmed
Jim Nelson (yorba-jim) wrote :

The error message marmuta generated is the exact message I was seeing. Sorry for not including that in my bug report -- it was late last night and a little bleary-eyed.

I removed the onboard package entirely to get around the problem, I don't know why I had it installed in the first place.

marmuta (marmuta) wrote :

Thanks for the confirmation, Jim. Onboard is (still) installed by default, you didn't need to to anything to get it.

I've fixed the Onboard problem in the 0.97 branch. Sebastien, should we ask for an SRU for Precise? Only the onboard.convert file changed.

marmuta (marmuta) wrote :

FYI, here's a backtrace of gsettings-data-convert from before the fix.

marmuta (marmuta) on 2013-02-13
Changed in onboard (Ubuntu):
status: Confirmed → Fix Committed
Changed in onboard:
status: New → Fix Committed
Changed in onboard (Ubuntu):
status: Fix Committed → Confirmed
marmuta (marmuta) wrote :

I've double checked, upgrades from Oneiric to Precise should have been mostly safe. Oneiric started out with Onboard 0.95.1, but 0.96.1 arrived with SRU lp:880085 in oneiric-updates. Going through Onboard 0.95->0.96->0.97 doesn't trigger this bug. I guess that's the main reason we haven't heard of this problem before. Asking for a SRU seems less necessary for now. We're prepared anyway, though, just in case.

Francesco Fumanti (frafu) wrote :

Hi,

I have uploaded a snapshot of the current development status of Onboard containing a fix for this bug and other new features to our main PPA:
https://launchpad.net/~onboard/+archive/ppa

The snapshot is available for raring and for saucy.

Have a nice day.

Changed in onboard:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package onboard - 0.99.0-0ubuntu1

---------------
onboard (0.99.0-0ubuntu1) saucy; urgency=low

  * Request for sponsorship for new upstream release (LP: #1215164)
  * debian/control:
    - Add libcanberra-dev, libxkbfile-dev and libhunspell-dev to Build-Depends
    - Raise Standards-Version to 3.9.4
    - Remove python3-virtkey from Depends
    - Add libxkbfile1, libcanberra0, libhunspell-1.3-0 and iso-codes to Depends
    - Define new package onboard-data package for all architectures
    - Add onboard-data to Recommends
    - Update description of onboard package
  * debian/control_python2.in: removed
  * debian/control_python3.in: removed
  * debian/onboard.install: new file to split keyboard from the prediction data
  * debian/onboard-data.install: new file with the prediction data for onboard
  * debian/rules:
    - Remove support for python2
    - Add override_dh_auto_install target to use debian/tmp
    - Add override_dh_install target
  * debian/patches/add_defaults_for_ubuntu.patch:
    - Update add_defaults_for_ubuntu.patch with values for this release
  * Long press popup:
    - Hide long press popup when keyboard gets hidden
    - Add possibility to show arbitrary layouts in popups
    - Add character alternatives for most latin based languages
  * Add key-press feedback:
    - Size of label popup stored in gsettings-key
    - Also allow images in the touch feedback
    - Don't show feedback popup when xembedded
  * Add sound feedback:
    - New dependency: libcanberra
    - Add 'Play sound' option to the Preferences dialog
  * Add word suggestions:
    - Add tools to create language models (lm) from large corpora
    - Learn from typed text by default
    - Limit over-learning in the terminal with additional filters.
    - Use UTF-8 encoding internally (cuts memory usage)
    - Fall back to hard-coded country codes if there is no lm for current locale
    - Add initial system language models for: de_AT, de_CH, de_DE, en_AU,
      en_ES, en_GB, en_US, fr_fr, it_IT, pt_BR, pt_PT, ru_RU
    - Optimize system language models for size/memory usage.
    - Use case insensitive predictions most of the time
    - Offer spelling suggestions based on the hunspell C-API
    - Auto-add word separators
    - Add word suggestion row to all layouts
    - Make word suggestion also work when using the scanning mode
    - Doctests available for English, German, Italian, Portuguese, Russian and
      Spanish
  * Add auto-capitalization
    - Off by default because very new
    - Add corresponding option to the Preferences of Onboard
    - Independent of word suggestions
  * Add XInput as a new event source and make it the default: (LP: #905636)
    - Fall back to GTK event handling if XInput 2.2 isn't available
    - Allow switching between GTK and XInput events without restarting Onboard
    - Listen only to the XInput client pointer and its slaves
    - Make XInput target specific windows instead of root window
    - Support Multi-touch
    - Don't count scroll-wheel movement as button presses
    - Grab pointer even if click is performed by different device than movement
    - Fix pointer becoming unresponsive on wetab...

Read more...

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers