onboard crashed with signal 5 in _XReply()

Bug #1016980 reported by Roman Stingler on 2012-06-23
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Onboard
Medium
Unassigned
onboard (Ubuntu)
Medium
Unassigned

Bug Description

crashed after restart

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: onboard 0.97.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic x86_64
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sat Jun 23 23:02:22 2012
ExecutablePath: /usr/bin/onboard
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120413)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/onboard
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: onboard
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XGetWindowProperty () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XGetTextProperty () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/python2.7/dist-packages/Onboard/osk.so
Title: onboard crashed with signal 5 in _XReply()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Roman Stingler (coolx67) wrote :

StacktraceTop:
 XGetWindowProperty (dpy=0x1a9cc00, w=14680069, property=303, offset=0, length=1000000, delete=0, req_type=0, actual_type=0x7fffc9909278, actual_format=0x7fffc990929c, nitems=0x7fffc9909280, bytesafter=0x7fffc9909288, prop=0x7fffc9909290) at ../../src/GetProp.c:61
 XGetTextProperty (display=<optimized out>, display@entry=0x1a9cc00, window=<optimized out>, window@entry=14680069, tp=tp@entry=0x7fffc9909310, property=<optimized out>) at ../../src/GetTxtProp.c:71
 get_window_name (window=14680069, display=0x1a9cc00) at Onboard/osk/osk_util.c:736
 osk_util_get_current_wm_name (self=<optimized out>) at Onboard/osk/osk_util.c:775
 PyEval_EvalFrameEx ()

Changed in onboard (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: a11y
marmuta (marmuta) wrote :

Confirming, as Francesco has seen this happening before. X reports BadWindow in XGetWindowProperty.

Changed in onboard (Ubuntu):
status: New → Confirmed
Changed in onboard:
status: New → In Progress
marmuta (marmuta) wrote :

Fixed in trunk, I believe. Needs more testing though, I still can't reproduce the X errors here. Francesco, when you get the chance to test trunk, please let me know how it goes.

Changed in onboard:
status: In Progress → Fix Committed
importance: Undecided → Medium
Francesco Fumanti (frafu) wrote :

@Roman

I have uploaded a snapshot with the fix to our Snapshots PPA for quantal:
https://launchpad.net/~onboard/+archive/snapshots
It is Onboard version 0.97.1+tr868-0ppa~quantal3 and probably also newer versions that might appear in the future.

Be aware that this version of Onboard is based on python3 and thus you will need version 0.61.0 of virtkey for it to work. This version is waiting for the Ubuntu developers to be reviewed and to be uploaded to the ubuntu quantal repositories. In the meantime, you can get it from my PPA:
https://launchpad.net/~frafu/+archive/ppa

tags: added: running-unity
Launchpad Janitor (janitor) wrote :
Download full text (4.7 KiB)

This bug was fixed in the package onboard - 0.98.0-0ubuntu1

---------------
onboard (0.98.0-0ubuntu1) quantal; urgency=low

  * Freeze exception request for new upstream release (LP: #1041303)
  * debian/pycompat: removed as not used anymore
  * debian/control:
    - Build-Depends:
      + replace python and python-all-dev with python3-all-dev
      + replace python-distutils-extra with python3-distutils-extra
      + remove libxi-dev as libgtk-3-dev pulls it in
    - remove X-Python-Version and set X-Python3-Version: >= 3.2
    - Depends:
      + remove ${python:Depends}, python-cairo, python-dbus,
        python-virtkey (>= 0.60.0) and gir1.2-wnck-3.0
      + add ${python3:Depends}, python3-cairo, python3-gi-cairo,
        python3-dbus and python3-virtkey (>= 0.61.0)
  * debian/rules:
    - enhance it to work with python2 and python3
    - add procedure to switch between python2 and python3
    - add --without python-support to appease lintian
  * debian/onboard.lintian-override:
    - override missing manual message
    - override extra-license-file message
  * Move gsettings path to /org/onboard (LP: #982699); thanks R. Ancell
  * Various visual improvements:
    - push down effect on keys
    - keys now have shadows
    - smaller touch handles
    - tweak images used by click buttons and other keys
    - smoother transparency transitions
  * Detect window manager to care for its specificities
  * Add command line option to override automatic environment detection
  * Mark command line help as translatable
  * Add middle click in hover click mode; requires mousetweaks >= 3.3.90
  * Various auto-show fixes
  * Stop endless loop of auto-show on top of unity dash
  * Fix some show/hide problems
  * Stop wiggling of launcher icons on show/hide of keyboard window
  * Various python3 adaptions, trying to keep python2 compatibility
  * Move to python3 needs virtkey version >= 0.61.0
  * Switch all translated strings to unicode (LP: #933030)
  * Make python3 the default
  * Don't show disabled buttons when XEmbedding (LP: #1019593)
  * Don't create the icon palette when XEmbedding
  * Add new color scheme to follow the HighContrastInverse theme update
  * Stayon top of full-screen windows in force-to-top mode (LP: #1035578)
  * Fix keyboard and icon palette not always above dash
  * Add lockdown key to disable all dwell-activation
  * Adapt to WM_NAMEs of Unity version 6
  * Write message listing dependencies when sdist fails
  * Add tests to check translations for errors, uses python-nose
  * Make Onboard more robust against translation errors
  * Make icon palette dwellable
  * Add dconf version detection, thanks Robert Ancell
  * Fix Super key (LP: #900191)
  * Make menu key pop up context menu
  * Separate layout loading from the keyboard widget
  * Improve exception handling for theme and color files
  * Limit keyboard size when it doesn't fit on screen (LP: #991318)
  * Trap various X BadWindow errors (LP: #1016980)
  * Work around regression of configure event in quantal
  * Remove wnck dependency as gtk3's window-state-event reports iconification
  * Prevent zombie process when launching preferences (LP: #936332)
  * Only appear in gnome...

Read more...

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers