Okular in repository is ancient and crasjhes system

Bug #1866561 reported by rrhobbs on 2020-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
okular (Ubuntu)
Undecided
Unassigned

Bug Description

SUMMARY
Okular partially locks system

STEPS TO REPRODUCE
1. open pdf document

OBSERVED RESULT
1. Attempt to access other open apps / Plasma via mouse fails altho
2. keyboard works / terminal is available via cli and terminal works as long as typing within about 10 sec of open; else locks up as well
3. CtlC will close terminal
4. Killall okular will unlock system

EXPECTED RESULT
Normal operation

SOFTWARE/OS VERSIONS
Windows:
macOS:
Linux/KDE Plasma: Kubuntu 18.04
(available in About System)
KDE Plasma Version: 5.12.9
KDE Frameworks Version: 5.44.0
Qt Version: 5.9.5

ADDITIONAL INFORMATION
[reply] [−]Comment 1Albert Astals Cid 2020-03-08 16:50:53 UTC
All pdf files?

Also, you have not specified the okular version.
[reply] [−]Comment <email address hidden> 2020-03-08 17:17:31 UTC
>>> All pdf files?

<<< Good point / thanks. Problem only started with a document I have only started opening frequently lately. Worked great up to now. Will advise any problems additional docs.

>>> Also, you have not specified the okular version.

<<< 1.3.3
[reply] [−]Comment 3Albert Astals Cid 2020-03-08 18:21:27 UTC
1.3.3 is ancient. Please update to something newer, if this used to work and an update broke it, you may want to contact the Kubuntu people

Rik Mills (rikmills) wrote :

I use that version of okular all the time with no such issues. Additionally, if this was a generic problem or one caused by an update, then it is highly likely there would be multiple reports of this, and I have not seen that. It sounds very much like some issue specific to your system.

Changed in okular (Ubuntu):
status: New → Incomplete
Brian Foster (blfoster) wrote :

I also use okular v1.3.3 all the time without the described issue.
It *might* have something to do with the _particular_ PDF you are
trying to open. I would suggest that, if possible, you attach the
failing PDF to this bug report.

Also, it's unclear (to me) from your description if the PDF which
is now failing used to work? *If* it did, *and* you still have a
working copy, *and* it is possible to attach it, then I would also
suggest attaching the (previously-)working PDF to this bug report.

Please ensure it is clear which (attached) PDF is failing, and also
which one is working.

Finally, any idea if there is, e.g., "excessive" memory consumption
or I/O?

rrhobbs (rrhobbs-geo) wrote :

Issues havent happened f a few weeks / honestly I have quit using Okular, instead using the gnome app "Document Viewer".

I have KDE desktop installed on my Ubuntu (Dell repo) so I guess some weirdness is to be expected.

In a few weeks or so will get new 20.04 LTS so will all be a new game....

Thx all f your time and interest

Launchpad Janitor (janitor) wrote :

[Expired for okular (Ubuntu) because there has been no activity for 60 days.]

Changed in okular (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers