No network showing from the dialer app even though phone calls are possible

Bug #1598181 reported by Jim Hodapp on 2016-07-01
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
turbo
Undecided
Unassigned
dialer-app (Ubuntu)
Medium
Gustavo Pichorim Boiko
indicator-network (Ubuntu)
Undecided
Unassigned
ofono (Ubuntu)
High
Alfonso Sanchez-Beato

Bug Description

I noticed that I am seeing "No network" being displayed in the upper right hand corner of the dialer app even though I am able to make phone calls. This is on turbo and using the smaller SIM slot (#2) with T-Mobile in the US.

Build version info:

current build number: 116
device name: turbo
channel: ubuntu-touch/rc-proposed/ubuntu
last update: 2016-07-01 09:38:31
version version: 116
version ubuntu: 20160701
version device: 20160617-82a5c0d
version custom: 20160701

Jim Hodapp (jhodapp) wrote :
Jim Hodapp (jhodapp) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ofono (Ubuntu):
status: New → Confirmed
Jim Hodapp (jhodapp) on 2016-07-27
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
status: New → Confirmed
Tony Espy (awe) wrote :

A quick look at the list-modems output shows the following for the NetworkRegistration interface for SIM1:

 [ org.ofono.NetworkRegistration ]
        Mode = auto
        Strength = 100
        Name =
        Technology = umts
        Status = registered
        LocationAreaCode = 20498
        CellId = 15168848

Perhaps the lack of an operator "Name" is causing the dialer-app to show "No Network"?

Changed in dialer-app (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in dialer-app (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Seth (seth-ciango) wrote :

I have created a video and log file to demonstrate some of the behavior.

Step 1: Notice "No Network" at dialer screen for "SIM 2 AT&T." "SIM 1 Cricket" shows connected
Step 2: Visually verify connections
Step 3: Select SIM 2 AT&T at the dialer screen
Step 4: Successfully dial the US Naval Observatory Time Announcer to verify connection to AT&T network
Step 5: Hang up
Step 6: Visually verify that "No Network" is still displayed for "SIM 2 AT&T"

This happens no matter which SIM card is in which slot. In this instance, AT&T was not showing service. However, Cricket and T-Mobile will exhibit the same behavior of "No Network" yet successfully make phone calls.

Seth (seth-ciango) wrote :

Attaching Video File

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in ofono (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Jim Hodapp (jhodapp) on 2016-08-12
Changed in ofono (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ofono (Ubuntu):
importance: Undecided → High
Changed in indicator-network (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → 13
Jim Hodapp (jhodapp) on 2016-08-17
Changed in ofono (Ubuntu):
status: In Progress → Fix Committed
Changed in dialer-app (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ofono - 1.17.bzr6921+16.10.20160819.6-0ubuntu1

---------------
ofono (1.17.bzr6921+16.10.20160819.6-0ubuntu1) yakkety; urgency=medium

  [ Alfonso Sanchez-Beato (email Canonical) ]
  * Fix network name parsing for turbo (LP: #1598181)

 -- Alfonso Sanchez-Beato <email address hidden> Fri, 19 Aug 2016 11:08:32 +0000

Changed in ofono (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Andrew DeMarsh (andrewdemarsh) wrote :

I'm not sure this is fixed in OTA-13 I just updated and am now receiving the denied message via sim slot 2 on the Virgin Mobile Canada (Reseller of Bell) Network. I had no problem before.

Pat McGowan (pat-mcgowan) wrote :

@andrew that sounds like a different issue, can you enter the bug and provide all your system information

The bug below was originally created because of the "DENIED" issue and got
merged with the "No Network" issue. I agree that they look like two
separate problems affecting users in multiple countries.

https://bugs.launchpad.net/ubuntu/+source/ofono/+bug/1592232

On Wed, Sep 21, 2016 at 1:59 PM, Pat McGowan <email address hidden>
wrote:

> @andrew that sounds like a different issue, can you enter the bug and
> provide all your system information
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1592232).
> https://bugs.launchpad.net/bugs/1598181
>
> Title:
> No network showing from the dialer app even though phone calls are
> possible
>
> Status in Canonical System Image:
> Fix Released
> Status in turbo:
> New
> Status in dialer-app package in Ubuntu:
> Invalid
> Status in indicator-network package in Ubuntu:
> Invalid
> Status in ofono package in Ubuntu:
> Fix Released
>
> Bug description:
> I noticed that I am seeing "No network" being displayed in the upper
> right hand corner of the dialer app even though I am able to make
> phone calls. This is on turbo and using the smaller SIM slot (#2) with
> T-Mobile in the US.
>
> Build version info:
>
> current build number: 116
> device name: turbo
> channel: ubuntu-touch/rc-proposed/ubuntu
> last update: 2016-07-01 09:38:31
> version version: 116
> version ubuntu: 20160701
> version device: 20160617-82a5c0d
> version custom: 20160701
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1598181/+
> subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers