add "Preferred" property to ConnectionContext interface

Bug #1361864 reported by Antti Kaijanmäki on 2014-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
libqofono (Ubuntu)
High
Jonas G. Drange
network-manager (Ubuntu)
High
Tony Espy
network-manager (Ubuntu RTM)
High
Tony Espy
nuntium (Ubuntu)
High
Alfonso Sanchez-Beato
nuntium (Ubuntu RTM)
High
Alfonso Sanchez-Beato
ofono (Ubuntu)
High
Alfonso Sanchez-Beato
ofono (Ubuntu RTM)
High
Alfonso Sanchez-Beato
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange
ubuntu-system-settings (Ubuntu RTM)
High
Jonas G. Drange

Bug Description

To implement system-settings APN editor reliably there has to be a Tag field with is an arbitrary non user-visible string that can be set for any Context.

We also need org.ofono.ConnectionManager.AddContext which takes a variant map with prepopulated values for the context to be created, so we can have a function in QOfono QOfonoConnectionManager::addContextWithTag(QString tag).

Related branches

Changed in ofono (Ubuntu):
importance: Undecided → Wishlist
Tony Espy (awe) wrote :

We've gone this path before... and met with incredible resistance from upstream ( and so did Jolla ) to this idea, so we went with the smarts for which context is "preferred" delegated to Network Manager and nuntium.

If you still feel strongly about this, we can revisit during the sprint.

Changed in ofono (Ubuntu):
status: New → Incomplete
Tony Espy (awe) on 2014-10-20
Changed in ofono (Ubuntu):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Tony Espy (awe) wrote :

Moved status to Invalid as this isn't something I'm convinced we need.

Changed in ofono (Ubuntu):
status: Incomplete → Invalid
Tony Espy (awe) on 2015-03-17
Changed in ofono (Ubuntu):
status: Invalid → Confirmed
Tony Espy (awe) wrote :

Changed back to Incomplete, as this came up again during a meeting this morning to discuss the current state of the APN editor.

I think what's needed is some way to indicate that an APN/context is the preferred APN for a Internet and/or MMS.

I'm not quite sure why a generic tag was proposed, as I think a simple boolean 'Preferred' property would suffice. Doing this also means we wouldn't need to add a new method either.

Note, NetworkManager currently reads the ofono gprs contexts directly from ofono's settings file ( /var/lib/ofono/<IMSI/gprs ), which isn't ideal. I'll create a backlog task for NM, as this really should be done via DBus.

Also, if we were to implement this, NM's ofono code would need to change to honor the 'Preferred' APN, and ignore the other APNs. Nuntium would also have to change to honor this new property as well.

Bill Filler (bfiller) on 2015-03-27
Changed in ofono (Ubuntu):
assignee: Antti Kaijanmäki (kaijanmaki) → Alfonso Sanchez-Beato (alfonsosanchezbeato)
importance: Wishlist → High
Changed in network-manager (Ubuntu):
importance: Undecided → High
Changed in nuntium (Ubuntu):
importance: Undecided → High
Tony Espy (awe) on 2015-03-27
Changed in nuntium (Ubuntu):
status: New → Confirmed
Changed in network-manager (Ubuntu):
status: New → Confirmed
assignee: nobody → Tony Espy (awe)
tags: added: apn

This brach

https://github.com/rilmodem/ofono/pull/173

implements a per-context "Preferred" property that can be used freely by the ofono clients to express preference on context activation.

Changed in ofono (Ubuntu):
status: Confirmed → In Progress
Tony Espy (awe) on 2015-04-01
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Tony Espy (awe) on 2015-04-01
Changed in ofono (Ubuntu):
status: In Progress → Fix Committed
Jonas G. Drange (jonas-drange) wrote :

Can we use this tag for MMS as well? Since we cannot query nuntium directly (as per [1]).

[1] https://bugs.launchpad.net/ubuntu/+source/nuntium/+bug/1370660/comments/7

@Jonas, yes, it can be used for MMS too. There is in fact no restriction on how this flag is used on the ofono side. Whatever needs to be enforced is something between system-settings and NetworkManager. For ofono, it is just a property that can be read and written from outside, and it is not used internally.

no longer affects: libqofono (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ofono - 1.12.bzr6892+15.04.20150407-0ubuntu1

---------------
ofono (1.12.bzr6892+15.04.20150407-0ubuntu1) vivid; urgency=medium

  [ Alfonso Sanchez-Beato ]
  * ubuntu-apndb.c, src/common.c, test-common.c: provision IA APNs
    LTE modems may require a new IA APN for non-GPRS operation,
    this change allows a new IA APN type to be provisioned along
    with Internet and MMS APNs.
  * gril/grilunsol.c: LTE signal strength fix (LP: #1433867)
  * ubuntu-apndb.c: load APNS w/out explict type (LP: #1437200)
  * mtkodem, plugins/mtk.c, unit/tesk-mtkunsol.c: Dynamic MTK firwmare switching
    This change causes the firmware on specific MTK-based phone to be
    dynamically switched/reset based on SIM type and roaming conditions.
  * include, plugins/mtk.c, src/modem.c, gprs.c: set data for just one slot (LP: #1413672)
    Make sure ConnectionManager.Powered property is set for only one slot in
    case the modem is of type dual SIM stand-by.
  * doc, gprs: add 'Preferred' property to GPRS contexts (LP: #1361864)
 -- CI Train Bot <email address hidden> Tue, 07 Apr 2015 06:50:28 +0000

Changed in ofono (Ubuntu):
status: Fix Committed → Fix Released
Changed in libqofono (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Jonas G. Drange (jonas-drange)
Changed in libqofono (Ubuntu):
status: Confirmed → In Progress
Tony Espy (awe) on 2015-05-07
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in libqofono (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jonas G. Drange (jonas-drange)
Tony Espy (awe) on 2015-05-13
summary: - add "Tag" property to ConnectionContext interface
+ add "Preferred" property to ConnectionContext interface
Changed in nuntium (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww22-2015
tags: added: connectivity
Changed in nuntium (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww22-2015 → ww24-2015
Tony Espy (awe) on 2015-06-04
Changed in ofono (Ubuntu RTM):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Changed in ofono (Ubuntu):
status: Fix Released → In Progress
Changed in nuntium (Ubuntu):
status: Fix Released → In Progress
Changed in nuntium (Ubuntu RTM):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
status: New → In Progress
Tony Espy (awe) wrote :

At a meeting this week, we decided that all of the components that may activate and/or use a context, should set the 'Preferred' flag for the context if it's successfully activated and/or used ( eg. a context is used by ofono for the INITIAL_ATTACH APN request; if this succeeds, ofono will set the context as 'Preferred' ).

As such, I've re-opened the bug tasks for the affected packages ( network-manager, nuntium, and ofono itself ), and made sure we have Ubuntu (RTM) tasks for the same to track their release as updates.

Changed in ubuntu-system-settings (Ubuntu RTM):
status: New → In Progress
assignee: nobody → jgdx (jgdx)
assignee: jgdx (jgdx) → Jonas G. Drange (jonas-drange)
Changed in network-manager (Ubuntu RTM):
importance: Undecided → High
status: New → In Progress
Changed in nuntium (Ubuntu RTM):
importance: Undecided → High
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
Changed in ubuntu-system-settings (Ubuntu RTM):
importance: Undecided → High
Tony Espy (awe) on 2015-06-09
Changed in network-manager (Ubuntu RTM):
assignee: nobody → Tony Espy (awe)
Changed in canonical-devices-system-image:
milestone: ww24-2015 → ww28-2015
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ofono - 1.12.bzr6900+15.10.20150702.3-0ubuntu1

---------------
ofono (1.12.bzr6900+15.10.20150702.3-0ubuntu1) wily; urgency=medium

  [Tony Espy]
  * test/rilmodem/sim: fix testing scripts for arale (LP: #1457775)
  * test: reverse meaning of list-modems -p (LP: #1438715)

  [ Alfonso Sanchez-Beato ]
  * gril: cleanup traces
  * src/gprs.c: set preferred for the used IA APN (LP: #1361864)
  * rilmodem, mtkmodem, plugins/ril.c, plugins/mtk.c: retry when a
    context deactivation request has finished with an error
  * build, include, plugins/c-ares-dns-client.c, src/dns-client.c,
    src/gprs.c: resolve MMS proxy/MMSC host name (LP: #1417976)

  [ Ratchanan Srirattanamet ]
  * build, rilmodem, qcommsimmodem, plugins/ril.c,
    src/radio-settings.c: add multi-sim support for qcommsimmodem

 -- CI Train Bot <email address hidden> Thu, 02 Jul 2015 17:04:18 +0000

Changed in ofono (Ubuntu):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package ofono 1.12.bzr6900+15.04.20150702.3-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ofono (1.12.bzr6900+15.04.20150702.3-0ubuntu1) vivid; urgency=medium

  [Tony Espy]
  * test/rilmodem/sim: fix testing scripts for arale (LP: #1457775)
  * test: reverse meaning of list-modems -p (LP: #1438715)

  [ Alfonso Sanchez-Beato ]
  * gril: cleanup traces
  * src/gprs.c: set preferred for the used IA APN (LP: #1361864)
  * rilmodem, mtkmodem, plugins/ril.c, plugins/mtk.c: retry when a
    context deactivation request has finished with an error
  * build, include, plugins/c-ares-dns-client.c, src/dns-client.c,
    src/gprs.c: resolve MMS proxy/MMSC host name (LP: #1417976)

  [ Ratchanan Srirattanamet ]
  * build, rilmodem, qcommsimmodem, plugins/ril.c,
    src/radio-settings.c: add multi-sim support for qcommsimmodem

 -- CI Train Bot <email address hidden> Thu, 02 Jul 2015 17:04:18 +0000

Changed in ofono (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015
Changed in nuntium (Ubuntu):
status: In Progress → Fix Released
Changed in nuntium (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
Tony Espy (awe) wrote :

network-manager version 0.9.10.0-4ubuntu15.1.6 released to overlay PPA

Changed in network-manager (Ubuntu RTM):
status: In Progress → Fix Released
Tony Espy (awe) on 2015-07-20
no longer affects: ubuntu-system-settings (Ubuntu Vivid)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package ubuntu-system-settings 0.3+15.04.20150731-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-system-settings (0.3+15.04.20150731-0ubuntu1) vivid; urgency=medium

  [ Ken VanDine ]
  * [cellular/apn] new APN panel made for the new 'Preferred' property,
    as well as the 'ResetContext' method. (LP: #1435360, #1361864,
    #1376714, #1457676, #1424149, #1442646, #1388222)

ubuntu-system-settings (0.3+15.10.20150729.1-0ubuntu2~gcc5.1) wily; urgency=medium

  * No change upload, build with GCC 5.

ubuntu-system-settings (0.3+15.10.20150729.1-0ubuntu1) wily; urgency=medium

  [ Christopher Lee ]
  * Update AP helper so it doesn't attempt to use an unreachable value
    when scrolling.

  [ Ken VanDine ]
  * Added a sleep to give set_forward_on_busy time to finish
  * Use wait_select_single in the wifi dialog and bump the sleep to 1
    second
  * We need to explicitly stop dbus in tearDownClass, fixes lingering
    dbus processes

ubuntu-system-settings (0.3+15.10.20150724-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Recompile with the new udm to avoid ABI issues.

ubuntu-system-settings (0.3+15.10.20150722-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * Resync trunk.

  [ Ken VanDine ]
  * Use TextField.write to properly use the OSK Added helper to dismiss
    OSK

  [ jonas-drange ]
  * [tests] avoids setting Interfaces property after the
    Cellular/Phone/About plugins have loaded.

ubuntu-system-settings (0.3+15.10.20150716-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * Resync trunk.

  [ Ken VanDine ]
  * [wifi] Fixed handling of loading extended attributes from the
    MenuModel (LP: #1472505)

  [ handsome_feng<email address hidden> ]
  * Add flickable in time/date page. (LP: #1469076)

  [ jonas-drange ]
  * [phone] make services insensitive when there are no services as well
    as adding autopilot tests for sim services. (LP: #1470779)

ubuntu-system-settings (0.3+15.10.20150708-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ jonas-drange ]
  * Lets the Wi-Fi panel respond to an SSID provided by dispatcher by
    launching a "Connect to" dialogue. (LP: #1241986)

ubuntu-system-settings (0.3+15.10.20150703-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Joerg Berroth ]
  * Added support for 802-1x wireless network configurations. (LP:
    #1241986)

ubuntu-system-settings (0.3+15.10.20150702.3-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Ken VanDine ]
  * Test searching for WiFi instead of Sound, online-accounts now has a
    soundcloud account type (LP: #1468029)

  [ Matthew Paul Thomas ]
  * Changes "Install & Restart" to "Restart & Install" and "Not Now" to
    "Cancel". lp:1359344 (LP: #1359344)

  [ jonas-drange ]
  * implement CFB, CFNRy and CFNRc as well as autopilot tests (LP:
    #1463828)

ubuntu-system-settings (0.3+15.10.20150622-0ubuntu2) wily; urgency=medium

  * debian/control:
    - don't have an alternative depends on system-image-snappy-cli,
      it's d...

Read more...

Changed in ubuntu-system-settings (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.10.0-4ubuntu19

---------------
network-manager (0.9.10.0-4ubuntu19) wily; urgency=medium

  [ Tony Espy ]
  * debian/patches/add_ofono_settings_support.patch: remove code
    that added APN, USERNAME and PASSWORD to NM_SETTING_GSM object.
    NM doesn't actually need access to these settings, and USERNAME/
    PASSWORD can cause issues with NM's secrets needed logic.
  * debian/patches/0001-wwan-add-support-for-using-oFono-as-a-modem-manager.patch,
    debian/patches/lp1461593-add-nm-settings-connection-reset-retries-methods.patch,
    debian/patches/add_ofono_settings_support.patch,
    debian/patches/lp1461593-add-modem-reconnect-delay-to-policy.patch: More changes
    to NMModemOfono's modem_state handling. Added get/set_reset_retries_timeout
    methods to NMSettingsConnection, and use the set method to lower the timeout for
    ofono connections to 30s. Finally added a 5s delay to NM_POLICY's activation
    logic triggered when a modem device is disconnected. This allows modem time to
    settle and NM to process the resulting DBus state changes. (LP: #1461593)
  * debian/patches/0001-wwan-add-support-for-using-oFono-as-a-modem-manager.patch,
    debian/patches/lp1445080-modify-device-modem-avail.patch,
    debian/patches/lp1445080-nm-modem-check-for-set-mm-enabled-func.patch,
    debian/patches/lp1461593-add-modem-reconnect-delay-to-policy.patch: These
    changes collectively fix flight-mode on arale ( and other devices ), due to
    some fundemental race conditions in the ofono logic. (LP: #1445080, #1440917)
  * debian/patches/0001-wwan-add-support-for-using-oFono-as-a-modem-manager.patch,
    debian/patches/add_ofono_settings_support.patch: Add support for the ofono
    gprs-context 'Preferred' property. (LP: #1361864)

  [ Mathieu Trudel-Lapierre ]
  * d/p/0002-wifi-cull-the-scan-list-before-signalling-ScanDone-b.patch:
    Re-add schedule_scan() call after we get the ScanDone signal from the
    supplicant. Otherwise we'd do one scan on startup and never scan again.
    (LP: #1445134)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 05 Aug 2015 12:17:28 -0400

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.10.20150814-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.10.20150814-0ubuntu1) wily; urgency=medium

  [ Ken VanDine ]
  * dismiss_osk after entering text

 -- CI Train Bot <email address hidden> Fri, 14 Aug 2015 19:59:01 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers