Data does not re-enable loss of reception

Bug #1234634 reported by Charles Redman on 2013-10-03
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned
ofono (Ubuntu)
Undecided
Charles Redman

Bug Description

If i drive through an area that does not coverage with my mobile provider, when i re-enter an area that does have coverage my data connection/3G does not reconnect automatically. There is nothing i can do from the phone to re-enable it except reboot it, which in the long run is less than desirable operation.

This has happened consistently from V72-V78 of the software.

tags: added: avengers
removed: 3g connectivity data mobile reception
Bill Filler (bfiller) on 2014-07-01
no longer affects: touch-preview-images
tags: added: rtm14
Tony Espy (awe) wrote :

@Bill

Have you confirmed that this issue really still exists? This was filed a *long* time ago.

Tony Espy (awe) wrote :

@Charles

Assigning back to you. Can you please confirm that this issue exists on the latest stable image?

Changed in ofono (Ubuntu):
status: New → Incomplete
assignee: nobody → Charles Redman (charles-redman)
Martti Piirainen (piiramar) wrote :

I tested this on mako HW, image 172, with a WCDMA network simulator (Anritsu MD8470A) where I can switch the simulated basestation on and off. At least in this simulated scenario, the data connection always comes back.

Some commented output from the monitor-ofono test script:
# base station out of reach
{NetworkRegistration} [/ril_0] Strength = 0
{ConnectionManager} [/ril_0] Attached = False
{ConnectionManager} [/ril_0] Bearer = none
{NetworkRegistration} [/ril_0] Status = searching
{NetworkOperator} [/ril_0/operator/00101] Status = available
{NetworkRegistration} [/ril_0] Name =
{NetworkRegistration} [/ril_0] Status = searching
# data connection stops
{ConnectionContext} [/ril_0/context1] Settings = {}
{ConnectionContext} [/ril_0/context1] Active = False
{RadioSettings} [/ril_0] FastDormancy = True
{RadioSettings} [/ril_0] FastDormancy = False
{ConnectionManager} [/ril_0] Attached = True
{ConnectionManager} [/ril_0] Bearer = hspa
# base station is active again
{NetworkRegistration} [/ril_0] Status = registered
{NetworkRegistration} [/ril_0] Technology = umts
{NetworkRegistration} [/ril_0] LocationAreaCode = 128
{NetworkRegistration} [/ril_0] CellId = 0
{NetworkOperator} [/ril_0/operator/00101] Status = current
{NetworkRegistration} [/ril_0] Name = ANRITSU (Test PLMN 1-1)
{NetworkRegistration} [/ril_0] MobileCountryCode = 001
{NetworkRegistration} [/ril_0] MobileNetworkCode = 01
{NetworkRegistration} [/ril_0] Status = registered
{NetworkRegistration} [/ril_0] Strength = 0
{NetworkRegistration} [/ril_0] Strength = 67
# data context is active again
{ConnectionContext} [/ril_0/context1] Settings = { Address = 192.168.1.1, DomainNameServers = 192.168.1.2 192.168.1.2, Gateway = 192.168.1.2, Method = static, Interface = rmnet_usb0, Netmask = 255.255.255.0 }
{ConnectionContext} [/ril_0/context1] Active = True

Not necessarily 100% the same as real field testing, though.

Michael Frey (mfrey) on 2014-09-09
Changed in network-manager (Ubuntu):
status: New → Incomplete
tags: removed: rtm14
Launchpad Janitor (janitor) wrote :

[Expired for network-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in network-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers