immediately crashes

Bug #62648 reported by Martin Pitt on 2006-09-27
2
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu ppc alternate 20060927.7, 'oem' mode: after oem-config-prepare and reboot, booting stops at the VT with

  ImportError: No nmodule named oem_config.frontend

Martin Pitt (pitti) wrote :

For the record, /usr/sbin/oem-config already has the sys.path.insert(0, '/usr/lib/oem-config') (which was recently fixed).

/usr/lib/oem-config/oem_config/frontend/ exists and has __iit__.py, strange...

Martin Pitt (pitti) wrote :

Ah, it affects /usr/sbin/oem-config-dm, not /usr/sbin/oem-config.

Martin Pitt (pitti) wrote :

Adding sys.path.insert(0, '/usr/lib/oem-config') to oem-config-dm helps to get further.

Martin Pitt (pitti) wrote :

Now I get another exception:

  AttributeError: 'NoneType' object has no attribute 'get_size'

which is probably a side effect of the GtkWarning 'could not open display'.

Now I ran oem-config-firstboot from a VT after 'export DISPLAY=:0.0'. I got the first two questions (language/country and keyboard). Then I quickly saw the username/name/password dialog, then the program crashes with

   File "/usr/sbin/oem-config-dm", line 80, in ?
     sys.exit(dm.run(*sys.argv[3:]))
   File "/usr/sbin/oem-config-dm", line 66 un run
     os.kill(server.pid, signal.SIGTERM)
OSError: [Errno 3] No such process

and it starts all over again (repeatable).

Martin Pitt (pitti) wrote :

BTW, the initial import path issue seems to be fixed in 1.6, but the CD has 1.5.

Matt Zimmerman (mdz) on 2006-09-27
Changed in oem-config:
importance: Undecided → High
Tollef Fog Heen (tfheen) wrote :

Target for ubuntu-6.10

Changed in oem-config:
importance: High → Undecided
Colin Watson (cjwatson) wrote :

I think this is happening because the X server hasn't quite managed to start up yet when we do 'import gtk'. Rather than just increasing the sleep timeout, I'm trying to work out how to do this properly from gdm.

Colin Watson (cjwatson) wrote :

The original bug is fixed, and bug 62814 is here for the "could not open display" bit, so I'll close this one.

Changed in oem-config:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers