Blank screen after running oem-config

Bug #1638473 reported by colored1 on 2016-11-02
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
Undecided
Unassigned

Bug Description

STEPS TO REPRODUCE
In a virtual machine environment, install following the OEM setup testcase:
 https://bazaar.launchpad.net/~ubuntu-testcase/ubuntu-manual-tests/trunk/view/head:/testcases/image/1305_Install%20%28OEM%20setup%29

EXPECTED RESULTS
Final boot shows usable desktop.

ACTUAL RESULTS
A blank screen is shown with no mouse cursor. Typing has no affect, though one can reach a virtual terminal. At least that is the case in some (not all) virtual machine environments.

NOTES
 * PLEASE LIST YOUR RESULTS, successful or ortherwise with reproducing this bug. Versions are essential, as well as clear details on your system, especially video.
 * This does only seem to affect virtual machine environments, but it needs a wider degree of testing on real hardware.
 * This only seems to affect some virtual machine environments, so the issue may have something to do with the host environment. Further research is needed. It has appeared in KVM and VirtualBox, though it has also succeeded there.
 * Further testing is needed to see how far back it goes and which flavor(s) are affected.
 * Original bug report appears to have been for Kubuntu 16.04 on real hardware, but haven't heard from the OP. This bug has been heavily used on the ISO tracker for Kubuntu 17.04, so I'm co-opting it.

colored1 (colored1) wrote :

This bug seems to happen especially with Kubuntu: Tested with Ubuntu 16.04.1 + newest updates on the same system and working fine.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1638473

tags: added: iso-testing
Walter Lapchynski (wxl) wrote :

There are two bug reports on the tracker (see above) for 16.04.2 that affect VirtualBox. However, you'll notice that there's a real hardware test with no such problem.

Changed in oem-config (Ubuntu):
status: New → Confirmed
Darin Miller (darinmiller) wrote :

I could not repeat the black screen issue with either Ubuntu 16.04.2 amd64 nor the i686 OEM install.

HW: ASUS mb with UEFI BIOS, Intel VT-x enabled, Intel CPU with NVidia graphics card (driver v. 378.13).

Install worked as expected (both in VM and on real hw).

Walter Lapchynski (wxl) on 2017-02-23
Changed in oem-config (Ubuntu):
status: Confirmed → Triaged
Walter Lapchynski (wxl) on 2017-02-23
summary: - Blank screen after running oem-config
+ Blank screen after running oem-config in some virtual machine setups
Walter Lapchynski (wxl) on 2017-02-23
description: updated
description: updated
colored1 (colored1) on 2017-02-27
summary: - Blank screen after running oem-config in some virtual machine setups
+ Blank screen after running oem-config
colored1 (colored1) wrote :

This happens on Dell Latitude E6400 and E6420.

Are you sure you verified the ISO? If so, which architectures and versions
can you confirm this with? Do all the point releases of Trusty work ok?

colored1 (colored1) wrote :

It would have been nice to not replace my findings originally identified on hardware and replace it with virtual. Simply adding your findings would have been much more useful. Finding different
hardware working fine does not make the problem disappear on hardware. And following that logic, as
Darin had no failing setup, VMs would also not be affected?

The last version this worked for me was 14.04. Had this problem on Dell Latitude E6400, E5410 and E6420.
Tested now on a Dell Latitude E6400. It did not work with 16.04.1-desktop-amd64, so I freshly downloaded 16.04.2-desktop-amd64 and 16.10-desktop-amd64 for this bug (SHA256 OK, burnt to DVD with verification). It shows the same blank screen after running the OEM wizard, both from the installed OEM installation (by rebooting from disk after creating an image) AND from the restored CloneZilla image. Rebooting also shows a blank screen.
When pressing Ctrl-Alt-Del or the power button the Kubuntu image is displayed, before rebooting/powering off.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers