poor error handling - lack of recovery

Bug #153311 reported by Ian Jackson on 2007-10-16
0
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: oem-config

I installed gutsy 20071016.1 i386 d-i in oem mode in English (with auto-resize of another gutsy test install):

During the oem boot I:
 * Fiddled a bit with the Software Sources to remove the CD entry
 * Installed libadns1-bin using Synaptic
 * Created a user called "guest" using System / Administration / Users and Groups, in the most obvious way

Then I double-clicked on "prepare for shipping to end-user" which appeared to work, and rebooted.

When I rebooted the usual "enter your details" dialogue appeared as expected. I provided my language (Dutch), keyboard (British English) and timezone (Language) and was asked for my name and username and password.

When I confirmed my entering the password for the second time, the X server died immediately (black screen) and I was presented with a gdm prompt. The user and password I had provided during user firstboot did not work (I didn't try the guest user). I rebooted into the other install for forensics and found that the main admin user did not exist.

I am filing another bug about the fact that this problem was apparently caused by the fact that I created a user during the OEM preparation which I think ought to be supported.

This bug is about the fact that the oem firstboot program crashed leaving me with an unuseable setup. When the oem firstboot fails it ought to at least present the user with a useful error message and preferably it should try to avoid getting into a situation where the install is irrecoverably broken when it fails.

Related branches

Ian Jackson (ijackson) wrote :

The other bug I refer to, about support for oem-created users, is bug 153310.

Colin Watson (cjwatson) on 2007-10-16
Changed in oem-config:
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) on 2008-03-19
Changed in oem-config:
assignee: nobody → kamion
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oem-config - 1.32

---------------
oem-config (1.32) hardy; urgency=low

  [ Evan Dandrea ]
  * Use a GtkEventBox rather than a GtkScrolledWindow for the tzmap to
    match ubiquity (LP: #198179)
  * Port changes to zoommap.py from ubiquity:
    - Use a black border around tzmap points to assist the visually
      impaired.
    - Flash the currently selected location on the tzmap so that it's easier
      to spot.
    - When clicking on the tzmap, if the closest match is already selected,
      take the next closest.
    - Place the tzmap in an AspectFrame so it doesn't look distorted on
      widescreen displays (LP: #200152).
  * Center the oem-config window to match ubiquity.
  * Port fix for correctly answering the countrychooser/country-name question
    from ubiquity (was LP #174937) (LP: #203648).
  * Automatic update of included source packages: localechooser
    1.42ubuntu3.

  [ Colin Watson ]
  * Ensure that our build fails if one of the d-i components fails to build.
  * Add a check-manifest tool to ensure that d-i/manifest is in sync with
    d-i/source/ on upload (from ubiquity).
  * Don't clean console-setup; bits of it are intentionally missing from our
    copy, and it's not necessary.
  * Now that we allow user creation even if a non-system user already
    exists, we can only delete the temporary oem user once oem-config has
    actually succeeded (LP: #153311).

  [ Jonathan Riddell ]
  * kde_ui:
    - Load new Kubuntu wallpaper, also fix background if it can't find wallpaper
    - Load Oxygen icons if available

 -- Evan Dandrea <email address hidden> Tue, 25 Mar 2008 16:32:01 -0400

Changed in oem-config:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers