user created in firstboot screen doesnt have admin privs

Bug #149582 reported by Michael Brown on 2007-10-05
2
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: oem-config

Gutsy daily image 2007-10-05.

Ran oem-config-prepare at the end of the install.

On firstboot, created a user using the GUI dialog presented. The user created does not appear to have administrative privs needed to run 'sudo'.

Because the install was scripted with no root password, this leaves the system in a state where you cant get to root at all.

Related branches

Changed in dell:
importance: Undecided → Critical
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This was due to this user-setup bug, since fixed:

user-setup (1.14ubuntu4) gutsy; urgency=low

  * Only call archdetect if we have it, in order not to break use of the
    .deb outside ubiquity.

 -- Colin Watson <email address hidden> Fri, 05 Oct 2007 23:01:34 +0100

I'll upload oem-config shortly to incorporate this.

Colin Watson (cjwatson) on 2007-10-06
Changed in oem-config:
assignee: nobody → kamion
importance: Undecided → High
status: New → Triaged
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

oem-config (1.22) gutsy; urgency=low

  * Only run gnome-settings-daemon if it exists, removing dependency on
    gnome-control-center (LP: #147852).
  * GTK frontend:
    - Make sure the next button remains the default widget despite being
      hidden and re-shown.
  * Update translations from Rosetta.
  * Automatic update of included source packages: user-setup 1.14ubuntu4
    (LP: #149582).

 -- Colin Watson <email address hidden> Sat, 06 Oct 2007 13:19:18 +0100

Changed in oem-config:
status: Fix Committed → Fix Released
Michael Brown (michael-e-brown) wrote :

I am still seeing this problem on the 08 Oct live CD. Verified that manifest appears to have oem-config 1.22 and user-setup 1.14ubuntu4.

Colin Watson (cjwatson) wrote :

Argh. OK, I'll see if I can reproduce this (though tomorrow now).

Changed in oem-config:
status: Fix Released → Confirmed
Colin Watson (cjwatson) wrote :

I am unable to reproduce this. Could you please show me /var/log/oem-config.log?

Changed in oem-config:
status: Confirmed → Incomplete
Michael Brown (michael-e-brown) wrote :
Michael Brown (michael-e-brown) wrote :

upgraded to oem-config 1.22 and this is fixed. Hopefully the next Live DVD has this (the Live CD already does).

Changed in dell:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

Excellent, good to hear it. Thanks!

Changed in oem-config:
status: Incomplete → Fix Released
Chris Gregan (cgregan) on 2012-08-09
tags: added: cqa-verified
Changed in somerville:
importance: Undecided → Critical
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306170

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments