[gutsy] "Prepare for shipping to end user"-launcher remains in System -> Administration after setup

Bug #145281 reported by Christopher Denter on 2007-09-26
2
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
High
Colin Watson

Bug Description

This is gutsy with latest updates.
After installing gutsy in OEM mode (for testing purposes) and setting up the system I launched oem-config-prepare.
I got the 4-step-procedure on next reboot and everything worked correctly (although step 4 tends to take a long time).
After I logged in with my newly created user, the launcher "Prepare for shipping to end user" still appears in System -> Administration.

A customer who accidentally clicks this messes up his system, because the next time he boots he is asked to repeat the 4-step-procedure to create a new user.

I think this launcher should be removed from the menu in order to not cause confusion with customers / users.

regards

Related branches

Christopher Denter (dennda) wrote :

Sorry, where's the edit button for initial-bugpostings?

I - of course - meant:
"I think this launcher should be removed from the menu __after oem-config-prepare has been launched__ in order to not cause confusion with customers / users."

sorry for double posting.

regards

Colin Watson (cjwatson) on 2007-09-26
Changed in oem-config:
importance: Undecided → Medium
status: New → Confirmed
Martin Pitt (pitti) wrote :

Confirmed here.

Changed in oem-config:
importance: Medium → High
Colin Watson (cjwatson) wrote :

Fixed for post-RC.

Changed in oem-config:
assignee: nobody → kamion
milestone: ubuntu-7.10-rc → ubuntu-7.10
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

oem-config (1.23) gutsy; urgency=low

  * busybox sed doesn't support making backup files when editing in place
    (e.g. 'sed -i.oem'); chroot to edit kdmrc as well.
  * Fix GTK .desktop filename used in oem-config-prepare gksudo invocation.
  * Install .desktop files under /usr/share/applications/ at first install
    rather than shipping them there in the .debs, and remove them once
    oem-config-firstboot has been run (LP: #145281).
  * Set HOME in oem-config-dm so that iceauth is happier.
  * Start dcopserver before kwin (LP: #145226).
  * Run kdesktop too to fix the background in KDE.
  * Update translations from Rosetta.

 -- Colin Watson <email address hidden> Fri, 12 Oct 2007 15:04:03 +0100

Changed in oem-config:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers