Kubuntu OEM DCOP error

Bug #145226 reported by Henrik Nilsen Omma on 2007-09-26
10
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
High
Colin Watson
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Installing Kubuntu Gutsy Beta with the OEM option from thev desktop CD works fine until the last reboot. As I get the userconfig screen I get an error dialog about DCOP (screen shot attached). I don't get this problem with the Ubuntu version.

I'm testing in virtual box which may affect this, though networking generally works well there.

Henrik Nilsen Omma (henrik) wrote :
Henrik Nilsen Omma (henrik) wrote :

When I click OK I get this

Dave Morley (davmor2) wrote :

I have tried this on oem mode in alternative. I confirm that the error's are present on first time user install

Changed in ubiquity:
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This will very probably apply to the similar script used for automatic-ubiquity support.

Changed in ubiquity:
status: New → Confirmed
Colin Watson (cjwatson) wrote :

oem-config (1.20) gutsy; urgency=low

  * Add a --quiet option to oem-config-prepare to suppress its
    acknowledgement message (and thus the dialog requiring user interaction
    if $DISPLAY is set).
  * Add internationalisation (LP: #23537). Adjusted several widget names and
    strings in the KDE frontend to bring it into sync with the GTK frontend
    for this purpose.
  * Start dcopserver when running the KDE frontend (LP: #145226).
  * Add a --debug option to oem-config-firstboot to make debugging a bit
    less painful.
  * Remove use of dh_python, since it's a no-op now. Bump debhelper
    build-dependency to 5.0.37.3ubuntu2 (a.k.a. dh_python from 5.0.38) for
    this.
  * Clean up subprocesses even if oem-config-dm is interrupted.
  * GTK frontend:
    - Go forward when activating rows in language or keyboard treeviews.
  * Make sure the selected locale at least exists (we should really install
    the language pack, but this is a stopgap measure).
  * Automatic update of included source packages: console-setup 1.16ubuntu5,
    localechooser 1.38ubuntu2, user-setup 1.14ubuntu3.

 -- Colin Watson <email address hidden> Mon, 01 Oct 2007 17:59:41 +0100

Changed in oem-config:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

ubiquity (1.6.1) gutsy; urgency=low

  [ Evan Dandrea ]
  * Modified the install component to allow grub preseeding in automatic mode.
  * Add missing subprocess import to base.py.
  * Respect preseeded values for grub-installer/with_other_os and
    grub-installer/only_debian.

  [ Colin Watson ]
  * Strip translation context for imported strings (e.g. "Navigation|_Back")
    at a lower level so that it applies to the KDE frontend too.
  * KDE frontend:
    - Remove some duplicate code during widget translation.
    - Retranslate oem_id_label when the language is changed.
  * Update imported translations from gtk+2.0 2.12.0-0ubuntu1.
  * Forbid consecutive, initial, or final dots in hostnames (LP: #105890).
  * Check whether gconftool-2 exists before calling it.
  * Add missing Provides to ubiquity-frontend-mythbuntu.
  * Switch XS-Vcs-Bzr to the ~ubuntu-installer branch we're using at the
    moment.
  * Stop installing doc/Changelog.Guadalinex as the upstream changelog, as
    it's no longer current.
  * Upgrade to gettext 0.16.1.
  * Start dcopserver when running the KDE frontend in automatic-ubiquity
    mode (LP: #145226).
  * GTK frontend:
    - Work around http://bugzilla.gnome.org/show_bug.cgi?id=56070 by hiding
      and re-showing the button widgets, following a suggestion by Scott
      Horowitz.
    - Make the OK button the default widget in the create and edit partition
      dialogs.
  * Remove d-i/source/console-setup/Keyboard/MyKeyboardNames.pl on clean.
  * Only run gnome-settings-daemon if it exists, removing dependency on
    gnome-control-center (LP: #147852).
  * Add advanced button text to translation template (LP: #147612).
  * Add install button text to translation template, distinguished from the
    window title (LP: #103925).
  * Load strings for "Use as:" and "Mount point:".
  * Update translations from Rosetta.
  * Automatic update of included source packages: base-installer
    1.81ubuntu4, partman-auto-loop 0ubuntu11, partman-target 50ubuntu5.

  [ Mario Limonciello ]
  * Actually install xmltv from on-cd repo if checked.
  * Correct minor typo for nvidia xorg generation.
  * Explicitly remove via drivers before trying to install openchrome.

 -- Colin Watson <email address hidden> Wed, 03 Oct 2007 10:36:27 +0100

Changed in ubiquity:
status: Confirmed → Fix Released
Arne Goetje (arnegoetje) wrote :

still present in Kubuntu Alternate i386 [20070809.1]

Arne Goetje (arnegoetje) wrote :

Sorry, it's Kubuntu Alternate i386 [20071009.1]

reopening due to the last comment.

Colin, this looks like a permissions error - like ~/.DCOPserver* needs to be chown'd to user.user, not root. The dialog seems to refer to both errors, but not explicitly say the second one.

Changed in oem-config:
milestone: none → ubuntu-7.10-rc
status: Fix Released → Confirmed
Martin Pitt (pitti) on 2007-10-11
Changed in oem-config:
importance: Undecided → High
Colin Watson (cjwatson) wrote :

Odd, it should all be running as root. The mortal oem user has actually been deleted by this point ...

Colin Watson (cjwatson) on 2007-10-11
Changed in oem-config:
assignee: nobody → kamion
milestone: ubuntu-7.10-rc → ubuntu-7.10
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

oem-config (1.23) gutsy; urgency=low

  * busybox sed doesn't support making backup files when editing in place
    (e.g. 'sed -i.oem'); chroot to edit kdmrc as well.
  * Fix GTK .desktop filename used in oem-config-prepare gksudo invocation.
  * Install .desktop files under /usr/share/applications/ at first install
    rather than shipping them there in the .debs, and remove them once
    oem-config-firstboot has been run (LP: #145281).
  * Set HOME in oem-config-dm so that iceauth is happier.
  * Start dcopserver before kwin (LP: #145226).
  * Run kdesktop too to fix the background in KDE.
  * Update translations from Rosetta.

 -- Colin Watson <email address hidden> Fri, 12 Oct 2007 15:04:03 +0100

Changed in oem-config:
status: Fix Committed → Fix Released
Henrik Nilsen Omma (henrik) wrote :

Fix confirmed on 20071015 build.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.