[MoM SYNC] octave3.0 3.0.0-1

Bug #185653 reported by Stephan Rügamer
8
Affects Status Importance Assigned to Milestone
octave3.0 (Ubuntu)
Fix Released
Wishlist
Stephan Rügamer

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dear Colleagues,

please sync

source: octave3.0
version: 3.0.0-1
from: debian unstable

New Octave3.0 package, needed for new plplot

Thx,

\sh

 affects ubuntu/octave3.0
 subscribe ubuntu-archive
 status confirmed
 tag sync
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHmKm4wYnnM8CY76gRAq+pAJ9T6Cf2wTtfvVyTe6J++vp0em71UwCfUXwg
Mb+Wowabati/UZK2iMd94k4=
=0Pp8
-----END PGP SIGNATURE-----

Tags: sync
Revision history for this message
LaserJock (laserjock) wrote :

Ming Hua has some concerns about upgrade paths and the transition from Octave 2.9 to 3.0 I believe. Perhaps we should get that worked out before syncing?

Changed in octave3.0:
status: Confirmed → Incomplete
Revision history for this message
Stephan Rügamer (sruegamer) wrote :

HI,

I just can prepare some quick rebuilds of source packages which are depending on "octave" which is provided now from octace2.9 (which is already in the archive) and octace3.0.
If everything is fine, I'll remove Provides: octave from octave2.9 and go further with the sync of octave3.0.
The new plplot upstream version is depending on octave3.0 directly, so we need to get it in somehow.

What do you think?

\sh

Revision history for this message
Ming Hua (minghua) wrote :

Yes, my concerns are in the comments of bug #178424.

The problem is not as simple as a new octave package depending on octave3.0. There are quite a few reverse(-build)-dependencies. We also should think what to do with octave2.9. Leaving both in an LTS release doesn't seem wise to me.

I still think it's best to ask Debian octave team first.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Please Do Not Sync Anything Until https://bugs.edge.launchpad.net/ubuntu//+bug/185959 is finished.
I'll work with Martin Pitt on this.

Thx,

\sh

Changed in octave3.0:
assignee: nobody → shermann
status: Incomplete → In Progress
Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Please sync octave3.0 from sid

Changed in octave3.0:
importance: Undecided → Wishlist
status: In Progress → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

synced

Changed in octave3.0:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers