Please sync octave3.0 3.0.0-1 (universe) from Debian unstable (main)

Bug #178424 reported by Marco Rodrigues
This bug report is a duplicate of:  Bug #185959: octave3.0 transition. Edit Remove
10
Affects Status Importance Assigned to Milestone
octave2.9 (Ubuntu)
Triaged
Wishlist
Unassigned

Bug Description

Why it can be synced ?
- It has StevenK change to libfftw3-dev (last Ubuntu change).
- It has "Replaces" and "Conflicts" to replace octave2.9, so it can be backported in the future.
- GNU Octave 3.0 Released After 11 Years since version 2.0.
- It builds fine in Hardy pbuilder.

octave3.0 (3.0.0-1) unstable; urgency=low

    This is the real 3.0 release of Octave.

 -- Rafael Laboissiere <email address hidden> Sat, 22 Dec 2007 13:40:25 +0100

description: updated
Changed in octave2.9:
assignee: nobody → gothicx
status: New → In Progress
Revision history for this message
Marco Rodrigues (gothicx) wrote :

...

dh_builddeb -i
dpkg-deb: building package `octave3.0-doc' in `../octave3.0-doc_3.0.0-1_all.deb'.
dpkg-deb: building package `octave3.0-htmldoc' in `../octave3.0-htmldoc_3.0.0-1_all.deb'.
dpkg-deb: building package `octave3.0-emacsen' in `../octave3.0-emacsen_3.0.0-1_all.deb'.
dpkg-deb: building package `octave3.0-info' in `../octave3.0-info_3.0.0-1_all.deb'.
 dpkg-genchanges >../octave3.0_3.0.0-1_i386.changes
dpkg-genchanges: including full source code in upload
dpkg-buildpackage: full upload (original source is included)
Copying back the cached apt archive contents
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem
 -> cleaning the build env
    -> removing directory /var/cache/pbuilder/build//7312 and its subdirectories
Current time: Mon Dec 24 14:09:45 WET 2007
pbuilder-time-stamp: 1198505385

Revision history for this message
Ming Hua (minghua) wrote :

The octave3.0 package is a new package, superseding the old octave2.9 package. The octave2.9 package has been asked for removal in Debian (Debian bug #457675). So this bug is filed against the wrong package.

Also, octave2.9 used to build the octave binary meta package which depends on octave2.9. Now octave3.0 no longer builds octave binary package (there may be other plans by Debian's Octave maintainers), so upgrade path is currently broken.

Any MOTU who plans to ACK this sync please consider the above two points carefully, and preferablly speaking with Debian Octave maintainers first.

Changed in octave2.9:
assignee: gothicx → nobody
milestone: none → later
status: In Progress → Triaged
Revision history for this message
Daniel Holbach (dholbach) wrote :

Ming: Aren't the two packages installable in parallel? (Like cyrus2.1 and cyrus2.2?) If so, users will have to do the upgrade manually, no?

Revision history for this message
Ming Hua (minghua) wrote : [Bug 178424] Re: Please sync octave3.0 3.0.0-1 (universe) from Debian unstable (main)

First the disclaimer that I am not an Octave user and doesn't know about
Debian's octave packaging.

On Tue, Jan 08, 2008 at 02:26:08PM -0000, Daniel Holbach wrote:
> Ming: Aren't the two packages installable in parallel? (Like cyrus2.1
> and cyrus2.2?) If so, users will have to do the upgrade manually, no?

Looking at the installed file list, yes, they seem to be installable in
parallel. However, Debian maintainers never intended to support (in a
stable release sense) both octave2.9 and octave3.0, they filed the
Request for Removal bug for octave2.9 the same day octave3.0 enters
unstable.

My upgrade path comment is mainly about the "octave" meta-package. Now
both unstable and hardy's octave depends on octave2.9. With octave3.0
installed, you need to use "octave3.0" command to invoke the 3.0
version.

To make my position clear: I am all for including octave 3.0 in hardy,
however to sync the unstable package as is doesn't seem to be an
adequate, or even correct solution. I'm merely asking for more
discussion on this issue.

Ming
2008.01.09

Revision history for this message
Ming Hua (minghua) wrote :

On Wed, Jan 09, 2008 at 02:23:44AM -0600, I wrote:
> First the disclaimer that I am not an Octave user and doesn't know about
> Debian's octave packaging.
>
> On Tue, Jan 08, 2008 at 02:26:08PM -0000, Daniel Holbach wrote:
> > Ming: Aren't the two packages installable in parallel? (Like cyrus2.1
> > and cyrus2.2?) If so, users will have to do the upgrade manually, no?
>
> Looking at the installed file list, yes, they seem to be installable in
> parallel.

Uhm, on a closer look, octave3.0 Conflicts/Replaces/Provides octave2.9.
So no, they are not installable in parallel.

Ming
2008.01.09

Revision history for this message
Daniel Holbach (dholbach) wrote :

Marco: can you talk to the Octave Maintainers in Debian and find out if the upgrade for user is OK? (If it is, we should make sure that octave2.9 is removed from the archive too)

Revision history for this message
Marco Rodrigues (gothicx) wrote :

Daniel, Ming...

I'll talk with Debian maintainers to know more about this change from 2.9 to 3.0 and what it should break or not.

Thanks for helping

Revision history for this message
Aanjhan Ranganathan (aanjhan) wrote :

Any updates on this? Octave 3.0 seems like a _big_ release and would be nice to have it in Hardy.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Hi Aanjhan,

yes, we are working on a transition: please have a look at https://bugs.launchpad.net/ubuntu//+bug/185959

Regards,

\sh

Revision history for this message
Ming Hua (minghua) wrote :

Since \sh is working on the octave2.9 -> octave3.0 transition and tracking the status in bug #185959, let's mark this bug as a duplicate of that one.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers