octave should give clear error message when gnuplot is not installed

Bug #141055 reported by GabrielGrant on 2007-09-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Octave
Unknown
Unknown
octave (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: octave

Currently, installing Octave from "Add/Remove Applications" (installing with Synaptic not tested) does not install GNUPlot, and so using the "plot" command in Octave yields the folloeing error:

octave:1> x=0:pi/1000:2*pi;
octave:2> plot(x, sin(x))
sh: gnuplot: not found
warning: broken pipe -- some output may be lost
sh: gnuplot: not found
error: Version numbers must be a single row
error: evaluating if command near line 73, column 3
error: called from `compare_versions' in file `/usr/share/octave/2.9.12/m/miscellaneous/compare_versions.m'
error: evaluating static command near line 35, column 5
error: evaluating if command near line 29, column 3
error: called from `__go_draw_axes__' in file `/usr/share/octave/2.9.12/m/plot/__go_draw_axes__.m'
error: evaluating switch command near line 57, column 4
error: evaluating for command near line 55, column 2
error: evaluating if command near line 37, column 7
error: evaluating if command near line 30, column 5
error: evaluating if command near line 29, column 3
error: called from `__go_draw_figure__' in file `/usr/share/octave/2.9.12/m/plot/__go_draw_figure__.m'
error: evaluating if command near line 61, column 6
error: evaluating if command near line 58, column 4
error: evaluating if command near line 56, column 2
error: evaluating for command near line 55, column 7
error: evaluating if command near line 38, column 5
error: called from `drawnow' in file `/usr/share/octave/2.9.12/m/plot/drawnow.m'

Expected result:

A plot should appear.

GabrielGrant (gabrielgrant) wrote :

As a side note, currently the Add/Remove application installs the package "octave2.9". Should it install the wrapper package "octave" instead?

-Gabriel

Ming Hua (minghua) wrote :

octave 2.9 recommends gnuplot. I don't see a problem here, because:

1. The plot feature is not essential for octave. It's one of the important features, sure, but I can imagine some people who use octave may not need/want to install gnuplot.

2. IIRC, the package management tools in gutsy should install Recommends.

By the way, don't write gnuplot as GNUPlot, it has nothing to do with GNU (I believe gnuplot predates GNU projet).

GabrielGrant (gabrielgrant) wrote :

Thanks for the quick response Ming (and sorry abour the mis-capitalisation). Perhaps this should be a request for a more sane/concise error message when gnuplot isn't present...just the first line, "sh: gnuplot: not found" would be good. Or perhaps that would be fixed with bug #141059, since most of the output seems to be the same.

What do you think?

Ming Hua (minghua) wrote :

Sure, more clear error message is always desired. I'll modify the bug description as such.

Changed in octave2.9:
importance: Undecided → Wishlist

Dear Reporter,

please check if your bugreport is still valid for octave3.0.

If yes, please update your package to octave3.0.

Rational:

Octave3.0 is the latest stable release of Octave. All former versions
like octave2.1 or octave2.9 were development releases, which are
obsolete now (for Hardy that is).

As your bugs are not worth a StableReleaseUpdate for the still
maintained Ubuntu release, I would like to ask you to check out
Octave3.0 and eventually, when you bug is fixed, close your bugreport
or update your report to match source package "octave3.0".

Thank you for shaping the future of Ubuntu,

\sh

--
SysAdmin, OSS Developer
GPG-Key ID: 0xC098EFA8
Fingerprint: 3D8B 5138 0852 DA7A B83F DCCB C189 E733 C098 EFA8
http://www.sourcecode.de/

This bug/feature is still valid for:
  GNU Octave, version 3.0.0 (capitalization as reported by Octave itself following "octave --version")

I agree that the error message is a bit verbose. One possible feature enhancement may be to prompt the user if they want the package installed, rather than five an error.

Confirming because it happens to several users.

Changed in octave2.9 (Ubuntu):
status: New → Confirmed
affects: octave2.9 (Ubuntu) → octave (Ubuntu)
Mike Miller (mtmiller) wrote :

This is fixed in Octave version 4.0.0 now in the 15.10 development repository. If gnuplot is not installed, it will not be available as a graphics_toolkit in Octave.

Changed in octave (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.