zenity crashed with SIGSEGV in zenity_tree_dialog_response()

Bug #968534 reported by RC Lages on 2012-03-29
686
This bug affects 163 people
Affects Status Importance Assigned to Milestone
Ubuntu Customization Kit
Undecided
Unassigned
Zenity
Fix Released
Critical
octave-zenity (Ubuntu)
High
guido
Precise
High
Zein Maya
Quantal
High
Sebastien Bacher
zenity (Arch Linux)
New
Undecided
Unassigned

Bug Description

TESTCASE:
* run "zenity --list --column="bug" --checklist option"
* click any of the button
* it segfaults without the update, it works with it

RC Lages (rclages) wrote :
Changed in zenity (Ubuntu):
importance: Undecided → Medium
summary: - zenity crashed with SIGSEGV in g_closure_invoke()
+ zenity crashed with SIGSEGV in zenity_tree_dialog_response()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zenity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
visibility: private → public
Changed in zenity (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Changed in zenity (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
Changed in zenity (Ubuntu):
status: Triaged → Fix Committed
Changed in zenity (Ubuntu Precise):
status: Triaged → In Progress
description: updated
Changed in zenity:
importance: Unknown → Critical
status: Unknown → Fix Released
Cesar Silva (cmsv20) wrote :

Expected to continue but to select the Spanish language gave an error application and was closed

seems fix is released by zenity team

Changed in uck:
status: New → Fix Released
Changed in zenity (Ubuntu Precise):
status: In Progress → Fix Committed

Hello Ronaldo, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

John Relph (relph) wrote :

Zenity no longer crashes for me (it was being called from audio-convert). Thanks.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zenity - 3.4.0-0ubuntu3

---------------
zenity (3.4.0-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_list_view_segfault.patch:
    - don't segfault when using the --list option (lp: #968534)
 -- Sebastien Bacher <email address hidden> Fri, 04 May 2012 08:43:26 -0700

Changed in zenity (Ubuntu Precise):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

This was not fixed in quantal yet, and quantal has a newer version, so we cannot copy from precise-proposed.

Changed in zenity (Ubuntu Quantal):
assignee: nobody → Sebastien Bacher (seb128)
milestone: none → quantal-alpha-1
Julian Taylor (jtaylor) wrote :

this update introduces bug 995435

tags: added: regression-updates
Julian Taylor (jtaylor) on 2012-05-08
tags: added: regression-release
removed: regression-updates
Julian Taylor (jtaylor) wrote :

there are still more issues lingering in this code, e.g. endless loop on cancel due to channel use after shutdown:
https://bugzilla.gnome.org/show_bug.cgi?id=675705

Mike Birchley (mbirchley) wrote :

I have many scripts with Zenity, with the update to 12.04 many now don't work, there is no message and CPU usage rises progressively. I was testing with this snippet:

ls -1 * | zenity --list --column="Files" --text="" --title=""

. . always worked in past, not now. No error messages. Have the latest Zenity [3.4.0-0ubuntu3]

futurefx (force) wrote :

when fix will arrive for 12.04, i cannot use UCK because of that.

Mike Birchley (mbirchley) wrote :

Updates 3.4.0-0ubuntu4 fixed most of my problems, thanks to developers. Minor quibble is the scale option, mouse wheel used to scroll the bar, not working now, but keyboard still works. Thanks for all the hard work.

Changed in zenity (Ubuntu Precise):
assignee: nobody → John Paul Mootry (john-paul-mootry)
Changed in zenity (Ubuntu):
milestone: quantal-alpha-1 → quantal-alpha-2
Zein Maya (niez-zein) on 2012-06-12
Changed in zenity (Ubuntu Precise):
assignee: John Paul Mootry (john-paul-mootry) → Zein Maya (niez-zein)
Sebastien Bacher (seb128) wrote :

zenity (3.4.0-2) unstable; urgency=low
...
  * debian/patches/02_fix_segfault_in_listview.patch: Fix segfault when using
    --list option. Patch cherry-picked from upstream Git. Closes: #668292

Changed in zenity (Ubuntu Quantal):
status: Fix Committed → Fix Released
benditoelqueviene (quasar1970) wrote :

I was directed to bug 973361 after a Unity 2D crash. Screen before Unity 2D error:
"Please read /user/share/doc/im-switch/README.Debian.gz
No user configuration enabled for es_ES.
Restart the X session to activate the selected input Method".
Unity 2D fails a lot!

Changed in zenity:
status: Fix Released → New
Changed in zenity:
status: New → Fix Released
guido (tommaguzzi) on 2014-11-21
affects: zenity (Ubuntu) → octave-zenity (Ubuntu)
Changed in octave-zenity (Ubuntu):
assignee: Sebastien Bacher (seb128) → guido (tommaguzzi)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.