mountall-net tries to mount ocfs2 before o2cb is started

Bug #474215 reported by Christian Schlittchen
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ocfs2-tools (Ubuntu)
Fix Released
Low
Unassigned
Precise
Won't Fix
Undecided
Unassigned
Trusty
Triaged
Undecided
Unassigned

Bug Description

Binary package hint: ocfs2-tools

Upstart tries to mount an ocfs2 filesystem defined in fstab before /etc/init.d/o2cb has been run, the mount
therefore fails.

As a workaround I run '/etc/init.d/o2cb start' in mountall-net.conf.

Revision history for this message
Bram Metsch (metsch) wrote :

This also affects hardy using the classical SysV init style

Even more severe, the o2cb is stopped before the ocfs2 filesystems are unmounted.
Other machines that use the same OCFS2 volume then will need to fence theirselfes and hence will panic or reboot, see http://oss.oracle.com/projects/ocfs2/dist/documentation/v1.2/ocfs2_faq.html#QUORUM

Revision history for this message
Alex Harrington (alexharrington) wrote :

This still seems to be a problem in Lucid. We've moved from Hardy (no problems automounting OCFS2 over iSCSI from there) but on Lucid the o2cb service has never started the cluster when the machine is booted and then as a consequence mountall-net fails to mount the drive.

Revision history for this message
Chuck Short (zulcss) wrote :

ocfs2-tools probably be needed to converted to upstart.

Changed in ocfs2-tools (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Nec (nicolas-ecarnot) wrote :

Hi,

Has anyone made this upstart scripts available?
I'm not sure this bug should have its importance set to 'Low' : the present behaviour makes the difference between a working and a non working cluster node in case of reboot. It's not a detail.

Revision history for this message
Juan Pavlik (jjpavlik) wrote :

Hi, i'd like to help to fix this problem. Right now i've stopped my openstack deployment because of this bug. I'll try to write a o2cb upstart script to boot, then i'll go for the ocfs2 script. If anyone wants to help, just let me know! Thanks

Revision history for this message
Andreas Otto (andreas-otto) wrote :

I can't believe this bug still exists in Ubuntu 12.04 LTS. Is OCFS2 so rarely used that this bug has no importance to the package mantainers?

Please consider raising the severity to something more than low.

Revision history for this message
Rafael David Tinoco (rafaeldtinoco) wrote :

Thank you for taking the time to report this bug. In an effort to keep an
up-to-date and valid list of bugs to work on, I have reviewed this report to
verify it still requires effort and occurs on an Ubuntu release in standard
support, and it does not.

It is unfortunate that we were unable to resolve this defect, however there
appears to be no further action possible at this time. I am therefore moving the
bug to 'Fix Released' to current development release as the issue does not apply
to it any longer.

If you disagree or have new information, we would be grateful if you could
please open a new bug mentioning new affected versions with a possible
reproducer in the bug description.

Changed in ocfs2-tools (Ubuntu Trusty):
status: New → Won't Fix
Changed in ocfs2-tools (Ubuntu Precise):
status: New → Won't Fix
Changed in ocfs2-tools (Ubuntu Trusty):
status: Won't Fix → Triaged
Changed in ocfs2-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers