Failed to start LSB: Load O2CB cluster services at system boot.

Bug #1584629 reported by sles
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ocfs2-tools (Ubuntu)
Fix Released
Undecided
Unassigned
Trusty
Won't Fix
Low
Unassigned

Bug Description

Ubuntu 16.04.

Sometimes (not every boot) o2cb failed to start:

systemctl status o2cb
● o2cb.service - LSB: Load O2CB cluster services at system boot.
   Loaded: loaded (/etc/init.d/o2cb; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Пн 2016-05-23 11:46:43 SAMT; 2min 12s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1526 ExecStart=/etc/init.d/o2cb start (code=exited, status=1/FAILURE)

май 23 11:46:43 inetgw1 systemd[1]: Starting LSB: Load O2CB cluster services at system boot....
май 23 11:46:43 inetgw1 o2cb[1526]: Loading filesystem "configfs": OK
май 23 11:46:43 inetgw1 o2cb[1526]: Mounting configfs filesystem at /sys/kernel/config: mount: configfs is already
май 23 11:46:43 inetgw1 o2cb[1526]: configfs is already mounted on /sys/kernel/config
май 23 11:46:43 inetgw1 o2cb[1526]: Unable to mount configfs filesystem
май 23 11:46:43 inetgw1 o2cb[1526]: Failed
май 23 11:46:43 inetgw1 systemd[1]: o2cb.service: Control process exited, code=exited status=1
май 23 11:46:43 inetgw1 systemd[1]: Failed to start LSB: Load O2CB cluster services at system boot..
май 23 11:46:43 inetgw1 systemd[1]: o2cb.service: Unit entered failed state.
май 23 11:46:43 inetgw1 systemd[1]: o2cb.service: Failed with result 'exit-code'.

next try is successful:
systemctl status o2cb
● o2cb.service - LSB: Load O2CB cluster services at system boot.
   Loaded: loaded (/etc/init.d/o2cb; bad; vendor preset: enabled)
   Active: active (exited) since Пн 2016-05-23 11:49:07 SAMT; 1s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2101 ExecStart=/etc/init.d/o2cb start (code=exited, status=0/SUCCESS)

май 23 11:49:07 inetgw1 systemd[1]: Starting LSB: Load O2CB cluster services at system boot....
май 23 11:49:07 inetgw1 o2cb[2101]: Loading stack plugin "o2cb": OK
май 23 11:49:07 inetgw1 o2cb[2101]: Loading filesystem "ocfs2_dlmfs": OK
май 23 11:49:07 inetgw1 o2cb[2101]: Mounting ocfs2_dlmfs filesystem at /dlm: OK
май 23 11:49:07 inetgw1 o2cb[2101]: Setting cluster stack "o2cb": OK
май 23 11:49:07 inetgw1 o2cb[2101]: Starting O2CB cluster inetgw: OK
май 23 11:49:07 inetgw1 systemd[1]: Started LSB: Load O2CB cluster services at system boot..

I guess this is startup dependency problem.

Thank you!

Tags: ubuntu-ha
sles (slesru)
affects: systemd (Ubuntu) → ocfs2-tools (Ubuntu)
Revision history for this message
Nish Aravamudan (nacc) wrote :

It would appear that this check in /etc/init.d/o2cb:

check_filesystem "$FSNAME" "$MOUNTPOINT" && return 2

is failing. There is specific code in the init-script to handle this case, though.

Would you be able to run

`sudo bash -x /etc/init.d/o2cb start` and attach the log of that output here?

I guess there could be a race between something (I'm not sure what yet) mounting configfs during boot and the init script running check_filesystem and mount.

It looks like (at least) the init-scripts /etc/init.d/mountkernfs.sh and /etc/init.d/target do mount configfs.

I think we should update the o2cb init-script (upstream probably: https://oss.oracle.com/bugzilla/enter_bug.cgi) to handle mount returning 32 (I think that's the correct RC) since it's inherently racy (init is no longer single threaded).

@slesru, would you be willing to file that bug?

Then again, given that ocfs2-tools looks effectively dead upstream, we probably will need to fix it on our own.

Changed in ocfs2-tools (Ubuntu):
status: New → Triaged
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

The development seems to be happening here: https://github.com/markfasheh/ocfs2-tools

Might be worth filing a bug there: https://github.com/markfasheh/ocfs2-tools/issues

Revision history for this message
sles (slesru) wrote :

Hello!

I don't use ocfs2 on Ubuntu anymore, migrated to Oracle Linux, it works there.

Thank you!

Shawn (shawnpatti)
description: updated
tags: added: ubuntu-ha
Revision history for this message
Rafael David Tinoco (rafaeldtinoco) wrote :

Thank you for taking the time to report this bug. In an effort to keep an
up-to-date and valid list of bugs to work on, I have reviewed this report to
verify it still requires effort and occurs on an Ubuntu release in standard
support, and it does not.

It is unfortunate that we were unable to resolve this defect, however there
appears to be no further action possible at this time. I am therefore moving the
bug to 'Fix Released' to current development release as the issue does not apply
to it any longer.

If you disagree or have new information, we would be grateful if you could
please open a new bug mentioning new affected versions with a possible
reproducer in the bug description.

Changed in ocfs2-tools (Ubuntu Trusty):
status: New → Triaged
no longer affects: ocfs2-tools (Ubuntu Xenial)
no longer affects: ocfs2-tools (Ubuntu Yakkety)
Changed in ocfs2-tools (Ubuntu):
status: Triaged → Fix Released
Changed in ocfs2-tools (Ubuntu Trusty):
importance: Undecided → Low
Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

Trusty has reached its end of standard support.

Changed in ocfs2-tools (Ubuntu Trusty):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers