Ubuntu

probleme d'installation d' ocamlbricks

Reported by zake on 2011-10-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
marionnet
Undecided
Jean-Vincent Loddo
ocamlbricks (Ubuntu)
Undecided
Unassigned

Bug Description

l'erreur est la suivante:
./marionnet_from_scratch
* Warning: some OCaml/Ubuntu (>= 11.x) combinations may require the option -g
  Shall I do as if you chose -g (compile OCaml with Godi) ([y]/n)? y
* The log file is //tmp/marionnet_from_scratch.kBnDJbt6/log
* This looks like a Debian or derived distribution. Oh, joy!
  Required packages: g++ flex libtool bison gawk aptitude graphviz uml-utilities libgtk2.0-dev libglade2-dev gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev bridge-utils uml-utilities rlfe
  Shall I install required package(s) with aptitude ([y]/n)? y
  Shall I use the aptitude option --allow-untrusted ([y]/n)? n
* Required the [sudo] password for home:
* Installing aptitude .......................
  Note: I will also install vde2 with aptitude
* Installing required packages with aptitude ........................................................................................................................
* Downloading marionnet ... 100%
* Downloading ocamlbricks ... 100%
* Downloading ocaml (godi) ... 100%
* Compiling ocaml with godi ... 100%
* Compiling ocamlbricks ... 100%FAILED!
Last 20 lines of log (//tmp/marionnet_from_scratch.kBnDJbt6/log):
======
==========> WIDGETS/LEDGRID/GObj.mlpack
==========> WIDGETS/LEDGRID/GObj.ml
============> WIDGETS/LEDGRID/GObj.mll
============> WIDGETS/LEDGRID/GObj.mly
Warning: Failed to build the module GEdit requested by ocamldep
Warning: Failed to build the module GFile requested by ocamldep
Warning: Failed to build the module GObj requested by ocamldep
mid rule ocaml: mli -> cmi (%=DOT/dot_widget ): cache miss: a product is not in build dir (DOT/dot_widget.cmi)
//tmp/marionnet_from_scratch.kBnDJbt6/godi/bin/ocamlc.opt -c -thread -thread -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib/ -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//threads -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//lablgtk2 -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//camlp4 -pp camlp4of -I DOT -I EXTRA -I SHELL -I GETTEXT -I MAKE -I CAMLP4 -I CONFIGURATION -I MARSHAL -I STRUCTURES -I BASE -I WIDGETS -I WIDGETS/LEDGRID -o DOT/dot_widget.cmi DOT/dot_widget.mli
+ //tmp/marionnet_from_scratch.kBnDJbt6/godi/bin/ocamlc.opt -c -thread -thread -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib/ -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//threads -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//lablgtk2 -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//camlp4 -pp camlp4of -I DOT -I EXTRA -I SHELL -I GETTEXT -I MAKE -I CAMLP4 -I CONFIGURATION -I MARSHAL -I STRUCTURES -I BASE -I WIDGETS -I WIDGETS/LEDGRID -o DOT/dot_widget.cmi DOT/dot_widget.mli
File "DOT/dot_widget.mli", line 17, characters 44-56:
Error: Unbound type constructor GFile.filter
Command exited with code 2.
make[2]: *** [ocamlbricks.cmxa] Erreur 10
make[2]: quittant le répertoire « /tmp/marionnet_from_scratch.kBnDJbt6/ocamlbricks-0.90.3 »
FAILED when building "ocamlbricks.cmxa".
make[1]: *** [native-libraries] Erreur 255
make[1]: quittant le répertoire « /tmp/marionnet_from_scratch.kBnDJbt6/ocamlbricks-0.90.3 »
FAILURE: could not build native libraries.
make: *** [libraries] Erreur 255
======
Exiting.

Changed in marionnet:
assignee: nobody → Jean-Vincent Loddo (loddo)
Jean-Vincent Loddo (loddo) wrote :

I need more information about your installation. Could you execute the following commands on your system:
$ cat /etc/issue
$ uname -a
$ dpkg -l gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev
In my opinion, aptitude has not really installed the gtk-related packages that are needed compiling ocaml+lablgtk with godi. Thus, godi has built only ocaml, not lablgtk, and the error becomes visible compiling ocamlbricks (that needs the couple ocaml+lablgtk).
Jean-Vincent

Download full text (5.5 KiB)

$ cat /etc/issue
Ubuntu 11.10 \n \l

$ uname -a
Linux home-desktop 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 athlon i386 GNU/Linux

$ dpkg -l gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-============================================
ii freeglut3-dev 2.6.0-1ubuntu2 OpenGL Utility Toolkit development files
un gtkgl-dev <none> (aucune description n'est disponible)
ii libxmu-dev 2:1.1.0-2 X11 miscellaneous utility library (developme
ii tk8.4-dev 8.4.19-4 Tk toolkit for Tcl and X11, v8.4 - developme

so where to find this couple ocaml+lablgtk and how to install ??
sorry for my bad english :-p
and thinks for our answers !

> Date: Mon, 31 Oct 2011 09:53:03 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 883508] Re: probleme d'installation d' ocamlbricks
>
> I need more information about your installation. Could you execute the following commands on your system:
> $ cat /etc/issue
> $ uname -a
> $ dpkg -l gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev
> In my opinion, aptitude has not really installed the gtk-related packages that are needed compiling ocaml+lablgtk with godi. Thus, godi has built only ocaml, not lablgtk, and the error becomes visible compiling ocamlbricks (that needs the couple ocaml+lablgtk).
> Jean-Vincent
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/883508
>
> Title:
> probleme d'installation d' ocamlbricks
>
> Status in Marionnet - A virtual network laboratory:
> New
> Status in “ocamlbricks” package in Ubuntu:
> New
>
> Bug description:
> l'erreur est la suivante:
> ./marionnet_from_scratch
> * Warning: some OCaml/Ubuntu (>= 11.x) combinations may require the option -g
> Shall I do as if you chose -g (compile OCaml with Godi) ([y]/n)? y
> * The log file is //tmp/marionnet_from_scratch.kBnDJbt6/log
> * This looks like a Debian or derived distribution. Oh, joy!
> Required packages: g++ flex libtool bison gawk aptitude graphviz uml-utilities libgtk2.0-dev libglade2-dev gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev bridge-utils uml-utilities rlfe
> Shall I install required package(s) with aptitude ([y]/n)? y
> Shall I use the aptitude option --allow-untrusted ([y]/n)? n
> * Required the [sudo] password for home:
> * Installing aptitude .......................
> Note: I will also install vde2 with aptitude
> * Installing required packages with aptitude ........................................................................................................................
> * Downloading marionnet ... 100%
> * Downloading ocamlbricks ... 100%
> * Downloading ocaml (godi) ... 100%
> * Compiling ocaml with godi ... 100%
> * Compiling ocamlbricks ... 100%FAILED!
>...

Read more...

Ahoj,

Dňa Mon, 31 Oct 2011 20:06:29 -0000 zake <email address hidden>
napísal:

> $ cat /etc/issue
> Ubuntu 11.10 \n \l
>
> $ uname -a
> Linux home-desktop 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42
> UTC 2011 i686 athlon i386 GNU/Linux
>
> $ dpkg -l gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev

In all debian repos are no gtkgl* packages, only libgtkgl2.0 and
libgtkglext1. Both with *-dev version...

regards
--
Slavko
http://slavino.sk

Jean-Vincent Loddo (loddo) wrote :

Thanks slavko for this remark. It's probably a reason why the script marionnet_from_scratch fails when launched with -g (ocaml compiled with godi) on a debian/testing with binutils =2.21.
zake: I will let you know when I have finished fixing the script.
Jean-Vincent

Jean-Vincent Loddo (loddo) wrote :

zake: I haven't fixed the script yet, but you can get and use the current version (from http://www.marionnet.org/download/marionnet_from_scratch/marionnet_from_scratch) simply answering n (no) to the question about godi:
...
Shall I do as if you chose -g (compile OCaml with Godi) ([y]/n)? n
...
In my opinion, this may work correctly. Could you try it?
Thanks,
Jean-Vincent

Download full text (8.4 KiB)

i try your proposition and this is the result:

> Date: Fri, 4 Nov 2011 18:53:12 +0000
> From: <email address hidden>./marionnet_from_scratch
* Warning: some OCaml/Ubuntu (>= 11.x) combinations may require the option -g
  Shall I do as if you chose -g (compile OCaml with Godi) ([y]/n)? n
* The log file is //tmp/marionnet_from_scratch.0yN9oaGI/log
* This looks like a Debian or derived distribution. Oh, joy!
* Downloading marionnet ... 100%
* Downloading ocamlbricks ... 100%
* Downloading ocaml ... 100%
* Downloading lablgtk ... 100%
* Compiling ocaml ... 13%^Chome@home-desktop:~/Bureau$ ./marionnet_from_scratch
bash: ./marionnet_from_scratch: Permission non accordée
home@home-desktop:~/Bureau$ chmod +x marionnet_from_scratch
home@home-desktop:~/Bureau$ ./marionnet_from_scratch
* Warning: some OCaml/Ubuntu (>= 11.x) combinations may require the option -g
  Shall I do as if you chose -g (compile OCaml with Godi) ([y]/n)? n
* The log file is //tmp/marionnet_from_scratch.pryUETAl/log
* This looks like a Debian or derived distribution. Oh, joy!
* Downloading marionnet ... 100%
* Downloading ocamlbricks ... 100%
* Downloading ocaml ... 100%
* Downloading lablgtk ... 100%
* Compiling ocaml ... 100%
* Compiling lablgtk ... 100%
* Compiling ocamlbricks ... 100%
* Compiling marionnet ... 100%
* Required the [sudo] password for home:
* Installing marionnet ... 100%
* Installing vde2: it seems to be already installed ok
* Installing dot (graphviz): it seems to be already installed ok
* Installing kernels_linux-2.6.18-ghost.tar.gz ... 100%
* Installing filesystems_pinocchio.tar.gz ... 100%
* Installing filesystems_machine-debian-lenny-sid-2008.tar.gz ... 100%
* Installing filesystems_machine-mandriva20100215.tar.gz ... 100%
* Installing /etc/marionnet/marionnet.conf ... ok
* Installing daemon:
  Shall I install the marionnet daemon in your runlevels ([y]/n)? n
---
* Warning: your X server has been launched with the option '-nolisten tcp'
  => This option should be removed from your X display manager configuration.
     Shall I try to fix it ([y]/n)? y
     Ok. File(s) changed: /etc/X11/xinit/xserverrc
     You must restart your X display manager for the changes to take effect.
---
* Cleaning...
---
* Notes:
  - Install additional filesystem in /usr/local/share/marionnet/filesystems/
  - Install additional kernels in /usr/local/share/marionnet/kernels/
  - Customize your installation by editing /etc/marionnet/marionnet.conf
---
Success.
home@home-desktop:~/Bureau$ marionnet
=======================================================
 Welcome to marionnet
 Version : 0.90.6
 Source revision : 318 - 2011-02-02 19:27:57 +0100
 Ocamlbricks revision : 229 - 2010-11-23 10:55:39 +0100

 Built in date 2011-11-05 22:57:37 +0100 on sy...

Read more...

Jean-Vincent Loddo (loddo) wrote :

...
* Installing daemon:
  Shall I install the marionnet daemon in your runlevels ([y]/n)? n

Why not??? The marionnet-daemon installation is a part of the marionnet installation...
You have now to launch manually
$ /etc/init.d/marionnet-daemon start
each time (as root) before running marionnet as normal user.

Concerning the warning:
...
(marionnet:20590): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

you can find a solution in this page:
http://forum.ubuntu-fr.org/viewtopic.php?id=92216

Best regards,
Jean-Vincent

zake (zakaria-zz1) wrote :
Download full text (4.6 KiB)

thank you very much it works!

> Date: Mon, 7 Nov 2011 11:06:58 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 883508] Re: probleme d'installation d' ocamlbricks
>
> ...
> * Installing daemon:
> Shall I install the marionnet daemon in your runlevels ([y]/n)? n
>
> Why not??? The marionnet-daemon installation is a part of the marionnet installation...
> You have now to launch manually
> $ /etc/init.d/marionnet-daemon start
> each time (as root) before running marionnet as normal user.
>
> Concerning the warning:
> ...
> (marionnet:20590): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »
>
> you can find a solution in this page:
> http://forum.ubuntu-fr.org/viewtopic.php?id=92216
>
> Best regards,
> Jean-Vincent
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/883508
>
> Title:
> probleme d'installation d' ocamlbricks
>
> Status in Marionnet - A virtual network laboratory:
> New
> Status in “ocamlbricks” package in Ubuntu:
> New
>
> Bug description:
> l'erreur est la suivante:
> ./marionnet_from_scratch
> * Warning: some OCaml/Ubuntu (>= 11.x) combinations may require the option -g
> Shall I do as if you chose -g (compile OCaml with Godi) ([y]/n)? y
> * The log file is //tmp/marionnet_from_scratch.kBnDJbt6/log
> * This looks like a Debian or derived distribution. Oh, joy!
> Required packages: g++ flex libtool bison gawk aptitude graphviz uml-utilities libgtk2.0-dev libglade2-dev gtkgl-dev freeglut3-dev tk8.4-dev libxmu-dev bridge-utils uml-utilities rlfe
> Shall I install required package(s) with aptitude ([y]/n)? y
> Shall I use the aptitude option --allow-untrusted ([y]/n)? n
> * Required the [sudo] password for home:
> * Installing aptitude .......................
> Note: I will also install vde2 with aptitude
> * Installing required packages with aptitude ........................................................................................................................
> * Downloading marionnet ... 100%
> * Downloading ocamlbricks ... 100%
> * Downloading ocaml (godi) ... 100%
> * Compiling ocaml with godi ... 100%
> * Compiling ocamlbricks ... 100%FAILED!
> Last 20 lines of log (//tmp/marionnet_from_scratch.kBnDJbt6/log):
> ======
> ==========> WIDGETS/LEDGRID/GObj.mlpack
> ==========> WIDGETS/LEDGRID/GObj.ml
> ============> WIDGETS/LEDGRID/GObj.mll
> ============> WIDGETS/LEDGRID/GObj.mly
> Warning: Failed to build the module GEdit requested by ocamldep
> Warning: Failed to build the module GFile requested by ocamldep
> Warning: Failed to build the module GObj requested by ocamldep
> mid rule ocaml: mli -> cmi (%=DOT/dot_widget ): cache miss: a product is not in build dir (DOT/dot_widget.cmi)
> //tmp/marionnet_from_scratch.kBnDJbt6/godi/bin/ocamlc.opt -c -thread -thread -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib/ -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib/ocaml/std-lib//threads -I //tmp/marionnet_from_scratch.kBnDJbt6/godi/lib...

Read more...

Lucas Nussbaum (lucas) wrote :

bug filed against the ubuntu ocamlbricks package, while the user complains about marionnet_from_scratch.

Changed in ocamlbricks (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers