objgraph docs/uncollectable.txt test fails with Python 3.4

Bug #1270872 reported by Stefano Rivera on 2014-01-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
objgraph
Fix Committed
Undecided
Unassigned
objgraph (Debian)
Fix Released
Unknown
objgraph (Ubuntu)
Undecided
Unassigned

Bug Description

Imported from Debian bug http://bugs.debian.org/734586:

Package: objgraph
Version: 1.7.2-2

Hello,

objgraph's test suite fails with python 3.4:

| $ python3.4 tests.py
| ..........F/usr/lib/python3.4/imp.py:32: PendingDeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
| PendingDeprecationWarning)
| .
| ======================================================================
| FAIL: docs/uncollectable.txt
| Doctest: uncollectable.txt
| ----------------------------------------------------------------------
| Traceback (most recent call last):
| File "/usr/lib/python3.4/doctest.py", line 2187, in runTest
| raise self.failureException(self.format_failure(new.getvalue()))
| AssertionError: Failed doctest test for uncollectable.txt
| File "docs/uncollectable.txt", line 0
|
| ----------------------------------------------------------------------
| File "docs/uncollectable.txt", line 24, in uncollectable.txt
| Failed example:
| len(gc.garbage)
| Expected:
| 1
| Got:
| 0

It works fine with 2.7 and 3.3, so apparently Python 3.4 has some
changes in its garbage collection which fail that test?

Keeping at "normal" for now as Python 3.4 is still in experimental.
This will become serious (FTBFS) as soon as 3.4 becomes a supported
version in sid.

Thanks for considering,

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Changed in objgraph (Debian):
importance: Undecided → Unknown
Changed in objgraph (Debian):
status: New → Confirmed
Martin Pitt (pitti) wrote :

This can also be seen when running the autopkgtest with python3.4 as default:

http://people.canonical.com/~pitti/tmp/autopkgtest-py34/fail/py34-objgraph/results/

tags: added: python3.4
Marius Gedminas (mgedmin) wrote :

Upstream author here. Just noticed this by accident, from Martin's mail to ubuntu-devel. (I must've misconfigured the Launchpad project somehow because I didn't get an email notification.)

Is there a PPA where I could find Python 3.4 built for saucy?

Marius Gedminas (mgedmin) wrote :

Ok, I built a Python 3.4 from sources and can reproduce the error.

Marius Gedminas (mgedmin) wrote :

Ok, that test demonstrates a peculiarity of Python's garbage collection that was fixed in Python 3.4:
http://docs.python.org/dev/whatsnew/3.4.html#pep-442-safe-object-finalization

Therefore I think the best course of action is to disable this particular test on 3.4 and newer versions.

Marius Gedminas (mgedmin) wrote :
Changed in objgraph:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package objgraph - 1.7.2-2ubuntu1

---------------
objgraph (1.7.2-2ubuntu1) trusty; urgency=medium

  * Disable uncollectable.txt on Python 3.4. LP: #1270872.
 -- Matthias Klose <email address hidden> Sun, 26 Jan 2014 19:43:08 +0100

Changed in objgraph (Ubuntu):
status: New → Fix Released
Changed in objgraph (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.