Bluetooth "Browse files on" functionality broken

Bug #822275 reported by Gioele Barabucci
124
This bug affects 27 people
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
Undecided
Unassigned
obex-data-server (Ubuntu)
Undecided
Unassigned

Bug Description

It is not possible to browse files on bluetooth devides using the `gnome-bluetooth` "Browse files on...".

This is a regression from Karmic where the "Browse file on" functionality was flawlessly working.

Steps to reproduce, TEST CASE:

1) enable bluetooth on mobile device;
2) select "Browse files on" from `gnome-bluetooth` applet;
3) select one mobile device;
4) wait for the nautilus window to appear (it will not).

Tested on a brand new Lucid LTS 10.04.3.

As suggested in bug #542805 (closed as fix released but only partially really fixed), I tried running `/usr/share/doc/obexd-client/examples/list-folders`. This little application crashes with

----
Traceback (most recent call last):
  File "/usr/share/doc/obexd-client/examples/list-folders", line 38, in <module>
    list_folder(folder)
  File "/usr/share/doc/obexd-client/examples/list-folders", line 12, in list_folder
    session_path = client.CreateSession({ "Destination": sys.argv[1], "Target": "ftp"})
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.openobex.Error.Failed:
----

Bug #283064, comment 22 (bug closed as invalid) suggests that this problem is caused by a mismatching version of `obex-data-server` and offers a PPA (currently outdated) to solve this problem.

Bug #161 on obex-data-server's mantis (http://bugs.muiline.com/view.php?id=161) from 2009 says that changing the obex-data-server DBus config fixes this problems. They also applied a patch to their SVN version.

Could you please fix this bug by backporting to Lucid versions of gnome-bluetooth and obex-data-server that are compatible with each other? Thank you.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-bluetooth 2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-33.71-generic 2.6.32.41+drm33.18
Uname: Linux 2.6.32-33-generic x86_64
Architecture: amd64
Date: Sun Aug 7 14:48:48 2011
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110720.1)
SourcePackage: gnome-bluetooth

Revision history for this message
Gioele Barabucci (gioele) wrote :
Revision history for this message
Oliver Joos (oliver-joos) wrote :

I see the same bug in Ubuntu 11.04 (Natty)!

The mentioned Traceback of the example script "list-folders" shows more hints now:

Traceback (most recent call last):
  File "/usr/share/doc/obexd-client/examples/list-folders", line 38, in <module>
    list_folder(folder)
  File "/usr/share/doc/obexd-client/examples/list-folders", line 12, in list_folder
    session_path = client.CreateSession({ "Destination": sys.argv[1], "Target": "ftp"})
  File "/usr/lib/pymodules/python2.7/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.7/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.7/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

tags: added: natty
Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Changed in obex-data-server (Ubuntu):
status: New → Confirmed
summary: - "Browse files on" functionality broken on Lucid LTS
+ Bluetooth "Browse files on" functionality broken
Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

Browse files on is totally broken in Ubuntu 10.04 LTS. (Lucid)

Nautilus not open obex location.
Place ”obex://[A8:7E:33:B2:D5:EA]/” can not be opened
Error while getting peer-to-peer dbus connection: The name :1.142 was not provided by any .service files

send files in bluetooth working.... (my nokia 2720-a phones)

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

sudo killall bluetooth-applet
[sudo] password for tomppa:
tomppa@home-base:~$ bluetooth-applet -d
** Message: adding killswitch idx 0 state 1
** Message: killswitch 0 is 1
** Message: killswitches state 1
** (bluetooth-applet:3702): DEBUG: Unhandled UUID 00005001-0000-1000-8000-0002ee000001 (0x5001)
** (bluetooth-applet:3702): DEBUG: Unhandled UUID 00005002-0000-1000-8000-0002ee000001 (0x5002)
** (bluetooth-applet:3702): DEBUG: Unhandled UUID 00005003-0000-1000-8000-0002ee000001 (0x5003)
** (bluetooth-applet:3702): DEBUG: Unhandled UUID 00005557-0000-1000-8000-0002ee000001 (0x5557)
** (bluetooth-applet:3702): DEBUG: Unhandled UUID 00005601-0000-1000-8000-0002ee000001 (0x5601)
** Message: killswitch 0 is 1
** Message: killswitches state 1
Failed to mount OBEX volume: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

(bluetooth-applet:3702): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (bluetooth-applet:3702): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed

tags: added: testcase
Revision history for this message
freezeloud (freezeloud) wrote :

I have same issue with 11.10 (upgraded from 11.04 - not clean install), but it had worked fine for me on 11.04.

Revision history for this message
Steve White (stevan-white) wrote :

Ditto freezeloud. This is on a Samsung NC-20.

Revision history for this message
Steve White (stevan-white) wrote :

Maybe related:
When I pull down "Browse files on device..." from the bluetooth applet, the dialog is mangles: the list of devices is very very short, one can just barely see some letters.

See attached.

The scroll buttons kind of work, but barely. So I saw the device in the list and was able to select it.
Then I clicked Browse.

The bluetooth applet crashed, and disappeared from the gnome panel. In /var/log/messages
 at-spi-registry[12731]: segfault at c ip 00d4fb99 sp bfc881a0 error 4 in libgconf-2.so.4.1.5[d3a000+2c000]
bluetooth-apple[12769]: segfault at 40 ip 00bb6a4e sp bfe7d950 error 4 in libgnome-bluetooth.so.8.0.0.dpkg-new (deleted)[ba7000+1a000]

Revision history for this message
Steve White (stevan-white) wrote :

The dialog:

Revision history for this message
Steve White (stevan-white) wrote :

Same problem on an x86-64 desktop, for which Bluetooth file browsing was also working previous to an upgrade from 11.4 to 11.10.

Revision history for this message
Steve White (stevan-white) wrote :

Tried re-installs

sudo apt-get install --reinstall bluez bluez-alsa bluez-cups bluez-gstreamer bluez-utils
sudo apt-get install --reinstall libgnome-bluetooth8 pulseaudio-module-bluetooth

No luck.
------------------------
Tried backing up /var/lib/bluetooth/, deleting its contents, re-starting.
Then I paired with my phone, apparently successfully.

The phone does *not* appear in the gnome-bluetooth applet pop-down menu, as it did before.
It does appear in the mangled Browse Files dialog, as I described in the posting yesterday.

Attempted to Browse, as in that posting, and the bluetooth-applet segfaulted, as before.

So it's not the config files, and it's not the /var/lib files.
------------------------
Oh. lsusb on the Samsung laptop shows
Bus 004 Device 002: ID 0a5c:2101 Broadcom Corp. Bluetooth Controller

The desktop computer uses a dongle. lsusb shows several bluetooth devices attached (not sharing files!)
Bus 004 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 004 Device 003: ID 04fc:05d8 Sunplus Technology Co., Ltd Wireless keyboard/mouse
Bus 006 Device 002: ID 046d:0a04 Logitech, Inc. V20 portable speakers (USB powered)
Bus 004 Device 004: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 004 Device 005: ID 0a5c:4503 Broadcom Corp. Mouse (Boot Interface Subclass)
Bus 004 Device 006: ID 0a5c:2148 Broadcom Corp.

Revision history for this message
Steve White (stevan-white) wrote :
Download full text (5.8 KiB)

Here's a backtrace.

It will be better, when somebody tells us the secret of where the libgnome-bluetooth debug symbols are hidden.

This is looking like user-interface code to me.

#0 0x00140a4e in ?? () from /usr/lib/libgnome-bluetooth.so.8
#1 0x003e19d4 in gtk_tree_model_filter_real_visible (filter=0x806c800,
    child_model=0x806c778, child_iter=0xbfffe8a0)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtktreemodelfilter.c:1260
#2 0x003e6669 in gtk_tree_model_filter_visible (child_iter=0xbfffe8a0,
    self=0x806c800)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtktreemodelfilter.c:1290
#3 gtk_tree_model_filter_row_changed (c_model=0x806c778, c_path=0x8174550,
    c_iter=0x81764c0, data=0x806c800)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtktreemodelfilter.c:2041
#4 0x002d4cfa in _gtk_marshal_VOID__BOXED_BOXED (closure=0x824d220,
    return_value=0x0, n_param_values=3, param_values=0x8261260,
    invocation_hint=0xbfffea00, marshal_data=0x0)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtkmarshalers.c:1310
#5 0x0074ec3c in g_closure_invoke (closure=0x824d220, return_value=0x0,
    n_param_values=3, param_values=0x8261260, invocation_hint=0xbfffea00)
    at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
#6 0x007619f0 in signal_emit_unlocked_R (node=0x8119ff8, detail=0,
    instance=0x806c778, emission_return=0x0, instance_and_params=0x8261260)
    at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272
#7 0x0076a787 in g_signal_emit_valist (instance=0x806c778, signal_id=187,
    detail=0, var_args=0xbfffebc4 "\020\354\377\277\020\235\027\b\t\336=")
    at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3003
#8 0x0076a8f3 in g_signal_emit (instance=0x806c778, signal_id=187, detail=0)
    at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3060
#9 0x003e08c2 in gtk_tree_model_row_changed (tree_model=0x806c778,
    path=0x8174550, iter=0xbfffec10)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtktreemodel.c:1803
#10 0x003e67b4 in gtk_tree_model_filter_row_changed (c_model=0x808a6d8,
    c_path=0x8179d10, c_iter=0x81663d0, data=0x806c778)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtktreemodelfilter.c:2088
#11 0x002d4cfa in _gtk_marshal_VOID__BOXED_BOXED (closure=0x824d238,
    return_value=0x0, n_param_values=3, param_values=0x8261320,
    invocation_hint=0xbfffed90, marshal_data=0x0)
    at /build/buildd/gtk+3.0-3.2.0/./gtk/gtkmarshalers.c:1310
#12 0x0074ec3c in g_closure_invoke (closure=0x824d238, return_value=0x0,
    n_param_values=3, param_values=0x8261320, invocation_hint=0xbfffed90)
    at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
#13 0x007619f0 in signal_emit_unlocked_R (node=0x8119ff8, detail=0,
    instance=0x808a6d8, emission_return=0x0, instance_and_params=0x8261320)
    at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272
#14 0x0076a787 in g_signal_emit_valist (instance=0x808a6d8, signal_id=187,
    detail=0, var_args=0xbfffef54 "\260I\021\b")
    at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3003
#15 0x0076a8f3 in g_signal_emit (instance=0x808a6d8, signal_id=187, detail=0)
    at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3060
#16 0x003e08c2 in gtk_tree_model_row_changed (tree_model=0x80...

Read more...

Revision history for this message
Ulf Mehlig (umehlig) wrote :

I had no problem with this on 11.04. On 11.10 I see above mentioned problems #4 + #8.

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

why do not you fix this Lucid 10.04 version Although this would have to be a long-publishing support.

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

/usr/share/doc/obexd-client/examples/list-folders A8:7E:33:B2:D5:EA
Traceback (most recent call last):
  File "/usr/share/doc/obexd-client/examples/list-folders", line 38, in <module>
    list_folder(folder)
  File "/usr/share/doc/obexd-client/examples/list-folders", line 12, in list_folder
    session_path = client.CreateSession({ "Destination": sys.argv[1], "Target": "ftp"})
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.openobex.Error.Failed:

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

/usr/share/doc/obexd-client/examples$ ./ftp-client -d A8:7E:33:B2:D5:EA -g Kuvat

Traceback (most recent call last):
  File "./ftp-client", line 115, in <module>
    "Target": "ftp"})
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.openobex.Error.Failed:

Revision history for this message
Ivan Barjaktarov (ivan-thegreat) wrote :

Man this is why Linux is NOT meant for desktop machines.. if you want X powered system ppl should go OS X, things there work flawlesly.. Me to ended up with faulty system with no browse bluetooth no more... Oneiric Oncelot

Revision history for this message
Steve White (stevan-white) wrote :

Hey guys!

This is pretty bad for us Bluetooth users.
Please take some action!

Revision history for this message
Oliver Joos (oliver-joos) wrote :

@Steve: Yes, this is a major bug! To help solving it, we should be as precise as possible. I suppose you talk of several problems in your comments: browsing fails, gui problems, seg faults. Gioele, Thomas and I all see a "DBusException". If you see other symptoms then please open new reports for them so that the right people hear of them as soon as possible.

My bug 839157 is probably the same as this. But I resist from marking it as duplicate because of the multiple symptoms mentioned here.

Revision history for this message
Steve White (stevan-white) wrote :

Hi Oliver!

I don't doubt this is a cluster of bugs. I just reported what I see, trying to do a task that used to be easy.

It is difficult to be precise about a pile of bugs.

If you could, say, fix the basic functionality (not the device dialog issue), and push those fixes out, maybe clarity would improve.

In fact, other bluetooth-related bugs showed up in the last release, but I'm hesitant to report them, because it has been such a mess.

We are anticipating hearing from you!

Revision history for this message
Oliver Joos (oliver-joos) wrote :

Unfortunately am just an affected user like you. I did not look into the source of bluetoothd yet. But I made positive experiences by splitting up bugs into one report per symptom. Anyway thanks for sharing your findings!

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

im fix it this proplem a removed A-link usb-card and add a Lacie pci-card same place. Maybe usb-card is broken or else.??
This is very hard find.

Please check my usb bug 918772 (https://bugs.launchpad.net/libusb/+bug/918772) there are call trace.

Revision history for this message
Oliver Joos (oliver-joos) wrote :

I found a workaround for the similar bug 839157 - see my comment 30 there for details.

If you feel affected by this bug and are able to "fix" it by that workaround then please share your findings and leave a comment here!

Revision history for this message
Ninjaonchronic (ninjaonchronic) wrote :

On "Ubuntu 12.10 64 bit" with "Intel® Core™ i3 CPU M 350 @ 2.27GHz × 4" using "blueman 1.23-0ubuntu3"

When trying to browse my device, after connecting to my device (phone) and trying the "browse device" feature I get this error message:

Could not display "obex://[00:25:E5:20:8C:F5]/".

Error: Message did not receive a reply (timeout by message bus)
Please select another viewer and try again.
(obex-data-server 0.4.6-0ubuntu2)

I can send and recieve files just find but no browsing whatsoever.
When I run blueman-manager from terminal I get this error upon clicking "browse device"

child_closed (/usr/lib/python2.7/dist-packages/blueman/Functions.py:140)
['/usr/bin/blueman-browse', u'-d 00:25:E5:20:8C:F5'] closed

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

i have same errors in 12.10 Ubuntu 64bit.

but this also working.

Mount to phones to linux use:
 obexfs -b A8:7E:33:B2:D5:EA /home/tuomas/Nokia2720a

unmount to phones
 fusermount -u /home/tuomas/Nokia2720a

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

Please also note that the Ubuntu 10.04 live-cd version software, however, will work correct. But when you installed and updated software. Software not working. What has be changed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers