changing multiple desktop names results in last one being not changed.

Bug #1522625 reported by Lyn Perrine on 2015-12-03
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
lxpanel (Ubuntu)
Medium
Unassigned
Nominated for Xenial by Alberto Salvia Novella
obconf (Ubuntu)
Medium
Unassigned
Nominated for Xenial by Alberto Salvia Novella
openbox (Ubuntu)
Medium
Unassigned
Nominated for Xenial by Alberto Salvia Novella

Bug Description

To reproduce open obconf or openbox-configuration manager on the latest xenial lubuntu install in the lxde menu and change two desktop names. I expected both names to change after changing all of them instead only the first changed and having openbox reload its configuration through openbox --reconfigure or restarting openbox did not get the desktop name to display correctly. To find this display it is best to change desktop using control alt left control alt right. I got after changing to hug1 and hug2 that I got it to say hug1 but not hug2 but after I logout and log back in to lightdm it goes away so this can be a workaround.

obconf:
  Installed: 1:2.0.4+git20150213-1
  Candidate: 1:2.0.4+git20150213-1
  Version table:
 *** 1:2.0.4+git20150213-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ xenial/universe i386 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: obconf 1:2.0.4+git20150213-1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic i686
ApportVersion: 2.19.2-0ubuntu8
Architecture: i386
CurrentDesktop: LXDE
Date: Thu Dec 3 15:24:29 2015
InstallationDate: Installed on 2015-12-03 (0 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha i386 (20151203)
SourcePackage: obconf
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1522625

tags: added: iso-testing
Simon Quigley (tsimonq2) wrote :

This usually gets fixed when I restart LXDE.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in obconf (Ubuntu):
status: New → Confirmed
edve98 (edvinas-senda) wrote :

Might be worth noting that if you change more than 2 names only the last one will not be changed (but this bug suggests that only the first one would be changed)

Changed in obconf (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
planet (planet1) on 2016-01-08
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in obconf (Ubuntu):
status: Confirmed → Triaged
Simon Quigley (tsimonq2) wrote :

Confirmed in Lubuntu Xenial Xerus Alpha 2.

Simon Quigley (tsimonq2) wrote :

This is NOT an issue with obconf, this looks like it's an issue with lxpanel. See my screenshot below for proof:

http://i.imgur.com/b4DxDzR.png

Changed in obconf (Ubuntu):
status: Triaged → Invalid
Phill Whiteside (phillw) on 2016-04-08
Changed in obconf (Ubuntu):
status: Invalid → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
Phill Whiteside (phillw) on 2016-04-08
Changed in obconf (Ubuntu):
status: Incomplete → Confirmed
Simon Quigley (tsimonq2) on 2016-04-08
Changed in obconf (Ubuntu):
status: Confirmed → Invalid
Simon Quigley (tsimonq2) on 2016-04-08
affects: obconf (Ubuntu) → ubuntu
affects: ubuntu → obconf (Ubuntu)
Changed in lxpanel (Ubuntu):
importance: Undecided → Medium
Simon Quigley (tsimonq2) wrote :

Weird. I enabled 8 desktops and renamed to these:
Desktop 1: foo
Desktop 2: bar
Desktop 3: baz
Desktops 4-8: (unnamed desktop)

1 and 2 showed the change, but not 3.

So this is still confirmed in Lubuntu Yakkety Yak Alpha 1.

LStranger (andrej-rep) wrote :

Apparently if more than 1 desktop is renamed, then name of last one is never changed, neither openbox --reconfigure nor openbox --restart helps. And this issue is not related to lxpanel, as openbox itself does not show the change, but lxpanel is affected in regard of plugins which show workplace name on panel.

Changed in openbox (Ubuntu):
status: New → Confirmed
summary: - changing multiple desktop names only results in the first being changed.
+ changing multiple desktop names results in last one being not changed.
no longer affects: openbox (Ubuntu)
Changed in openbox (Ubuntu):
status: New → Confirmed
Changed in openbox (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers