nzbget fails to connect with GnuTLS error

Bug #1427486 reported by Michael Scafidi
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nzbget (Ubuntu)
High
Unassigned

Bug Description

Release: Ubuntu Vivid Vervet (15.04)

When attempting to download any file with nzbget, even fetching nzbs themselves from a server, the following message is displayed:

TLS handshake failed: Error in the system's randomness device.

It seems to be an incompatibility between nzbget and the current gnutls that is shipped with Ubuntu 15.04 as this issue occurs even when compiling nzbget 13/14 from source. The issue can be avoided by configuring nzbget with:

--with-tlslib=OpenSSL

To force nzbget to use OpenSSL instead of GnuTLS.

This is my first bug report so please let me know if additional information is needed.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: nzbget 13.0+dfsg-1
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic x86_64
ApportVersion: 2.16.2-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Mar 2 22:29:27 2015
InstallationDate: Installed on 2015-03-03 (0 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150224)
SourcePackage: nzbget
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Michael Scafidi (mascafidi) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nzbget (Ubuntu):
status: New → Confirmed
Changed in nzbget (Ubuntu):
importance: Undecided → High
Revision history for this message
Andreas Moog (ampelbein) wrote :

This bug should be resolved with 14.2+dfsg-2 and later, can you test and report back please? Thanks.

Changed in nzbget (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for nzbget (Ubuntu) because there has been no activity for 60 days.]

Changed in nzbget (Ubuntu):
status: Incomplete → Expired
Revision history for this message
satmandu (satadru-umich) wrote :

This bug is back in the dev Yakkety nzbget 17.0 version.

Revision history for this message
satmandu (satadru-umich) wrote :

(By which I mean we get the "TLS handshake failed: Error in the system's randomness device." that was previously attributed to gnutls usage.)

Revision history for this message
pdf (pdffs) wrote :

Confirming, nzbget-17.0+dfsg-1 is inexplicably being built against GnuTLS again, so this bug is back.

Changed in nzbget (Ubuntu):
status: Expired → Confirmed
Revision history for this message
Andreas Moog (ampelbein) wrote :

Latest upload was built with openssl.

Changed in nzbget (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers