Ubuntu

Separate x-screens option does not result in a desktop manager on the 2nd screen

Reported by blitzd on 2011-10-26
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
nvidia-settings (Ubuntu)
Undecided
Unassigned

Bug Description

In a dual monitor setup, using the nvidia driver 'current' (because 173 won't even allow for settings to be changed), the Separate X Screens option results in a desktop on one (the main) screen, and the other screen with a blank white background and the default X cursor.

Enabling Xinerama in this same configuration results in a X session that freezes shortly after login.

Description: Ubuntu 11.10
Release: 11.10

  Installed: 280.13-0ubuntu2
  Candidate: 280.13-0ubuntu2
  Version table:
 *** 280.13-0ubuntu2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nvidia-settings 280.13-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Wed Oct 26 12:42:23 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: nvidia-settings
UpgradeStatus: No upgrade log present (probably fresh install)

blitzd (blitzd) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-settings (Ubuntu):
status: New → Confirmed
Achim Behrens (k1l) wrote :

This Bug affects me, too.

Using a Dell Vostro 1500 with nvidia 8600GTM with an external Monitor via VGA wth nvidia-current.

Used to have 2 seperate X Screens on Lucid before with gnome2.
Twinview works on both Screens, but with seperate x-screens options i either get a white screen or the wallpaper but no panel or dash. The Mouse can move over to the external Desktop but just shows a X like in low grafics mode.

I tried my old lucids xorg.conf where the setup worked, but its no difference.

tags: added: nvidia
Achim Behrens (k1l) wrote :

I have exactly the same things happening, but with an ATI Radeon card

Cristobal Tapia (crtapia) wrote :

I have the same problem here. I'm using the Dell Studio XPS 13 with the double Nvidia Hybrid-SLI configuration: GeForce 9200M GS + GeForce 9400M G.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers