Ubuntu

Saved settings are not used after log in/reboot/x server reboot

Reported by TGP1994 on 2010-09-10
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nvidia-settings

It seems like this has been a long lasting issue that should perhaps be fixed :S

Anyhow, after installing the 17* (was it 9 or 6?) drivers, my resolution, after being changed, applied, and saved to /etc/X11/xorg.conf from the nvidia-settings control panel, is not used if I either log off then on again, restart X (Ctrl Alt Backspace), or restart my computer. The settings will only stay for the current session.

I am using a NVIDIA GeForce FX 5500, with Linux Mint 9 (Kernel: 2.6.32-24-generic (i686))

Attached are my xorg.conf files before and after I apply the settings.

TGP1994 (tgp1994) wrote :

And here's the afterwards log:

TGP1994 (tgp1994) wrote :

Hope a fix can be released soon...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-settings (Ubuntu):
status: New → Confirmed
e633 (e633) wrote :

Same thing here, i have to set the refresh rate upon every reboot.
AMD Athlon 64 X2 6000+
3GB DDR2 800
Asus m4n78 pro (motherboard)
Ge Force GTX 550 Ti
Ubuntu 12.04 x86
Driver version: 295.40
Xserver: 1.11.3
NV-CONTROL version 1.27
Also here: ubuntuforums.org/showthread.php?p=11907672

manos (gkmanos21) wrote :

Same issue here. I save my changes to xorg.conf and I have to manually change my settings in nvidia-settings each time I reboot, log out or restart X.

manos (gkmanos21) wrote :

Also in unity -> system settings -> Displays my monitor is recognized as Laptop and not as LG L192WS

manos (gkmanos21) wrote :

I finally sorted it out!!!

I only changed in /etc/X11/xorg.conf in Section "Screen" the Option "metamodes" "1440x900 +0+0; nvidia-auto-select +0+0" into
"metamodes" "1440x900_60" where 60 is my native lcd refresh rate.

Now every time I boot everything is crystal clear.

I enclose an attachment of my xorg.conf with this post.

Please send positive feedback of the solution

TGP1994 (tgp1994) wrote :

@manos: I'm glad you were able to find a way to get resolutions sticking!

e633 (e633) wrote :

Doesn't work for me. Maybe because i have two monitors?
relevant line --> Option "metamodes" "1280x1024_60"
See attachment for my xorg.conf

mightymouse2045 (eagleeyes426) wrote :

Same issue with me

Xorg.0.log shows:

[ 3455.129] (II) NVIDIA(0): Assigned Display Device: DFP-1
[ 3455.129] (II) NVIDIA(0): Validated modes:
[ 3455.129] (II) NVIDIA(0): "1920x1080_60"
[ 3455.129] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 3455.168] (--) NVIDIA(0): DPI set to (40, 40); computed from "UseEdidDpi" X config
[ 3455.168] (--) NVIDIA(0): option
[ 3455.177] (II) NVIDIA(0): Setting mode "1920x1080_60"
[ 3455.259] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 3455.259] (==) NVIDIA(0): Backing store disabled
[ 3455.259] (==) NVIDIA(0): Silken mouse enabled
[ 3455.259] (**) NVIDIA(0): DPMS enabled
[ 3455.259] (II) NVIDIA(0): [DRI2] Setup complete
[ 3455.259] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 3455.495] (II) NVIDIA(0): Setting mode "1920x1080_50i"

As you can see it validates the mode of 1920x1080_60 and sets the mode, then 300th of a second later sets the mode to a different refresh rate 1920x1080_50i

Attached is my xorg.conf also - I have disabled twinview and xinerama and nothing is working.

mightymouse2045 (eagleeyes426) wrote :

This looks like an xrandr issue.

Output from xrandr shows that the highest and default resolution it detects is 1920x1080 @ 50hz. But my native resolution for my monitor is 1920x1080 @ 60hz, so it makes sense why it keeps resetting to what xrandr lists as the default, but it's a pain having to manually change it each session:

   1920x1080 50.0* 51.0 52.0 53.0 54.0 55.0 56.0 57.0 58.0
   1680x1050 59.0 60.0
   1600x1024 61.0
   1440x900 62.0 63.0
   1440x576 64.0
   1440x480 65.0
   1400x1050 66.0 67.0 68.0
   1360x768 69.0 70.0
   1280x1024 71.0 72.0 73.0
   1280x960 74.0 75.0
   1280x800 76.0
   1280x720 77.0 78.0
   1152x864 79.0 80.0 81.0 82.0 83.0 84.0 85.0
   1024x768 86.0 87.0 88.0 89.0 90.0 91.0
   960x720 92.0 93.0
   960x600 94.0
   960x540 95.0
   928x696 96.0 97.0
   896x672 98.0 99.0
   840x525 100.0 101.0 102.0 103.0 104.0
   832x624 105.0
   800x600 106.0 107.0 108.0 109.0 110.0 111.0 112.0 113.0 114.0 115.0
   800x512 116.0
   720x576 117.0
   720x480 118.0
   720x450 119.0
   720x400 120.0
   700x525 121.0 122.0 123.0 124.0
   680x384 125.0 126.0
   640x512 127.0 128.0 129.0
   640x480 130.0 131.0 132.0 133.0 134.0 135.0 136.0 137.0
   640x400 138.0
   640x350 139.0
   576x432 140.0 141.0 142.0 143.0 144.0 145.0 146.0
   512x384 147.0 148.0 149.0 150.0 151.0
   416x312 152.0
   400x300 153.0 154.0 155.0 156.0 157.0
   360x200 158.0
   320x240 159.0 160.0 161.0 162.0
   320x200 163.0
   320x175 164.0

mightymouse2045 (eagleeyes426) wrote :

This appears to be fixed with NVidia 302.07 beta drivers

Changed in nvidia-settings (Ubuntu):
status: Confirmed → Fix Released
Bollespiser (dundundunbolle) wrote :

This is not fixed.

On Ubuntu 13.04 I'm adjusting "Color Correction" for one of my screens.
It's all well and done until next time I log in. Brightness and Contrast is still at 0.000 and Gamma at 1.000. Settings are not saved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers