NVIDIA X Server configuration not working

Bug #526955 reported by aspa on 2010-02-24
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
nvidia-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nvidia-settings

I'm trying to configure external display using NVIDIA X Server Settings.
When I activate "X Server Display Configuration" selection in the configuration panel I sometimes get the following error message:

"Unable to load X Server Display Configuration page:

Failed to find display device 0x00000001 on screen 0 (on GPU-0)
while parsing metamode:

'CRT-0: NULL'"

When the problem appears it seems to appear consistently with every invocation until the next X server restart or reboot.

ProblemType: Bug
Architecture: i386
Date: Wed Feb 24 12:41:43 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nvidia-settings
NonfreeKernelModules: nvidia
Package: nvidia-settings 180.25-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic-pae
SourcePackage: nvidia-settings
Uname: Linux 2.6.31-19-generic-pae i686

aspa (marko-asplund) wrote :
aspa (marko-asplund) wrote :

here's a screenshot of the error.

aspa (marko-asplund) wrote :

Also, the "window movement key" stopped working (moving a window by holding down alt-key + grabbing the window).

This problem disappeared when I logged out and the X server was restarted.

This issue may be related to https://bugs.launchpad.net/bugs/526950

Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Ralf Donau (ruelle) wrote :

I get a similar error message:

"
Unable to load X Server Display Configuration page:

Failed to query NoScanout for screen 0.
"

My solution was to edit /etc/X11/xorg.conf manually and add the line
Option "TwinView" "True"
to the device-section as mentioned in /usr/share/doc/nvidia-173/README.txt.gz

bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in nvidia-settings (Ubuntu):
status: New → Incomplete
gero (gerod) wrote :

I still see this problem in Lucid when ever I unplug one screen, attach another and then try to change the NVidia setup accordingly. The change works but when I start the NVidia tool again it shows the message mentioned above and I'm stuck until the next X-server restart.

This confirms that the bug still exists in a current version of Ubuntu. Can you please change the status back to 'New'?

David Fraser (davidf) wrote :

Re comment 6: I get this in Maverick too. I've found the advice in this forum post helpful: http://ubuntuforums.org/showthread.php?t=1047029
Basically you can use the command-line to tell nvidia-settings to reset which displays are present. It then properly forgets about the old display and allows you to use the dialog to detect the new one. I'm using the latest packaged drivers (260.19.06-0ubuntu1)
Here's a short script that should reset to only using the laptop's local LCD:

#!/bin/bash
echo Current display status
nvidia-settings -d -q AssociatedDisplays
echo Configuring to only know about LCD display
nvidia-settings -a AssociatedDisplays=0x00010000
echo Updated display status
nvidia-settings -d -q AssociatedDisplays

Changed in nvidia-settings (Ubuntu):
status: Incomplete → New
gero (gerod) wrote :

David, thanks for this advice which inspired another workaround:

After clicking the "Detect Displays" button (which will recognize the new screen and the loss of the old one) select "Apply" before configuring the new screen. Only after switching to a one-screen set-up, configure the new screen. This procedure will leave the configuration intact.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-settings (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers