Ubuntu

nvidia sets HUE to -1000

Reported by Fernando Miguel on 2009-07-04
364
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Totem
Unknown
High
nvidia-settings (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Scott Ritchie
totem (Ubuntu)
Low
Unassigned
Nominated for Karmic by Scott Ritchie

Bug Description

==WORKAROUND==

Using Totem (Ubuntu's default video player) :

1. open totem via Applications > Sound & Video > Movie Player
2. open the preferences window via Edit > Preferences
3. select the Display tab
4. click the Reset to Defaults button

============

opening movies makes them look blueish due to the fact that nvidia settings have HUE set to -1000
the user can manually fix that, by setting to zero, but the next time a movie is opened it will re-set to -1000

ProblemType: Bug
Architecture: amd64
Date: Sat Jul 4 11:44:00 2009
DistroRelease: Ubuntu 9.10
MachineType: To Be Filled By O.E.M. S37S
NonfreeKernelModules: nvidia
Package: nvidia-glx-180 185.18.14-0ubuntu2
ProcCmdLine: root=UUID=a8aa4adb-b3e6-4e1d-b4ad-e6cd704788b2 ro vga=0x360
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-1.14-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu4
 libgl1-mesa-glx 7.5~rc4-1ubuntu2
 libdrm2 2.4.11-0ubuntu1
 xserver-xorg-video-intel N/A
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu1
SourcePackage: nvidia-graphics-drivers-180
Uname: Linux 2.6.31-1-generic x86_64
dmi.bios.date: 01/22/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0801
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: S37S
dmi.board.vendor: To Be Filled By O.E.M.
dmi.board.version: 1.00
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0801:bd01/22/2008:svnToBeFilledByO.E.M.:pnS37S:pvr1.0:rvnToBeFilledByO.E.M.:rnS37S:rvr1.00:cvnToBeFilledByO.E.M.:ct10:cvr1.0:
dmi.product.name: S37S
dmi.product.version: 1.0
dmi.sys.vendor: To Be Filled By O.E.M.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-1-generic

[lspci]
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M G [10de:0428] (rev a1) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:8265]

nvidia-bug-report.log.gz

Philip Muškovac (yofel) wrote :

Tried to reproduce it on my Nvidia Quadro NVS 140M and got this:

Mplayer: works fine
VLC: works fine
Totem: broken
Mplayer: now also broken
VLC: now also broken

Totem bug?

Changed in totem:
status: Unknown → New
Changed in totem (Ubuntu):
importance: Undecided → Low
status: New → Triaged

Confirm this, had the similar issue: http://ubuntuforums.org/showthread.php?t=1204718
But after I reset HUE to the default value everything is shown fine, in vlc, mplayer and totem. But before this all these players had the similar issue.

Joe_Bishop wrote:
> Confirm this, had the similar issue: http://ubuntuforums.org/showthread.php?t=1204718
> But after I reset HUE to the default value everything is shown fine, in vlc, mplayer and totem. But before this all these players had the similar issue.
>
>
i don't understand what you want me to do? i posted you the link to that
bug :P im affected by it :P

Artur Rona (ari-tczew) wrote :
Bryce Harrington (bryce) on 2009-08-13
tags: added: karmic
Jarno Suni (jarnos) wrote :

Here video gets blue tint, if I reset Color balance preferences in Totem (gstreamer). If I set Hue slider to one of either ends, colors get normal.

Jarno Suni (jarnos) wrote :

Oh, but I don't use the restricted driver.

Scott Ritchie (scottritchie) wrote :

Wanted to confirm this as a big issue. For me:
Opening a video starts it as blue. I go to nvidia-settings (proprietary drivers) and see that Hue got set to -1000. I move it up to 0 and the video looks normal. If I open a new video, everything goes blue again until I wiggle the slider a bit.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Elisiano Petrini (elisiano) wrote :

Exactly the same problem here!

I solved the problem by:
 1. Open gstreamer-properties (alt+f2, enter gstreamer-properties)
   2. Change to the video tab
   3. Change the default output plugin to "custom"
   4. Place the following command in the bottom box: videobalance hue=-1 ! autovideosink
   5. Close the box and enjoy your now correct colour

I've been using 185 and i havent seen this bug in many weeks

$ apt-cache policy nvidia-glx-185
nvidia-glx-185:
  Installed: 185.18.36-0ubuntu3
  Candidate: 185.18.36-0ubuntu3
  Version table:
 *** 185.18.36-0ubuntu3 0
        500 http://darkstar.ist.utl.pt karmic/restricted Packages
        500 http://archive.ubuntu.com karmic/restricted Packages
        100 /var/lib/dpkg/status
     185.18.36-0ubuntu1~karmic~ppa1 0
        500 http://ppa.launchpad.net karmic/main Packages

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Bryce Harrington (bryce) on 2009-10-09
description: updated
Steffen Röcker (sroecker) wrote :

This is still an issue for me.

After I change the hue in totem properties to either side it shows correctly, even after closing and opening another video.

nvidia-glx-96: 96.43.13-0ubuntu3

This is an issue for me in latest karmic with version 185.18.36-0ubuntu7

Using gstreamer-properties didn't work so I tried nvidia settings. Unlike Scott from above, my hue setting was 0, but when I moved it to something else then back to 0 the video was fixed. In VLC I managed to work around the problem by setting the video output to OpenGL.

Tim (tim-gizzy) wrote :

I had the same problem with the release version! fortunatly setting the custom settings in gstreamer-properties fixed it for me - It is these silly problems that give Linux such a bad name. For most people such a problem is a complete show stopper and results in Windows being re installed.

johanpdx (johanpdx) wrote :

Kieran Fleming: Changing the VLC setting according to your instruction also worked for me.
Giorgio Stefanoni: Following your gstreamer-properties instructions fixed the general problem.
Thanks to you both for user-friendly guidance.
Tim: I sympathize, but I'm also delighted that just googling the problem ("nvidia ubuntu hue slider") landed me here and got me the advice I needed--and within my non-techie ability to cope.

Camille Appert (bibinou) on 2009-11-10
summary: - nvidia sets HUE to -1000
+ Video is tinted blue (nvidia sets HUE to -1000)

Added a workaround in the description, and updated the title so it shows up when people try to report this very bug.

description: updated
Elisiano Petrini (elisiano) wrote :

I have the same problem.
Since Totem gets stuck when opening video with external subtitles I had to do in a different way.
This might be useful for everyone who wants to use an alternative player to Totem.
In this example I used VLC but every player would do.

1) Set the correct HUE value in nvidia-settings and close the panel
2) Create a custom nautilus script like this in $HOME/.gnome2/nautilus-scripts/ :
-----------------------
elisiano@thunder:~$ cat ~/.gnome2/nautilus-scripts/VLCWrapper
#!/bin/bash
/usr/bin/vlc --sub-autodetect-file --fullscreen $1 &
sleep 0.5
/usr/bin/nvidia-settings -l
-----------------------

3) set the script as executable ( chmod +x ~/.gnome2/nautilus-scripts/VLCWrapper )

Done.
Now every time you right click a file in the Scripts menu you will find an entry with your newly created script.
Of course you can choose whichever player you prefer instead of vlc.

petrescs (petrescs) wrote :

Not sure this is a duplicate of #409640. In my particular case, blue tint was fixed by setting the default video output to "X Window System (No Xv)" instead "Autodetect" in gstreamer-properties (as described in #409640 by Spang #8). I'm using Nvidia 185.18.36-0ubuntu9 and HUE value was already 0 after upgrade to karmic.

Camille Appert (bibinou) on 2009-11-10
summary: - Video is tinted blue (nvidia sets HUE to -1000)
+ nvidia sets HUE to -1000
D Becker (dmitrinbecker) wrote :

I have two laptops with nvidia hardware, both running karmic, both using the 185.18.36-0ubuntu9 driver packages. The GeForce Go 7700 does not suffer from this bug, but the GTX280M does... however the "videobalance hue=-1..." workaround noted above (comment #11) only works for me if I use "1" instead of "-1".

Selecting "X Window System (No Xv)" also works, but greatly increases the CPU usage for high-res video... I'd imagine with a slower machine that could be a problem.

Using the "videobalance hue=..." workaround on the 7700 actually _causes_ the hue to be messed up on that machine.

D Becker (dmitrinbecker) wrote :

The gstreamer-properties workaround fixes the problem with things that use gstreamer with xv, but I'm still seeing this problem with other applications that use xv -- so it looks to me like the problem is not in totem or gstreamer. MPlayer, for example, shows this problem with "-vo xv", but not when using other output drivers - Again, only on my GTX280M, but not on my GeForce Go 7700.

Archish (archish) wrote :

I am also affected by this same bug since Jaunty 9.04 and using Karmic 9.10 atm. The bug exists for me in all media players in linux and really annoying as for me I cannot use VDPAU in totem and mplayer there is no workaround. Since I dont see any progress in the bug being fixed from previous version can someone please tell me which is having the bug so that I can try to push forward with the right team:

- Nvidia Driver
- Xorg
- Player specfic?

Thanks.

BassKozz (basskozz+ubuntu) wrote :

Solution that fixes all players (totem, vlc, firefox[flash], etc...):
Open totem Menu:Edit->Preferences:Display [Reset to defaults] Button
Source: http://bit.ly/58ZEIq

Archish (archish) wrote :

But the above fix has be done every time the system reboots :/

BassKozz (basskozz+ubuntu) wrote :

@Archish, not for me, I set it (#23) once and it fixed it for good

Yep, #23 has been fine for me for a good while now

Ville Ranki (ville-ranki) wrote :

This happened to me after upgrading from Jaunty to Karmic. Using NVidia drivers. Reseting totem settings to defaults seemed to fix the problem, but naturally this should be fixed in the source.

Robert Hooker (sarvatt) wrote :

This has been fixed with lucid's nvidia-settings updates, the problem stemmed from using the old 180 version nvidia-settings with a 185+ driver.

affects: nvidia-graphics-drivers-180 (Ubuntu) → nvidia-settings (Ubuntu)
Changed in nvidia-settings (Ubuntu):
status: Confirmed → Fix Released
narcelio (narcelio) wrote :

As a temporarily workaround, you can type this at command line:

nvidia-settings --assign=XVideoTextureHue=0

thomas (qubes) wrote :

I still have this bug in Lucid with version 195.36.08-0ubuntu2 installed. Hue seems messed up even time Totem loads a new video. typing "nvidia-settings --assign=XVideoTextureHue=0" while any video is playing fixes the issue until a new video is loaded. I can also start the nvidia-control panel and move the Hue slider and that fixes the issue as well.

Robert Hooker (sarvatt) wrote :

thomas: Did you upgrade from karmic? can you try deleting your ~/.nvidia-settings-rc file and restart X/reboot?

John Connor (tanor85) wrote :

Found a workaround for this bug that has been around for an eternity.

- Go to Applications , ubuntu software center
- download Gnome MPlayer
- open Gnome Mplayer
- Go to : edit, preferences, set video output to ''x11''.
- Gnome Mplayer will be your one and only video player from now on.

This workaround doesnt seem to diminish performance.

For me, the bug seemed to appear when I downloaded ''MPlayer Plugin for Mozilla''
None of the other solutions worked permenantly without diminishing performance (video lag).

Good luck.

Le Gluon Du Net (legluondunet) wrote :

If you have this bug (blue and red color in video are invert) and you have a nvidia, you don't have to install or uninstall any software.
Just launch the "nvidia X server settings", choose your screen (X screen 0), "Xserver video settings", "Reset hardware defaults".

That's worked for me and others.

LGDN

After today's kernel header update on 10.04 lucid, things turned blue again.

Fix:
1) Open totem Menu:Edit->Preferences:Display [Reset to defaults] Button
2) Move Hue slider all the way to the left <―
3) [Optional] Sigh…

Changed in totem:
importance: Unknown → High
L. Ross Raszewski (rraszews) wrote :

I'll add that for me (Lucid, kernel 2.6.32-25), merely *starting* nvidia-settings fixes the hue, even if you don't adjust any settings.

Changed in totem:
status: New → Unknown
Subeh Sharma (subeh-sharma) wrote :

still seeing this problem!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.