Fails to parse xorg.conf

Bug #366360 reported by Trouilliez vincent on 2009-04-24
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nvidia-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nvidia-settings

Just upgraded Ubuntu 8.10 to 9.04, and using nvidia-settings for the first time ever (since the gnome tool now refuses to launch, instructing me to use nvidia-settings instead)

Problem : when I click on "Save to X Configuration File", I get this error:

"Failed to parse existing X config file '/etc/X11/xorg.conf'!"

I attached xorg.conf. This is how I obtained it:

1) upgraded to 9.04 -> no xorg.conf file at all, logical, all supposed to be auto-configured AIUI..
2) Went to System -> Administration -> Hardware Drivers, to enable the proprietay Nvidia driver
3) ran "dontzap --disable", since I wanted it. No idea if it's relevant, but stating it to be complete, just in case it somehow matters

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: nvidia-settings 180.25-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nvidia-settings
Uname: Linux 2.6.28-11-generic i686

Bryce Harrington (bryce) wrote :

Hi vincent-trouilliez-modulonet,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in nvidia-settings (Ubuntu):
status: New → Incomplete

Yup, here it is. I assume "Xorg.0.log" is the file being currently used by the running session ? If so it should be the appropriate file in my case, as the bug is repeatable at will in the current session.

Update: for unrelated reasons, I did a fresh install of Ubuntu 9.04 (re-using my /home partition, though), and go figure, nvidia-settings worked ! No idea why it works now, so maybe the bug might come back, but for the time being I guess we can close the bug, I will re-open it in the future if need be.

jay armstrong (jayarmstrong) wrote :

I'm having the same problem on a fresh install of 9.04. I installed the restricted nvidia driver 180, rebooted, configured the dual monitors via nvidia-settings and get the same error as above.

Running nvidia-settings with gksu didn't help but from the terminal I see the following:

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Undefined Device "(null)" referenced by Screen "Default Screen".

The original xorg.conf is attached.

I added the following line to the "Screen" section and now nvidia-settings is working correctly:

     Device "Default Device"

It appears that nvidia-settings is behind X in its guessing ability and simply gives up when no video device is specified under Screen. X, on the other hand, seems to march through the file and just grab the first available device.

Also of note, you have to run nvidia-settings as root (gksu nvidia-settings) or you won't have permissions to save the X files anyway. Perhaps those devs could have it prompt the user for a password or ubuntu devs could have it do the same on launching?

Kzin (wmkzin) wrote :

Thank you Jay, that fixed mine too.
Added Device "Default Device" under the section Screen.
then gksudo nvidia-settings

Textureglitch (textureglitch) wrote :

I've found another workaround. Running 'sudo nvidia-xconfig' creates a clean xorg.conf file that the nvidia-settings app can parse.
Somehow it just doesn't like the default xorg.conf that's distributed with Ubuntu.

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Rex de Jong (rex-de-jong) wrote :

Same with Karmic alpha 6

Bryce Harrington (bryce) on 2009-10-09
tags: removed: needs-xorglog
Paul Libert (plibert) wrote :

For Karmic, adding
    Device "Default Device"
in the
Section "Screen"
solved the problem.

JoseRoberto (joseroberto) wrote :

I'm having the same problem, on ubuntu 9.10, the section device is like in this bug recommend and the problem persist

Section "Device"
 Identifier "Default Device"
 Option "NoLogo" "True"
 Driver "nvidia"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers