Black-screen on boot with nvidia 390 for Budgie, MATE, Xubuntu, Kubuntu

Bug #1764005 reported by fossfreedom on 2018-04-14
142
This bug affects 28 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Alberto Milone

Bug Description

Upgraded from Ubuntu Budgie 17.10 to 18.04. After the plymouth splash left with a black screen.

Purged all the nivdia-* packages and rebooted - graphical logon and logged in ok with nouveau.

Tried software & updates to reinstall the nvidia 390 drivers. Rebooted. Left at black screen again.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: nvidia-driver-390 390.48-0ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
NonfreeKernelModules: wl nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
Date: Sat Apr 14 21:42:04 2018
InstallationDate: Installed on 2016-11-26 (503 days ago)
InstallationMedia: budgie-remix 16.10 "Budgie-remix" - amd64 (20161013)
SourcePackage: nvidia-graphics-drivers-390
UpgradeStatus: Upgraded to bionic on 2018-04-14 (0 days ago)

fossfreedom (fossfreedom) wrote :
fossfreedom (fossfreedom) wrote :

whilst in the black screen state I switched to a TTY and ran ubuntu-bug nvidia-390 - I used the keep option to create the .apport file.

After purging and booting back with nouveau I ran "apport-bug apport.nvidia-driver-390.4lwinjii.apport" to report this issue. If there is a better way to get more logs please let me know.

fossfreedom (fossfreedom) wrote :

Tried again.

I edited GRUB to boot with nomodeset - this didnt fix the login screen.

Them in a TTY I install nvidia-prime then ran

sudo prime-select intel

After a reboot graphical logon screen (lightdm slick-greeter) and logged in successfully to the desktop.

So the regression here is that nvidia-390 is not installing the same config as generated by prime-select

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Giraffe (dodger-forum) wrote :

Using a Quadro M2000M on 18.04 with nvidia-prime same problem here...

Marc Fez (marc-fez) wrote :

same problem.

Dell XPS 15 9560
GeForce GTX 1050
Clean install of Ubuntu Budgie Bionic

I've tried with nvidia-390 and nvidia-396

summary: - Black-screen on boot with nvidia 390 for GTX 960M
+ Black-screen on boot with nvidia 390 for Budgie, MATE, Xubuntu, Kubuntu
Martin Wimpress (flexiondotorg) wrote :

Dell XPS 15 9550 running Ubuntu MATE 18.04 daily is also affected.

Graphics: Card-1: Intel HD Graphics 530
           Card-2: NVIDIA GM107M [GeForce GTX 960M]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 3840x2160@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
           version: 4.5 Mesa 18.0.0-rc5

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

The nvidia 390 drivers were installed via the Additional Drivers UI. On next boot after plymouth splash is shown the screen is black. Switched to tty1 and tried to run `sudo prime-select nvidia` which reported the nvidia profile was already set. So I ran `sudo prime-select intel` and on next boot was presented with the display manager.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Ubuntu MATE 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Ubuntu Budgie 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Kubuntu 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Xubuntu 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Ubuntu 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

This system does NOT suffer from the issue under Ubuntu vanilla but I have attached the logs as they may be of help.

Mike Wilson (mwilson-e) wrote :

Entroware Kratos R3 running Ubuntu MATE 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Kratos R3 running Ubuntu Budgie 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Kratos R3 running Ubuntu Kubuntu 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Kratos R3 running Ubuntu Xubuntu 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

Once rebooted system boots to blank screen. `sudo prime-select intel` lets the system boot again.

Mike Wilson (mwilson-e) wrote :

Entroware Kratos R3 running Ubuntu 18.04 daily

Graphics: Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: X.Org 1.19.6
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48

Please find a tarball attached that includes Xorg.log, gpu-manager.log and dmesg.

Once installed, these commands were issued.
  $ sudo apt update
  $ sudo apt install nvidia-driver-390 nvidia-prime
  $ reboot

This system does NOT suffer from the issue under Ubuntu vanilla but I have attached the logs as they may be of help.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Kubuntu 18.04 daily

Log of `journalctl --since=today` attached.

Mike Wilson (mwilson-e) wrote :

Entroware Zeus R1L running Ubuntu MATE 18.04

/var/log/Xorg.0.log attached.

tags: added: rls-bb-incoming
Alberto Milone (albertomilone) wrote :

(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

This is from the last log.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High

For your reference, I've just repeated the steps using Ubuntu MATE 18.04 daily on the XPS 15 9550 but this time added ppa:graphics-drivers/ppa and installed nvidia-driver-396 and everything worked correctly.

Actually, I retract the above. nvidia-396 appears to works because the nvidia driver isn't being used after install.

Alberto Milone (albertomilone) wrote :

I managed reproduce this using Mate. Lightdm doesn't seem to be too happy about me dropping its configuration files for PRIME. Luckily, this can be easily fixed.

Changed in nvidia-prime (Ubuntu):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → In Progress
no longer affects: nvidia-graphics-drivers-390 (Ubuntu)
SkirmantasJ (skirmis) wrote :

Same on ThinkPad T470 Intel + Nvidia MX940 on Ubuntu 18.04, tried nvidia-390 and nvidia-396

I am new to bug reporting so apologies if I'm doing this wrong.

It seems I am also affected by this. I tried the upgrade from mate 17.10 to 18.04 with nvidia installed which lead to a black screen. Then I tried upgrading first and then installing nvidia also a black screen. I have a Lenovo w550s with a quadro k620m. Commenting out the "Primary GPU" line in

/usr/share/X11/xorg.conf.d/11-nvidia-prime.conf

and setting the file immutable seems to work. Nvidia settings shows my GPU is used. However, running glxinfo I get the following error

Error: couldn't find RGB GLX visual or fbconfig

so I cannot confirm

Please let me know if I can provide any further information.

Rik Mills (rikmills) on 2018-04-23
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.8.8

---------------
nvidia-prime (0.8.8) bionic; urgency=medium

  * 90-nvidia.conf,
    debian/dirs.in,
    debian/install.in,
    debian/rules,
    oem/00-prime-offload,
    prime-offload,
    prime-switch:
    - Restore the Lightdm configuration snippets, as it removing
      them caused a black screen on boot on all the Ubuntu flavours
      that rely on Lightdm (LP: #1764005).
      Leave only prime-switch out, since a reboot is required now.

 -- Alberto Milone <email address hidden> Fri, 20 Apr 2018 12:25:01 +0200

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
Darin Miller (darinmiller) wrote :

Confirming this fixes my bug also: https://bugs.launchpad.net/ubuntu/+source/sddm/+bug/1762885.

Nice job Alberto!

Daniel Boyd (danboyd) wrote :

I am still having problems. Running nvidia-prime 0.8.8.

I upgraded from 17.10 and have four monitors connected to a Dell Precision 7510 with a Quadro M1000M.

In xorg, I get one of the four monitors. In wayland I get the other 3!

I've attached my xorg.0.log

I unfortunately can't stick around to help troubleshoot because this is my production work machine and I thought I'd take my lunch break to upgrade to 18.04. whoops. Now I'm going to have to wipe and revert to 17.10... :/

Bryce Leo (bryce-leo) wrote :

Broken again with kernel 4.15.0.22.23.

I have this with kernel 4.15.0.22, not with 4.15.0.20

fossfreedom (fossfreedom) wrote :

This bug report has been marked as fix released. Please create a new bug report.

Run

    ubuntu-bug linux

Add the comment of which kernel works and that the current kernel does not

ZL (lzy7071) wrote :

I am on 4.15.0.22 using Nvidia 980. I initially encountered the same bug. But after upgrading to NVIDIA 390.59, I was able to boot up normally.

Harsh Gupta (harshgupta1992) wrote :

I have this issue with kernel 4.15.0.22

Harsh Gupta (harshgupta1992) wrote :

Update to comment#35: Upgrading to the latest nvidia drivers with 4.15.0.22 fixed it.

Mehman Jamalov (sensenku89) wrote :

Hi, I installed Ubuntu 18.04 x64 and it looks OK. then I added nvidia drivers ppa and installed latest driver for my GTX 1050 in my laptop. I did it via terminal "sudo apt install nvidia-driver-396" and it installed drivers. But after restart I get black screen. And aftr that I logged in with ALT+CTRL+F3. Then logged in with my usrername and typed "nvidia-smi" the result was good and it said I have installed 396 driver.

My laptop : MSI GP62 7RD
CPU: I7-7700hq
GPU: Nvidia GTX 1050/ intel HD graphics 630
Screens:
https://ibb.co/eHPAhy
https://ibb.co/cMH2vJ
https://ibb.co/mqrvFJ

Thanks a lot

I have the same problem and the Gnome 3 eats a lot of my CPU reducing the performance.

My machine:
Ubuntu 18.04
Vostro 3500
Intel Core i5 540m
NVidia GT-310m

Jack Howarth (jwhowarth) wrote :

I am seeing the same problem with current cosmic 18.10. The stock nouveau drivers work fine but using 'sudo ubuntu-drivers autoinstall' to install either the nvidia-390 or nvidia-396 drivers produces a black screen (backlighting completely off) after the ubuntu splash screen has been displayed on rebooting.

MacPro 2008
GPU: EVGA GTX 680 flashed with the Mac ROM images

Hi!

Had same issue. Fixed by removing from `/etc/default/grub` the `nomodeset` parameter from the `GRUB_CMDLINE_LINUX="nomodeset"`as to obtain:
`GRUB_CMDLINE_LINUX=""` then run `sudo update-grub` and reboot the laptop

bzoltan (agnu) wrote :

I also have this problem with prime Intel 4200M, Geforce GT 740M using the nvidia 390 driver, on 18.10 (cosmic).

Nouveau works, and the intel gpu also works even if I have the 390 driver installed (I used: sudo prime-select intel)

RAVITEJA KORADA (ravi003teja) wrote :

After restarting my laptop gets flickering and sometimes black or purple screen

To post a comment you must log in.